AnsweredAssumed Answered

Issues with LearningSampleGadget in lab

Question asked by dustin.peet14 on Jan 20, 2017
Latest reply on Jan 24, 2017 by dustin.peet14

Hello-

 

I've been working with CCX for awhile but have just recently started to brave the finesse gadget world.  I've got a lot of scripting background, so the JS and XML doesn't scare me, but admittedly it also isn't the specific language I have the most experience with.

 

I have a CCX 10.6 lab environment and I downloaded the LearningSampleGadget.  I worked through the pdf and built it up myself, placed it into an IIS server and updated the finesse layout to point to it.  After logging into Jabber as an agent it does draw the gadget but it fails to populate anything in the box (other then html for user data), and it also doesn't show the js buttons to go ready/not ready or to make a call.  After looking through the code, and positive that I missed something small in the syntax, I reverted the to _Final versions.  When I logged out of finesse and then back in, I'm still seeing the same errors in the Sample Gadget box on the home tab.

 

I turned on debugging in IE, and the first thing it complained about was that the .ClientLogger method was unspecified.  Ok, fine, I thought and I commented out all of the logging lines in the js, other than the variable declaration.  I saved the changes and uploaded to the IIS server, logged out/in to finesse and now I get an error that jQuery is undefined.  Seemed strange so I did a get on the finesse.js and jquery.min.js files and downloaded to view.  Both of the files look fine and are in their appropriate locations /desktop/assets/js/

 

I thought that maybe since it wasn't populating the gadget with at least the user data that something was wrong with the API in finesse so I downloaded postman and tried manual gets/puts and all attempts displayed and updated correctly.

 

I looked through code for another couple hours and I'm still in the same place 

 

Anyone else have this issue previously or have any ideas?  The code that I have is exactly what is on github for LearningSampleGadge 10.6 so I'll refrain from an attachment here.  I also tried to adjust the layout gadget call to include the full path to the xml on the IIS server and to simply leave as it is.  Neither config helped.  Oh, and I did reboot the servers (cucm and ccx) to no avail.

 

Thanks for the somewhat long read!

Outcomes