1 Reply Latest reply on Oct 28, 2016 4:13 AM by npateriy

    IOX sandbox learning lab deployment (console fetch failing)

    npateriy

      Hi,

       

      I am able to reach till last step of app deployment on sanbox based on learning lab. Cisco DevNet Learning Labs

       

      App show running but trying to access console returns:

       

      return :

      >>>ioxclient application console npateriyaapp

      Currently active profile :  default

      Command Name: application-console

      Console setup is complete..

      Running command : [ssh -p 2222 -i npateriyaapp.pem appconsole@10.10.10.123]

      SSH client is not present on the platform.

      Attempting to connect using native SSH implementation..., press Ctrl+C to exit

       

      Connecting to appconsole@10.10.10.123:2222 using pem file npateriyaapp.pem

      Error processing command :  dial tcp 10.10.10.123:2222: getsockopt: connection refused


      >> NeeleshP-ServelessDemo>>ioxclient app list

      Currently active profile :  default

      Command Name: application-list

      List of installed App :

      1. npateriyaapp --->    RUNNING

      2. npateriyaapp2 --->    RUNNING


      -----------------------


      I logged into iox caf and so following error in logs, not sure if this related:

       

      2016-10-28 03:21:39.880+0000: starting up

      PATH=/sbin:/usr/sbin:/bin:/usr/bin LIBVIRT_DEBUG=3 LIBVIRT_LOG_OUTPUTS=3:stderr /usr/lib/libvirt/libvirt_lxc --name npateriyaapp --console 25 --security=smack --handshake 28 --veth vnet1

      PATH=/bin:/sbin TERM=linux container=lxc-libvirt HOME=/ container_uuid=153908f2-a661-4394-b4d1-e3a3dc972f9f LIBVIRT_LXC_UUID=153908f2-a661-4394-b4d1-e3a3dc972f9f LIBVIRT_LXC_NAME=npateriyaapp /sbin/init

      2016-10-28 03:21:40.130+0000: 1: info : libvirt version: 1.2.15

      2016-10-28 03:21:40.130+0000: 1: warning : lxcContainerUnmountSubtree:615 : Failed to unmount '/.oldroot/var/volatile', trying to detach subtree '/.oldroot': Invalid argument

       

      I tried both uploading app using CLI as well as web interface, with same result.

       

      Any help? 

       

      Most likely by the time I get response sanbox lease might be expired, but any suggestion for next iteration appreciated.

       

      Thanks,

      Neelesh