0 Replies Latest reply on Jul 5, 2016 8:55 AM by babelawa

    regarding ir829 iox setup

    babelawa

      Hi Team,

       

       

       

      Some i tried setting up iox setup..

       

      but now i am unable to install and reach cartridges..

       

       

       

       

      sgbu-india-ucs2::/users/babelawa/ioxclient_linux_amd64:153> ioxclient profiles show

      Active Profile :  sand

      Profile Name :  sand

              Host IP:  11.1.1.102

              Host Port:  8443

              Auth Keys:  cm9vdDpjaXNjbzEyMw==

              Auth Token: 

              Api Prefix:  /api/v1/

              URL Scheme:  https

      sgbu-india-ucs2::/users/babelawa/ioxclient_linux_amd64:154>

      sgbu-india-ucs2::/users/babelawa/ioxclient_linux_amd64:154> ./ioxclient cartridge list python27_yocto.tar.gz

      Currently using profile :  sand

      Command Name: cartridge-list

      Error processing command. Server returned  404

      sgbu-india-ucs2::/users/babelawa/ioxclient_linux_amd64:155>

       

       

       

       

      I have testbed where trying to setup iox deployement apps.

       

      I am referring this file:///C:/Users/babelawa/Downloads/IR829%20PaaS%20and%20Container%20Style%20Applications%20Deployment%20Guide.pdf

       

      IR829 PaaS and Container Style Applications Deployment Guide.pdf

       

       

       

      But there are some issues related to configs

       

      i am able to setup guest os with dhcp.

       

      Here is details and configs:

       

       

       

      IR800#sh iox host list de

       

       

      IOX Server is running. Process ID: 265

      Count of hosts registered: 1

       

       

      Host registered:

      ===============

          IOX Server Address: FE80::76A2:E6FF:FEFD:7DEC; Port: 22222

       

       

          Link Local Address of Host: FE80::1FF:FE90:8B05

          IPV4 Address of Host:       192.168.1.6

          IPV6 Address of Host:       fe80::1ff:fe90:8b05

          Client Version:             0.4

          Session ID:                 4

          OS Nodename:                IR800-GOS-1

          Host Hardware Vendor:       Cisco Systems, Inc.

          Host Hardware Version:      1.0

          Host Card Type:             not implemented

          Host OS Version:            1.0.0.2

          OS status:                  RUNNING

       

       

          Interface Hardware Vendor:  None

          Interface Hardware Version: None

          Interface Card Type:        None

       

       

          Applications Registered:

          =======================

              Count of applications registered by this host: 0

       

       

      IR800#

       

      But i am not able to reach to or ping to guest os from our local server.

       

       

       

       

       

      IR800#sh run int gigabitEthernet 0

      Building configuration...

       

       

      Current configuration : 70 bytes

      !

      interface GigabitEthernet0

      ip address 11.1.1.43 255.255.255.0

      end

       

       

      IR800#

      IR800#

      IR800#

      IR800#sh run int gi

      IR800#sh run int gigabitEthernet 5

      Building configuration...

       

       

      Current configuration : 151 bytes

      !

      interface GigabitEthernet5

      ip address 192.168.1.1 255.255.255.0

      ip nat inside

      ip virtual-reassembly in

      duplex auto

      speed auto

      ipv6 enable

      end

       

       

      IR800#

      IR800#

      IR800#sh run | s nat

      ! No destination mac-address configured

      ip nat inside

      ip nat outside

      ip nat inside source list NAT_ACL interface GigabitEthernet0 overload

      ip nat inside source static tcp 192.168.1.6 8443 interface GigabitEthernet0 8443

      ip nat inside source static tcp 192.168.1.6 22 interface GigabitEthernet0 2222

      IR800#

      IR800#

      IR800#sh run | s access

      ip access-list standard NAT_ACL

      permit 192.168.0.0 0.0.255.255

      IR800#

      IR800#

      IR800#sh run | s route

      default-router 192.168.1.1

      ip route 0.0.0.0 0.0.0.0 10.78.106.129

      ip route 192.168.223.0 255.255.255.0 192.168.1.6

      IR800#

      IR800#

      IR800#sh run | s default

      default-router 192.168.1.1

      ip default-gateway 10.78.106.129

      IR800#

      IR800#

      IR800#~

       

      >

      sgbu-india-ucs2::/users/babelawa/ioxclient_linux_amd64:222>

      sgbu-india-ucs2::/users/babelawa/ioxclient_linux_amd64:222> ioxclient profiles show

      Active Profile :  ir

      Profile Name :  ir

              Host IP:  192.168.1.6

              Host Port:  8443

              Auth Keys:  cm9vdDpjaXNjbzEyMw==

              Auth Token:

              Api Prefix:

              URL Scheme:  https

      sgbu-india-ucs2::/users/babelawa/ioxclient_linux_amd64:223>

      sgbu-india-ucs2::/users/babelawa/ioxclient_linux_amd64:223>

      sgbu-india-ucs2::/users/babelawa/ioxclient_linux_amd64:223> ioxclient install cartridge python27_yocto.tar.gz

      Currently using profile :  ir

      Error processing command :  Get https://192.168.1.6:8443/api/v1/hosting/tokenservice: dial tcp 192.168.1.6:8443: i/o timeout

      sgbu-india-ucs2::/users/babelawa/ioxclient_linux_amd64:224>

       

       

      Could you please help me here in setting up IOX.

       

       

      Regards,

      Balappa