AnsweredAssumed Answered

Reverse Proxy Nginx with co-browse problem

Question asked by snetykkim on Feb 2, 2016
Latest reply on Feb 5, 2016 by huliving

I have got a working lab model for the RE Mobile.

Everything works fine on the internal network.

 

I have now included the Nginx Reverse Proxy and tried calling via the Internet using a web browser but there are issues with co-browse.

The call gets routed in to the Finesse Desktop.

When I click the co-browse on the Finesse Desktop, the customer can't see the requested alarm.

 

It only appears when I try it through a reverse proxy server.

Please advice me.

 

Below is my Nginx configration :

 

server {

                listen 80;

                #listen 8080;

                listen 443 ssl;

                listen 8443 ssl;

                server_name rem.domain.co.kr;

                ssl_certificate /etc/nginx/certificate.crt;

                ssl_certificate_key /etc/nginx/privateKey.key;

 

 

 

                location / {

  

                proxy_pass https://10.0.9.101:8443/assistsample/$request_uri;

               # root /usr/share/nginx/html;

               # index index.html index.htm;

                }

 

 

                #REQUIRED FOR CSDK SESSION REQUEST

                location /gateway/ {

                proxy_http_version 1.1;

                proxy_set_header Upgrade $http_upgrade;

                proxy_set_header Host $http_host;

                proxy_pass https://10.0.9.101:8443$request_uri;

 

                #REQUIRED TO ALLOW CROSS DOMAIN REQUESTS

                add_header 'Access-Control-Allow-Origin' "$http_origin";

                add_header 'Access-Control-Allow-Credentials' 'true';

                add_header 'Access-Control-Allow-Methods' 'GET, POST, PUT, DELETE, OPTIONS';

                add_header 'Access-Control-Allow-Headers' 'Accept,Authorization,Cache-Control,Content-Type,DNT,If-Modified-Since,Keep-Alive,Origin,User-Agent,X-Mx-   ReqToken,X-Requested-With';

                }

 

 

                #REQUIRED FOR EXPERT ASSIST SAMPLE APP

                location /assistsample/ {

                proxy_set_header Host $http_host;

                proxy_pass https://10.0.9.101:8443$request_uri;

                }

 

 

                #REQUIRED FOR EXPERT ASSIST SAMPLE APP

                location /expertassist/agent/ {

                proxy_set_header Host $http_host;

                proxy_pass https://10.0.9.101:8443$request_uri;

                }

 

 

                #REQUIRED FOR EXPERT ASSIST

                location /assistserver/ {

                proxy_set_header Host $http_host;

                proxy_pass https://10.0.9.101:8443$request_uri;

                }

}

Outcomes