3 Replies Latest reply on Oct 15, 2015 1:32 AM by reece.martin

    MediaSense Lab: AXL connection failed

    dubber_ops

      It used to work but the lab I created yesterday got following error:

      Screen Shot 2015-09-24 at 14.18.09.PNG

      I've created axluser on CUCM and assigned AXL API permission, also tested with curl its working

       

      ❯ curl -vk -u axluser -H "Content-type: text/xml;" -H "SOAPAction:CUCM:DB ver=10.5" -d @request.xml https://10.10.20.1:8443/axl/

      Enter host password for user 'axluser':

      *   Trying 10.10.20.1...

      * Connected to 10.10.20.1 (10.10.20.1) port 8443 (#0)

      * TLS 1.2 connection using TLS_DHE_RSA_WITH_AES_128_CBC_SHA

      * Server certificate: hq-cucm-pub.abc.inc

      * Server auth using Basic with user 'axluser'

      > POST /axl/ HTTP/1.1

      > Host: 10.10.20.1:8443

      > Authorization: Basic YXhsdXNlcjpjaXNjb3BzZHQ=

      > User-Agent: curl/7.43.0

      > Accept: */*

      > Content-type: text/xml;

      > SOAPAction:CUCM:DB ver=10.5

      > Content-Length: 336

      >

      * upload completely sent off: 336 out of 336 bytes

      < HTTP/1.1 200 OK

      < Set-Cookie: JSESSIONIDSSO=CC5280022D25C82BC80D83FE667E470B; Path=/; Secure; HttpOnly

      < Set-Cookie: JSESSIONID=9C3F9BB15E6B4B8BFBC61BA3DDCB9A69; Path=/axl/; Secure; HttpOnly

      < X-Frame-Options: SAMEORIGIN

      < Content-Type: text/xml;charset=UTF-8

      < Content-Length: 1081

      < Date: Thu, 24 Sep 2015 03:59:11 GMT

      < Server:

      <

      * Connection #0 to host 10.10.20.1 left intact

      <?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Body><ns:executeSQLQueryResponse xmlns:ns="http://www.cisco.com/AXL/API/10.5"><return><row><name>Sample Device Template with TAG usage examples</name></row><row><name>Auto-registration Template</name></row><row><name>CSFUSER001</name></row><row><name>CSFUSER002</name></row><row><name>CSFUSER003</name></row><row><name>CSFUSER004</name></row><row><name>CSFUSER005</name></row><row><name>TABUSER006</name></row><row><name>TABUSER007</name></row><row><name>TABUSER008</name></row><row><name>TABUSER009</name></row><row><name>TABUSER010</name></row><row><name>BOTUSER011</name></row><row><name>BOTUSER012</name></row><row><name>BOTUSER013</name></row><row><name>BOTUSER014</name></row><row><name>BOTUSER015</name></row><row><name>TCTUSER016</name></row><row><name>TCTUSER017</name></row><row><name>TCTUSER018</name></row><row><name>TCTUSER019</name></row><row><name>TCTUSER020</name></row></return></ns:executeSQLQueryResponse></soapenv:Body></soapenv:Envelope>

       

      I've also got ssl_error_weak_server_ephemeral_dh_key error when accessing MediaSense admin page but I'm not sure that's related.

       

      Any help would be appreciated.

       

      Cheers,

      Bruce