AnsweredAssumed Answered

OPEN_REQ giving FAILURE_CONF, CTI protocol versioning

Question asked by urszula.dziurzynska on Apr 29, 2015
Latest reply on May 8, 2015 by vdheenad

Hello,

 

1. I have a problem with sendng OPEN_REQ

 

I get in response error: "com.cisco.Ged188.CRACTIInvalidMessageException: readMsg: Handled InvalidObjectException: Invalid definition for message of type: OPEN_REQ; nested exception is: no definition for message field of type: unknown tag: 0"

 

How can I know what is wrong?

 

2. I am also not sure about protocol CTI versioning. I've read documentation "Cisco Unified Contact Center Express CTI Protocol Developer Guide Release 10.5(1)". I can see in this doc  that some fields are supported only with specific protocol version (e.g.OPEN_CONF and field: FltPeripheralID for version 14 and later only).

But how can I know what version should I use? My server version is 10.6.1, my docs fo CTI (above) is 10.5.1 but version needs to be between 10 - 20.

 

I use version 14, but tried also numbers from 10 to 20 and in 1. still have the same error.

 

Urszula

Outcomes