AnsweredAssumed Answered

QoS Error: Sup2T, IOS15.1SY,6506-E, LAN Tengig Ethernet Module: Throws errors when QoS policy applied

Question asked by S.Srivas on Jan 21, 2015
Latest reply on Jan 21, 2015 by kelli.glass

QoS Erroring:

Please advice on the following.

 

Sup2T, IOS15.1SY,6506-E, LAN Ethernet Module:

Throws errors when QoS policy applied, (even at 5% total traffic)

No errors when QoS not applied, (Testing with Xena Tester).

 

Test indicates error on received end, when QoS applied and no errors when QoS not applied to Tengig interfaces.

 

The following is the relevant config:

############# No errors when service-policy is not applied as below##########
WAH-CE-6506E-02#
!
interface TenGigabitEthernet2/1
description 8/0-Xena Test Source
switchport
switchport trunk allowed vlan 1,112,201-209
switchport mode trunk
mtu 9216
platform qos vlan-based
auto qos voip trust
no cdp enable
!
interface TenGigabitEthernet1/5
description 8/1-Xena Test Destination
description CE to PE
switchport
switchport mode trunk
switchport nonegotiate
mtu 9216
platform qos vlan-based
no cdp enable

############# Errors when QoS applied. service-policy IN on 2/1 is applied as below##########
WAH-CE-6506E-02#
!
interface TenGigabitEthernet2/1
description 8/0-Xena Test Source
switchport
switchport trunk allowed vlan 1,112,201-209
switchport mode trunk
mtu 9216
platform qos vlan-based
auto qos voip trust
no cdp enable
service-policy type lan-queuing input IN5-6506E
!!!service-policy type lan-queuing output OUT5-6500E

!
interface TenGigabitEthernet1/5
description 8/1-Xena Test Destination
description CE to PE
switchport
switchport mode trunk
switchport nonegotiate
mtu 9216
platform qos vlan-based
no cdp enable
service-policy type lan-queuing input IN5-6506E
service-policy type lan-queuing output OUT5-6500E
end

################
policy-map type lan-queuing IN5-6506E
  class Q5-PREMIUM-RT
    bandwidth percent 30
  class Q5-MANAGEMENT-CTL
    bandwidth percent 1
  class Q5-ENHANCED1-CONF
    bandwidth percent 10
  class Q5-ENHANCED2-STR
    bandwidth percent 2
  class Q5-ENHANCED3-TDA
    bandwidth percent 10
  class Q5-STANDARD1-BLK
    bandwidth percent 5
  class class-default
!
policy-map type lan-queuing OUT2-6500E
<snip>

////////////

sh ver

Cisco IOS Software, s2t54 Software (s2t54-ADVENTERPRISEK9-M), Version 15.1(1)SY1, RELEASE SOFTWARE (fc5)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2013 by Cisco Systems, Inc.

Compiled Wed 01-May-13 12:43 by prod_rel_team

Outcomes