AnsweredAssumed Answered

IIS Reverse Proxy for finesse https URL

Question asked by arulselvanj on Jun 17, 2014
Latest reply on Jun 17, 2014 by dlender

Hi,

 

We tried reverse proxy for non gadget finesse application, working good with http but while we trying https URL getting below error.

 

HTTP Error 502.3 - Bad Gateway

A security error occurred

 

Unable to bypass the response, it throwing security error with finesse SSL certification.

 

Our rule for Reverse Proxy in web.config:

---------------------------------------------------------------

<rewrite>

            <rules>

                <rule name="Route the requests for api" stopProcessing="true">

                    <match url="^finesse/(.*)" />

                    <conditions>

                        <add input="{CACHE_URL}" pattern="^(https?)://" />

                    </conditions>

                    <action type="Rewrite" url="{C:1}://172.16.6.186/finesse/{R:1}" />

                   

                    <serverVariables>

                        <set name="HTTP_ACCEPT_ENCODING" value="" />

                    </serverVariables>

                </rule>

                 <rule name="Route the requests for bosh bind" stopProcessing="true">

                    <match url="^http-bind(.*)" />

                    <conditions>

                        <add input="{CACHE_URL}" pattern="^(https?)://" />

                    </conditions>

                    <action type="Rewrite" url="{C:1}://172.16.6.186:7071/http-bind/{R:1}" />

                    <serverVariables>

                        <set name="HTTP_ACCEPT_ENCODING" value="" />

                    </serverVariables>

                </rule>

            </rules>

      </rewrite>

 

Reference Link  :http://blogs.iis.net/carlosag/archive/2010/04/01/setting-up-a-reverse-proxy-using-iis-url-rewrite-and-arr.aspx

 

                        http://www.formortals.com/fix-for-0x80072f0c-error-502-3-bad-gateway-for-reverse-proxy-to-ssl-with-iis/

 

Thanks,

Arul Selvan

Outcomes