AnsweredAssumed Answered

QEMU Domain error

Question asked by gregoryiiams on May 11, 2015
Latest reply on May 13, 2015 by szhang2

Gentlemen,

 

First I want to say thanks for letting me in!

 

So, I've gotten my IOx App Manager running on my 819.  I've went through the cookbook, and used the simple factorial example, just working on learning the toolchain.

 

So, I've used the template yaml and xml file, edited them to change names.  Then I packaged my OVA.

 

OVA deploys successfully, but upon start, I get the following in the iox log:

May 10 16:23:52 P1020RDB local0.info CAF-stdout/stderr: libvirt: QEMU Driver error : Domain not found: no domain with matching name 'testapp'

May 10 16:24:46 P1020RDB local0.info [Thread-11] [vmanclient.py:353] Associated VPG 'VirtualPortGroup1' with VM 'testapp'.

May 10 16:24:50 P1020RDB local0.err [VmanMessageHandler] [vmanclient.py:798] Provision callback was unsuccessful for VM 'testapp'.

May 10 16:24:51 P1020RDB local0.info [Thread-11] [vmanclient.py:389] Deactivated VM 'testapp'.

May 10 16:24:51 P1020RDB local0.err [Thread-11] [vmanclient.py:383] Could not activate VM 'testapp'.

May 10 16:24:51 P1020RDB local0.info [Thread-11] [controller.py:1365] Connector 'testapp' state change: DEPLOYED-->RUNNING

May 10 16:24:51 P1020RDB local0.info [Thread-11] [controller.py:1331] Connector 'testapp' successfully started.

May 10 16:24:51 P1020RDB local0.info [CP Server Thread-6] [controller.py:1365] Connector 'testapp' state change: RUNNING-->STOPPED

May 10 16:24:52 P1020RDB local0.err [CP Server Thread-6] [vman.py:256] Error in connect to Guest Agent testapp:Domain not found: no domain with matching name 'testapp'

 

 

Is there an xml field I'm missing somewhere or...?

 

Thanks!

Outcomes