UCS-E slot/0 interface in VRF ?

Version 1
    This document was generated from CDN thread

    Created by: Patrick Pless on 28-02-2013 02:20:55 PM
    I'm attempting to configure my CIMC access through the PCIe slot/0 backplane connection.  The interface I'm pointing the unnumbered statement back to on the 3925 host device is a sub-interface in a VRF.  According to the user guides, I've configured "shared lom console" and then attempted to add a route back to the CIMC through the "ucse slot/0" interface.  Unfortunately, it seems you cannot specify the ucse slot/0 interface in a route statement when using a VRF.
    3925(config)#ip route vrf L3 10.94.0.8 255.255.255.255 ucse2/0
    % For VPN or topology routes, must specify a next hop IP address if not a point-to-point interface
    And you can't point the route to the sub-interface IP address...
    RIAB-3925(config)#ip route vrf L3 10.94.0.8 255.255.255.255 10.94.0.1
    %Invalid next hop address (it's this router)



    I configured using the external "M" management port and have the traffic loop outside of the UCS-E, through the rest of my L2 topology, and back to the sub-interface on the 3925, but this is less than ideal since it burns a port on the L2 switch the M port is connected to (customer wants to purchase the smallest L2 switch required, so this is a problem).
    Is this a limitation of the code at this time or is there another method to configure this?
     
    Thanks,
    Patrick
     
    IOS Config snippit below:
    interface ucse2/0
     ip vrf forwarding L3
     ip unnumbered GigabitEthernet0/2.751
     imc ip address 10.94.0.8 255.255.255.192 default-gateway 10.94.0.1
     imc access-port shared-lom console
    !
    interface ucse2/1
     description Internal switch interface connected to Service Module
     switchport mode trunk
     ip vrf forwarding L3
     no ip address
    !
    interface GigabitEthernet0/2.751
     encapsulation dot1Q 751
     ip vrf forwarding L3
     ip address 10.94.0.1 255.255.255.192
    end

    Subject: RE: UCS-E slot/0 interface in VRF ?
    Replied by: Daniel Miller on 28-02-2013 04:03:43 PM
    Hi Patrick,
    Does it work if you use a different interface instead of ucse?
    Thanks,
    Daniel

    Subject: RE: UCS-E slot/0 interface in VRF ?
    Replied by: Patrick Pless on 28-02-2013 04:09:14 PM
    Daniel Miller:
    Hi Patrick,
    Does it work if you use a different interface instead of ucse?
    Thanks,
    Daniel


    Hi Daniel,
    I'm assuming you mean the route command.  No, it does not accept an interface name of any type.
     
    Thanks,
    Patrick

    Subject: Re: New Message from Patrick Pless in Unified Computing System E-Series Ser
    Replied by: Tuong Au on 01-03-2013 02:12:19 PM
    Hi Patrick,

    Thanks for the update.

    Thanks,
    Tom

    From: Cisco Developer Community Forums <cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com>>
    Reply-To: "cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com>" <cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com>>
    Date: Friday, March 1, 2013 12:04 PM
    To: "cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com>" <cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com>>
    Subject: New Message from Patrick Pless in Unified Computing System E-Series Servers (UCSE) - Technical Questions: RE: New Message from Tuong Au in Unified Computing System E-Series Servers

    Patrick Pless has created a new message in the forum "Technical Questions": -------------------------------------------------------------- Hi Tuong, Unfortunately this does not work for us. In this customer scenario, the CICM address must be in the same network as the Gig interface, so we cannot change it to a non-10.94.0.0 address. And we can’t assign another address to the UCSE2/0 interface in the same network.

    I was able to make this work by bridging the UCSE2/0 interface together with the gig 0/2.751 interface and configuring the 10.94.0.1 IP on the BVI interface. I am now able to access the CIMC and was able to install ESX. This may be somewhat of a hack but it seems to work.

    Thanks,
    Patrick


    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Friday, March 01, 2013 2:42 PM
    To: cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com>
    Subject: New Message from Tuong Au in Unified Computing System E-Series Servers (UCSE) - Technical Questions: Re: New Message from Daniel Miller in Unified Computing System E-Series Ser

    Tuong Au has created a new message in the forum "Technical Questions": -------------------------------------------------------------- Hi Patrick,

    I also see the same issue with SM-SRE product so not sure if this configuration is supported in this manner. As a work around would below work? Remove 'ip unnumbered' config from ucse 2/0 and assign a static ip instead. G0/0.751 and UCSE 2/0 would still be in vrf L3. If you need to reach CIMC from outside of this router then add vrf route pointing to GigabitEthernet0/0.751 as the gateway.

    c3925e-2003#show run int ucse 2/0
    Building configuration...

    Current configuration : 175 bytes
    !
    interface ucse2/0
    ip vrf forwarding L3
    ip address 11.0.0.1 255.0.0.0
    imc ip address 11.0.0.2 255.0.0.0 default-gateway 11.0.0.1
    imc access-port shared-lom console
    end

    c3925e-2003#show run int GigabitEthernet0/0.751
    Building configuration...

    Current configuration : 125 bytes
    !
    interface GigabitEthernet0/0.751
    encapsulation dot1Q 751
    ip vrf forwarding L3
    ip address 10.94.0.1 255.255.255.192
    end

    c3925e-2003#ping vrf L3 11.0.0.2
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 11.0.0.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
    c3925e-2003#show ip route vrf L3

    Routing Table: L3
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
    a - application route
    + - replicated route, % - next hop override

    Gateway of last resort is not set

    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 10.94.0.0/26 is directly connected, GigabitEthernet0/0.751
    L 10.94.0.1/32 is directly connected, GigabitEthernet0/0.751
    11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 11.0.0.0/8 is directly connected, ucse2/0
    L 11.0.0.1/32 is directly connected, ucse2/0
    c3925e-2003#

    Thanks,
    Tom

    From: Cisco Developer Community Forums <cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com><mailto:cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com%3cmailto:cdicuser@developer.cisco.com>>>
    Reply-To: "cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com><mailto:cdicuser@developer.cisco.com><mailto:cdicuser@developer.cisco.com%3cmailto:cdicuser@developer.cisco.com%3e>" <cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com><mailto:cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com%3cmailto:cdicuser@developer.cisco.com>>>
    Date: Thursday, February 28, 2013 2:03 PM
    To: "cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com><mailto:cdicuser@developer.cisco.com><mailto:cdicuser@developer.cisco.com%3cmailto:cdicuser@developer.cisco.com%3e>" <cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com><mailto:cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com%3cmailto:cdicuser@developer.cisco.com>>>
    Subject: New Message from Daniel Miller in Unified Computing System E-Series Servers (UCSE) - Technical Questions: RE: UCS-E slot/0 interface in VRF ?

    Daniel Miller has created a new message in the forum "Technical Questions": -------------------------------------------------------------- Hi Patrick,
    Does it work if you use a different interface instead of ucse?
    Thanks,
    Daniel
    --
    To respond to this post, please click the following link: or simply reply to this email.
    --
    To respond to this post, please click the following link: or simply reply to this email.
    --
    To respond to this post, please click the following link: or simply reply to this email.

    Subject: Re: New Message from Daniel Miller in Unified Computing System E-Series Ser
    Replied by: Tuong Au on 01-03-2013 01:42:24 PM
    Hi Patrick,

    I also see the same issue with SM-SRE product so not sure if this configuration is supported in this manner.  As a work around would below work?  Remove 'ip unnumbered' config from ucse 2/0 and assign a static ip instead.  G0/0.751 and UCSE 2/0 would still be in vrf L3.  If you need to reach CIMC from outside of this router then add vrf route pointing to GigabitEthernet0/0.751 as the gateway.

    c3925e-2003#show run int ucse 2/0
    Building configuration...

    Current configuration : 175 bytes
    !
    interface ucse2/0
    ip vrf forwarding L3
    ip address 11.0.0.1 255.0.0.0
    imc ip address 11.0.0.2 255.0.0.0 default-gateway 11.0.0.1
    imc access-port shared-lom console
    end

    c3925e-2003#show run int GigabitEthernet0/0.751
    Building configuration...

    Current configuration : 125 bytes
    !
    interface GigabitEthernet0/0.751
    encapsulation dot1Q 751
    ip vrf forwarding L3
    ip address 10.94.0.1 255.255.255.192
    end

    c3925e-2003#ping vrf L3 11.0.0.2
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 11.0.0.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
    c3925e-2003#show ip route vrf L3

    Routing Table: L3
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
           a - application route
           + - replicated route, % - next hop override

    Gateway of last resort is not set

          10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C        10.94.0.0/26 is directly connected, GigabitEthernet0/0.751
    L        10.94.0.1/32 is directly connected, GigabitEthernet0/0.751
          11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C        11.0.0.0/8 is directly connected, ucse2/0
    L        11.0.0.1/32 is directly connected, ucse2/0
    c3925e-2003#

    Thanks,
    Tom

    From: Cisco Developer Community Forums <cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com>>
    Reply-To: "cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com>" <cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com>>
    Date: Thursday, February 28, 2013 2:03 PM
    To: "cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com>" <cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com>>
    Subject: New Message from Daniel Miller in Unified Computing System E-Series Servers (UCSE) - Technical Questions: RE: UCS-E slot/0 interface in VRF ?

    Daniel Miller has created a new message in the forum "Technical Questions": -------------------------------------------------------------- Hi Patrick,
    Does it work if you use a different interface instead of ucse?
    Thanks,
    Daniel
    --
    To respond to this post, please click the following link: or simply reply to this email.

    Subject: RE: New Message from Tuong Au in Unified Computing System E-Series Servers
    Replied by: Patrick Pless on 01-03-2013 02:04:24 PM
    Hi Tuong,  Unfortunately this does not work for us.  In this customer scenario, the CICM address must be in the same network as the Gig interface, so we cannot change it to a non-10.94.0.0 address.  And we can’t assign another address to the UCSE2/0 interface in the same network.

    I was able to make this work by bridging the UCSE2/0 interface together with the gig 0/2.751 interface and configuring the 10.94.0.1 IP on the BVI interface.   I am now able to access the CIMC and was able to install ESX.  This may be somewhat of a hack but it seems to work.

    Thanks,
    Patrick


    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Friday, March 01, 2013 2:42 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Tuong Au in Unified Computing System E-Series Servers (UCSE) - Technical Questions: Re: New Message from Daniel Miller in Unified Computing System E-Series Ser

    Tuong Au has created a new message in the forum "Technical Questions": -------------------------------------------------------------- Hi Patrick,

    I also see the same issue with SM-SRE product so not sure if this configuration is supported in this manner. As a work around would below work? Remove 'ip unnumbered' config from ucse 2/0 and assign a static ip instead. G0/0.751 and UCSE 2/0 would still be in vrf L3. If you need to reach CIMC from outside of this router then add vrf route pointing to GigabitEthernet0/0.751 as the gateway.

    c3925e-2003#show run int ucse 2/0
    Building configuration...

    Current configuration : 175 bytes
    !
    interface ucse2/0
    ip vrf forwarding L3
    ip address 11.0.0.1 255.0.0.0
    imc ip address 11.0.0.2 255.0.0.0 default-gateway 11.0.0.1
    imc access-port shared-lom console
    end

    c3925e-2003#show run int GigabitEthernet0/0.751
    Building configuration...

    Current configuration : 125 bytes
    !
    interface GigabitEthernet0/0.751
    encapsulation dot1Q 751
    ip vrf forwarding L3
    ip address 10.94.0.1 255.255.255.192
    end

    c3925e-2003#ping vrf L3 11.0.0.2
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 11.0.0.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
    c3925e-2003#show ip route vrf L3

    Routing Table: L3
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
    a - application route
    + - replicated route, % - next hop override

    Gateway of last resort is not set

    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 10.94.0.0/26 is directly connected, GigabitEthernet0/0.751
    L 10.94.0.1/32 is directly connected, GigabitEthernet0/0.751
    11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 11.0.0.0/8 is directly connected, ucse2/0
    L 11.0.0.1/32 is directly connected, ucse2/0
    c3925e-2003#

    Thanks,
    Tom

    From: Cisco Developer Community Forums <cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com%3cmailto:cdicuser@developer.cisco.com>>>
    Reply-To: "cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com><mailto:cdicuser@developer.cisco.com%3cmailto:cdicuser@developer.cisco.com%3e>" <cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com%3cmailto:cdicuser@developer.cisco.com>>>
    Date: Thursday, February 28, 2013 2:03 PM
    To: "cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com><mailto:cdicuser@developer.cisco.com%3cmailto:cdicuser@developer.cisco.com%3e>" <cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com%3cmailto:cdicuser@developer.cisco.com>>>
    Subject: New Message from Daniel Miller in Unified Computing System E-Series Servers (UCSE) - Technical Questions: RE: UCS-E slot/0 interface in VRF ?

    Daniel Miller has created a new message in the forum "Technical Questions": -------------------------------------------------------------- Hi Patrick,
    Does it work if you use a different interface instead of ucse?
    Thanks,
    Daniel
    --
    To respond to this post, please click the following link: or simply reply to this email.
    --
    To respond to this post, please click the following link: or simply reply to this email.