CSS removeMember in AXL for CUCM 9.0 doesn't work correct?

Version 1
    This document was generated from CDN thread

    Created by: Michael Kail on 14-02-2013 07:34:22 AM
    Hi everybody,

    i am having a problem with AXL version 9.0 and CUCM 9.0 when updating the route partitions of a calling search space. Adding partitions with addMembers works fine but removing partitions with removeMember does not update sortorder in the database table CallingSearchSpaceMember.
    Has anybody the same experiences/problems?
    Just to be sure, when using removeMembers you do only add the name and the index of the route partition you want to remove?

    After all, the tag field members, which worked the last AXL Version doesn't work anymore :-(

    Thanks for your help!
     

    Subject: RE: CSS removeMember in AXL for CUCM 9.0 doesn't work correct?
    Replied by: David Staudt on 14-02-2013 05:32:05 PM
    I can confirm the behaviour.  Also it appears if you remove a member in the UCM admin the sort order numbers get re-ordered, so there is variance there.

    Theoretically, the (functional) order of the members is still correct, there's just a 'hole' in the series.  Does the possibility of a 'missing' sort order value cause a problem in  your app that you can't work around?

    Can you clarify your last comment re 'tag field members' not working..?

    Subject: RE: CSS removeMember in AXL for CUCM 9.0 doesn't work correct?
    Replied by: Michael Kail on 18-02-2013 03:18:43 AM
    Theoretically it works. Until you want to delete another partition or add a new partition. As the series has a hole you have to check what holes are there to find the correct index for adding or removing a partition. 
    There is also another question: How can you change the order of the partitions? In former version there was the "member" tag (which is now replaced by removeMemebers and addMembers). But know you have to change the series with direct sql updates or delete and add requests.
     
     

    Subject: RE: CSS removeMember in AXL for CUCM 9.0 doesn't work correct?
    Replied by: David Staudt on 18-02-2013 10:38:43 AM
    If you need to do more than add or remove a single route partition you can still use <members> - this works for me on my 9.0 UCM:
    <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns="http://www.cisco.com/AXL/API/9.0">
       <soapenv:Header/>
       <soapenv:Body>
          <ns:updateCss sequence="1">
             <name>testCss</name>
                   <members>
                      <member>
                         <routePartitionName>testPartitionA</routePartitionName>
                         <index>1</index>
                      </member>
                      <member>
                         <routePartitionName>testPartitionB</routePartitionName>
                         <index>3</index>
                         </member>
                      <member>
                         <routePartitionName>testPartitionC</routePartitionName>
                         <index>2</index>
                         </member>
                   </members>
          </ns:updateCss>
       </soapenv:Body>
    </soapenv:Envelope>