Sending empty (no voice) message

Version 1
    This document was generated from CDN thread

    Created by: Ryan Ash on 19-11-2012 02:52:27 PM
    I am trying to send a voice message and receiving an error. version=8.5.  I am using perl and LWP but essentially generic HTTP POST like anyone else. 
    ERROR:
    <ErrorDetails><errors><code>MESSAGE_ERROR</code><message>did not receive two body parts (message, recipients): part count=1</message></errors></ErrorDetails>
     400 Bad Request

    $VAR1 = bless( {
                     '_content' => '--boundary_foo
    Content-Type: application/xml
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?><Message><Subject>my subject</Subject> <ArrivalTime>0</ArrivalTime><FromSub>false</FromSub></Message>
    --boundary_foo
    Content-Type: application/xml
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?><Recipients><Recipient><Type>TO</Type><Address><ObjectId>"fa8c7df9-b216-45d4-9058-3ab7bd50633d</ObjectId></Address></Recipient></Recipients>
    --boundary_foo
    ',
                     '_uri' => bless( do{\(my $o = 'https://MYSERVER:8443/vmrest/messages?userobjectid=fa8c7df9-b216-45d4-9058-3ab7bd50633d')}, 'URI::https' ),
                     '_headers' => bless( {
                                            'content-type' => 'multipart/mixed;boundary=boundary_foo',
                                            'authorization' => 'Basic Y2NhZG1pbjpzdGF0ZWZhcm1AMTIz'
                                          }, 'HTTP::Headers' ),
                     '_method' => 'POST'
                   }, 'HTTP::Request' );