multidirectory.asp from SDK doesn't work for 7937

Version 1
    This document was generated from CDN thread

    Created by: Hyoung-Kyu Min on 06-02-2012 12:16:34 PM
    Hi Forum members,
     
    We have implemented "multidirectory.asp" from IPPS SDK for multiple AD integration and it works for 7945 and 7965 phone models.
     
    However, when we test it on 7937 phone model, we are not getting query results for first and last name lookup although we can the query result for direcotry lookup.
     
    I would like to see if there's anyone who had similar experience with potential resolution.
     
    Your feedback is greatly appreciated.
     
    Thanks,
    David Min

    Subject: RE: multidirectory.asp from SDK doesn't work for 7937
    Replied by: Frank Wakelin on 06-02-2012 01:15:20 PM
    I found the exact same thing with the 7937 - I had to modify the script a bit to deal with the empty parameters submitted by the phone.

    Subject: RE: multidirectory.asp from SDK doesn't work for 7937
    Replied by: Frank Wakelin on 06-02-2012 01:15:20 PM
    I found the exact same thing with the 7937 - I had to modify the script a bit to deal with the empty parameters submitted by the phone.

    Subject: RE: multidirectory.asp from SDK doesn't work for 7937
    Replied by: David Staudt on 06-02-2012 12:42:49 PM
    As always, please confirm that the 7937 is running the latest available firmware version.
     
    Note: code samples provided in the SDK are intended for illustrative/training use, may not work with all versions of UCM or phone models/firmware, should NOT be used in production environments and are not supported in such.  If you have questions or problems in basic developer-oriented exploration of the samples we are happy to help, but please be prepared to provide detailed code-level questions/observations. 
     
    This sounds familiar to a situation that has arisen a few times previously, where some phones submit empty URL paramters as
     
    http://myserver/myapp.jsp?param1=&param2=somedata
     
    and some phones obmit sending empty URL parameters as:
     
    http://myserver/myapp.jsp?param2=somedata
     
    You may need to modify your server-side script to handle both situations.
     
    If that's not it, feel free to attach working vs. working network packet captures (Wireshark is commonly used) of the HTTP traffic.
     
     

    Subject: RE: multidirectory.asp from SDK doesn't work for 7937
    Replied by: Marc Stillman on 23-02-2012 09:25:17 AM
    What modifications did you do. We are having the same issue here