No response at all from AXL requests on V7 or V8

Version 1

    Subject: RE: No response at all from AXL requests on V7 or V8
    Replied by: Gordon Ross on 01-02-2012 05:57:56 AM
    You appear to be missing the "SOAPAction" HTTP header.

    Look at the "AXL Versioning Support" section in the XML Developer Guide.

    GTG
    This document was generated from CDN thread

    Created by: Paul McGuinness on 01-02-2012 05:34:05 AM
    Hi All,
     
    I'm trying to do a simple AXL request that works in V6, but returns nothing (no error, empty response) in V7/V8
     
    It doesn't even throw an error if you give it the wrong credentials....
     
    Does anyone have a AXL 'test' tool I could use, then I could check whats happening with WireShark or something similar....
     
    Cheers,
     
    Paul
     
     
    This is the request:-
     
     
    <SOAP-ENV:Envelope xmlns:SOAP-ENV='http://schemas.xmlsoap.org/soap/envelope/' xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance' xmlns:xsd='http://www.w3.org/2001/XMLSchema'>
    <SOAP-ENV:Body>
    <axl:getCCMVersion xmlns:axl='http://www.cisco.com/AXL/1.0' sequence='1'>
    <searchString>%</searchString>
    </axl:getCCMVersion>
    </SOAP-ENV:Body>
    </SOAP-ENV:Envelope>
     
    Here is the code (VBScript/VB6 for simplicity)
     
     
     
     
            ' Create an xmlhttp object:
            Dim xml As New ServerXMLHTTP60
           
           
    104     seqID = seqID + 1

    106     xml.setOption 2, SXH_SERVER_CERT_IGNORE_ALL_SERVER_ERRORS
    108     xml.open "POST", "https://192.168.1.156:8443/axl/", False, "ccmuser","ccmpass"
     
           'Add Proper Headers
    110     a = EncodeBase64("ccmuser" & ":" & "ccmpass")       <-- this becomes:    QQBYAEwAdQBzAGUAcgA6AEEAWABMAHUAcwBlAHIA
    112     xml.setRequestHeader "Authorization", "Basic " & a
    114     xml.setRequestHeader "Content-type", "text/xml"
    118     xml.setRequestHeader "POST", "8443/axl"
    120     xml.setRequestHeader "Accept", "text/xml"

            ' Actually Sends the request and returns the data:

            reqStr = "<SOAP-ENV:Envelope xmlns:SOAP-ENV='http://schemas.xmlsoap.org/soap/envelope/' xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance' xmlns:xsd='http://www.w3.org/2001/XMLSchema'><SOAP-ENV:Body><axl:getCCMVersion xmlns:axl='http://www.cisco.com/AXL/1.0' sequence='1'><searchString>%</searchString></axl:getCCMVersion></SOAP-ENV:Body></SOAP-ENV:Envelope>"


    170     xml.setRequestHeader "Content-length", CStr(Len(reqStr))
    172     xml.send reqStr

    174     getSoapRequest = xml.responseText             <---- The response here is always empty
    176     Set xml = Nothing

    Subject: RE: No response at all from AXL requests on V7 or V8
    Replied by: Paul McGuinness on 01-02-2012 08:32:21 AM
    You appear to be missing the "SOAPAction" HTTP header.

    Look at the "AXL Versioning Support" section in the XML Developer Guide.

    GTG


     
    Thanks for the quick reply - I did, but there is no mention of SOAPAction for requests like:-
     
    getCCMVersion
     
    When I look through the AXLAPO.wdsl, I found this definition

     
       
     1<operation name="getCCMVersion">
     2      <soap:operation soapAction="CUCM:DB ver=8.0 getCCMVersion" style="document"/>
     3      <input>
     4        <soap:body use="literal"/>
     5      </input>
     6      <output>
     7        <soap:body use="literal"/>
     8      </output>
     9    </operation>



     
    So added

    1xml.setRequestHeader "soapAction", "CUCM:DB ver=8.0 getCCMVersion"



     
     
    Still no error, and no response.

    Subject: RE: No response at all from AXL requests on V7 or V8
    Replied by: Paul McGuinness on 01-02-2012 10:19:30 AM
    SOLVED!


    My Encode64 function wasn't working... it would have been nice for something (possibly in the MSXML handler) to complain about bad credentials though LOL

    Subject: RES: New Message from Paul McGuinness in Administration XML (AXL) - Adminis
    Replied by: Victor Castro on 01-02-2012 11:00:41 AM
    Hi All,

    How can I cancel my account or stop to receive at this forum, please?

    Thank very much.

    Víctor Castro

    Att,
    Víctor Castro
    Desenvolvimento
    Wittel

    ¿Esta mensagem é endereçada exclusivamente à(s) pessoa(s) e/ou instituições acima indicadas e pode conter informações confidenciais, particulares ou privilegiadas. O uso dessas informações por pessoas não autorizadas está sujeito às penas da lei."
    "This message is intended only for the named person's and/or entity's use and may contain confidential, proprietary or legally privileged information. The misuse of the information contained herein is subject to legal penalties."

    De: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Enviada em: quarta-feira, 1 de fevereiro de 2012 13:20
    Para: cdicuser@developer.cisco.com
    Assunto: New Message from Paul McGuinness in Administration XML (AXL) - Administration XML Questions: RE: No response at all from AXL requests on V7 or V8

    Paul McGuinness has created a new message in the forum "Administration XML Questions":

    --------------------------------------------------------------
    SOLVED!


    My Encode64 function wasn't working... it would have been nice for something (possibly in the MSXML handler) to complain about bad credentials though LOL
    --
    To respond to this post, please click the following link:

    <http://developer.cisco.com/web/axl/forums/-/message_boards/view_message/5089041>

    or simply reply to this email.