uccx set xml data to variable

Version 1
    This document was generated from CDN thread

    Created by: Chris Byington on 26-01-2012 11:19:42 AM
    I am trying to parse an xml page and set one of the values to a variable. The variable keeps getting set to null.
     
    This how the page displays in firefox
     
    <CustomerSearchResult><AccountNumber>2110003737</AccountNumber><ResultCount>1</ResultCount><Culture>en-MY</Culture><Script>BadNumber</Script><NumEnrollments>3</NumEnrollments><ActiveStatusID>2</ActiveStatusID><ExecStatusID>2</ExecStatusID><EnrollerCustomerID>2110003005</EnrollerCustomerID><PresenterCustomerID>2110003009</PresenterCustomerID><LastDirectorAdvDate xsi:nil="true"/></CustomerSearchResult>
     
    This is after I import into a document variable using a Create XML document step
     
    TEXT[<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n<CustomerSearchResult xmlns=\"http://www.melaleuca.com/\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\" xmlns:xsi=\"[url=http://www.w3.org/2001/XMLSchema-instance\">\n]http://www.w3.org/2001/XMLSchema-instance\">\n  <AccountNumber>2110003737</AccountNumber>\n  <ResultCount>1</ResultCount>\n  <Culture>en-MY</Culture>\n  <Script>BadNumber</Script>\n  <NumEnrollments>3</NumEnrollments>\n  <ActiveStatusID>2</ActiveStatusID>\n  <ExecStatusID>2</ExecStatusID>\n  <EnrollerCustomerID>2110003005</EnrollerCustomerID>\n  <PresenterCustomerID>2110003009</PresenterCustomerID>\n  <LastDirectorAdvDate xsi:nil=\"true\"/>\n</CustomerSearchResult>]
     
    This is my Get Xml Document data step that sets the variable.
     
    "/descendant::CustomerSearchResult/child::AccountNumber"
     
    I dont understand why the uccx system inserts all \n in the document and am not sure if that is a problem.
     
    Any help would be greatly appreciated
     
    Chris