Developmnet for Unified Wireless IP Phone 7925G

Version 1
    This document was generated from CDN thread

    Created by: Manuel Abstreiter on 30-01-2012 08:23:50 AM
    Hi,
    I'm very new to the MIDlet development, so i have a few questions about it and the development for the 7925G at all.
    1. I know that there are some emulators for J2ME but is there a specific one for the 7925G? If yes where can I get it?
    2. Is it possible to write a application that runs in background? (Multitasking?)
    3. Is there any way to get data about the current available WiFi-Networks?
     
    I hope that I postet my questions at the right place.

    Subject: RE: Developmnet for Unified Wireless IP Phone 7925G
    Replied by: David Staudt on 10-02-2012 03:21:14 PM
    See the Emulator Skin Guide (and the Midlet SDK .zip) here:
     
    http://developer.cisco.com/web/jmapi/docs
     
    This will give you a 'pretty close' UI/layout/button approximation of the 7925/26, useful for Netbeans and Oracle J2ME IDEs.
     
    J2ME applications can be multi-threaded, and can run in the background (with some limitations and caveats), see:
     
    http://developers.sun.com/mobility/learn/midp/lifecycle/#execution
     
    Not aware of any J2ME API for low-level wi-fi subsystem query/manipulation.  Note the Cisco midlet implementation covers only a few of the core JSRs - see the developer guide.

    Subject: RE: Developmnet for Unified Wireless IP Phone 7925G
    Replied by: Manuel Abstreiter on 13-02-2012 07:15:24 AM
    Not aware of any J2ME API for low-level wi-fi subsystem query/manipulation.  Note the Cisco midlet implementation covers only a few of the core JSRs - see the developer guide.

     
    Could there be sth. like that in here:
    http://developers.sun.com/mobility/apis/articles/location/

    Subject: RE: Developmnet for Unified Wireless IP Phone 7925G
    Replied by: David Staudt on 13-02-2012 01:02:54 PM
    Per the linked page, that feature set requires Location API for J2ME (JSR 179).  Unfortunately our devices do not support any extended JSRs built-in.