"Finesse is out of service" (FCS version)

Version 1
    This document was generated from CDN thread

    Created by: Andrew Higgins on 15-01-2012 02:06:58 PM
    FCS version of Finesse, 8.5.3.10000-11, agents are able to get past the login but receive errors.

    -ICM 8.5(3)
    -CTIOS Server 8.5(3)
    -Agents are able to log in fine using CTIOS Toolkit and CAD desktops
    -When logging into Finesse the screen clears, changes to a grey background, and the agent receives the following popup.
    "Finesse is out of service."
    "Please try again or contact the administrator."
    -The first popup clears quickly (barely readable) and they receive another popup with the following.
    "Unable to connect to the server. You will be redirected to the sign-in page."
    -ICM CTI Server scrolls the following continuously (note X.X.X.X is the correct IP address of the Finesse server)
    -----START-----
    12:38:01 SESSION 262: Opening from client rsuser at (X.X.X.X:33420)
    12:38:01 Trace: *** Created ClientCB 262 rsuser
    12:38:01 Trace: CTIApplication:rocessOpenRequest - sessionID 262 from rsuser at (X.X.X.X:33420), version 16
    12:38:01 Trace: CTIApplication:penValidAgent from sessionID 262 (rsuser) - ACCEPTED (0 ms)
    12:38:01 Trace: CTIApplication:rocessCloseRequest - sessionID 262
    12:38:01 SESSION 262: Closing client rsuser at (X.X.X.X:33420)
    12:38:01 Trace: *** Destroyed ClientCB 262 rsuser
    12:38:06 SESSION 263: Opening from client rsuser at (X.X.X.X:33422)
    12:38:06 Trace: *** Created ClientCB 263 rsuser
    12:38:06 Trace: CTIApplication:rocessOpenRequest - sessionID 263 from rsuser at (X.X.X.X:33422), version 16
    12:38:06 Trace: CTIApplication:penValidAgent from sessionID 263 (rsuser) - ACCEPTED (0 ms)
    12:38:06 Trace: CTIApplication:rocessCloseRequest - sessionID 263
    12:38:06 SESSION 263: Closing client rsuser at (X.X.X.X:33422)
    12:38:06 Trace: *** Destroyed ClientCB 263 rsuser
    12:38:11 SESSION 264: Opening from client rsuser at (X.X.X.X:33424)
    12:38:11 Trace: *** Created ClientCB 264 rsuser
    12:38:11 Trace: CTIApplication:rocessOpenRequest - sessionID 264 from rsuser at (X.X.X.X:33424), version 16
    12:38:11 Trace: CTIApplication:penValidAgent from sessionID 264 (rsuser) - ACCEPTED (0 ms)
    12:38:11 Trace: CTIApplication:rocessCloseRequest - sessionID 264
    12:38:11 SESSION 264: Closing client rsuser at (X.X.X.X:33424)
    12:38:11 Trace: *** Destroyed ClientCB 264 rsuser
    -----END-----
    -ICM AW Security event log shows 3 back-to-back successful logins for <domain>\<finesse user>, the same values configured in /cfadmin.
    -CSA was disabled after install
    -Tomcat was restarted after disabling CSA, server has also been rebooted.
    -Desktop logs attached.

    Subject: RE: "Finesse is out of service" (FCS version)
    Replied by: David Lender on 17-01-2012 01:08:05 PM
    The issue appears to be with your CTI Server connection.  Check the configuration to be sure it is correct.

    0000000183: 172.35.1.67: Jan 15 2012 12:33:15.471 -0600: %CCBU_Infrastructure_SS_com.cisco.ccbu.finesse.subsystem.DBSubsystem_boot_thread-3-SERVER_NOT_READY: %[reason_string=subsystems not ready]: Server State is NOT_READY. ; This is caused by some other condition which caused the server to be unable to continue processing.  Check the rest of the log for other associated errors. 
    0000000023: 172.35.1.67: Jan 15 2012 12:33:26.422 -0600: %CCBU_pool-7-thread-1-3-CTI_OPEN_FAILURE: %[ERROR_DESCRIPTION=]: CTI Server rejected open request ; There is a configuration mismatch between this server and the CTI server
    0000000037: 172.35.1.67: Jan 15 2012 12:33:31.340 -0600: %CCBU_pool-7-thread-1-4-CTI_CONNECTION_RETRYING:  System is trying to connect to CTI server ; Please wait as the system retries
    0000000044: 172.35.1.67: Jan 15 2012 12:33:31.384 -0600: %CCBU_pool-7-thread-1-3-CTI_OPEN_FAILURE: %[ERROR_DESCRIPTION=]: CTI Server rejected open request ; There is a configuration mismatch between this server and the CTI server
    0000000054: 172.35.1.67: Jan 15 2012 12:33:36.347 -0600: %CCBU_pool-7-thread-1-3-CTI_OPEN_FAILURE: %[ERROR_DESCRIPTION=]: CTI Server rejected open request ; There is a configuration mismatch between this server and the CTI server
    0000000064: 172.35.1.67: Jan 15 2012 12:33:41.359 -0600: %CCBU_pool-7-thread-1-3-CTI_OPEN_FAILURE: %[ERROR_DESCRIPTION=]: CTI Server rejected open request ; There is a configuration mismatch between this server and the CTI server
    0000000068: 172.35.1.67: Jan 15 2012 12:33:46.334 -0600: %CCBU_pool-7-thread-1-3-CTI_CONNECTION_RETRIES_EXCEEDED:  System has failed to connect to CTI server; retries will continue ; Please check the network connection, and check whether the CTI server is online
    0000000077: 172.35.1.67: Jan 15 2012 12:33:46.349 -0600: %CCBU_pool-7-thread-1-3-CTI_OPEN_FAILURE: %[ERROR_DESCRIPTION=]: CTI Server rejected open request ; There is a configuration mismatch between this server and the CTI server

    Subject: RE: "Finesse is out of service" (FCS version)
    Replied by: David Lender on 17-01-2012 01:10:29 PM
    Also, are you using  the correct ICM version?   Finesse 8.5(3) requires ICM 8.5(3) and Callmanager 8.6(1)

    Subject: RE: "Finesse is out of service" (FCS version)
    Replied by: Andrew Higgins on 17-01-2012 01:14:46 PM
    Also, are you using  the correct ICM version?   Finesse 8.5(3) requires ICM 8.5(3) and Callmanager 8.6(1)

     
    Hi David,
     
    Per my original message, yes.  FCS finesse 8.5(3), ICM 8.5(3), CM 8.6.2.20000-2.  If you see the original post I also mentioned CTIOS Toolkit and CAD agents are logging in fine.  Additionally I included what's scrolling across CTI Server and it shows the connection from the Finesse server as "accepted".  Another engineer using a completely different lab system is also having the same issue.
     
    -Andrew
     

    Subject: RE: "Finesse is out of service" (FCS version)
    Replied by: David Lender on 17-01-2012 01:54:59 PM
    Is your peripheral id correct in the CTI Server configuration in Finesse Administration? It should be the Peripheral ID of the enterprise agent PG.  I understand that CTIOS Toolkit and CAD agents are running fine.   I assume your other CTI Server config in Finesse is fine otherwise you would not be attempting to connect at all.

    Subject: RE: "Finesse is out of service" (FCS version)
    Replied by: Andrew Higgins on 17-01-2012 02:27:08 PM
    >Is your peripheral id correct in the CTI Server configuration in Finesse Administration? It should be the Peripheral ID of the enterprise agent PG

    It is, I just double checked.

    >I assume your other CTI Server config in Finesse is fine otherwise you would not be attempting to connect at all.

    It's simplex actually.  No backup host or port is configured under Server Settings or Contact Center Enterprise Administration Server Settings.

    Subject: RE: "Finesse is out of service" (FCS version)
    Replied by: Theodore Phipps on 17-01-2012 03:16:58 PM
    Andrew,

    We will have some engineers look at this, but two questions first.

    1) In the installation, you needed to specify the correct domain setting.  We explain this in detail in the Installation Guide.  Do you know if this was done correctly?
    2) To configure the AW settings, you need to use Windows authentication instead of SQL authentication.  This is explained in the admin Guide.  Was this done correctly?

    I can point you to the exact page number if you can't find it.

    Ted

    Subject: RE: "Finesse is out of service" (FCS version)
    Replied by: BRAD CLARKE on 17-01-2012 05:11:42 PM
    The AW SQL logins are working fine, we can see this in the event logs.

    Subject: RE: "Finesse is out of service" (FCS version)
    Replied by: Monawar Alhaque on 18-01-2012 09:50:47 AM
    Hi Andrew,

    Assuming you are Cisco ATP partner, can you please open a case with Cisco PDI team and we will assist you with the install/implementation.

    http://www.cisco.com/web/partners/tools/pdi.html

    Thanks,

    - mo

    (Monawar Alhaque)
    Cisco PDI UCC Team Lead

    Office Phone:  1 469 255 0296
    Office Hours: 9:00 - 17:00 Central
    Office Days: Monday - Friday

    http://www.cisco.com/web/partners/tools/pdi.html

    Subject: RE: "Finesse is out of service" (FCS version)
    Replied by: Andrew Higgins on 17-01-2012 05:28:17 PM
    Hi Ted,
     
    >1) In the installation, you needed to specify the correct domain setting.  We explain this in detail in the Installation Guide.  Do you know if this was done correctly?
     
    Yes, confirmed.  Both forward and reverse lookup records configured in DNS.  Appropriate domain name and name server IP address configured during the installer.  Appropriate domain name configured in /cfadmin.
     
    >2) To configure the AW settings, you need to use Windows authentication instead of SQL authentication.  This is explained in the admin Guide.  Was this done correctly?
     
    The AW is joined to the domain.  MS SQL Server on the AW is configured to use mixed mode authentication.  MS SQL Server on the AW is running under a local service account created on the AW.  The username configured in /cfadmin is a domain user.  The same username has been added to the local administrators group on the AW and is a SQL Server administrator.  We've also tried using a different domain user account and assigning that user db_datareader rights to both the awdb and hds db.
     
    Note: This is the same environment we've been using for EFT builds with the exception of upgrading ICM from 8.5(1) to 8.5(3).  The existing environment worked fine with the previous builds.  We can schedule a WebEx if it would be more convienant.
     
    Thanks,
     
    -Andrew

    Subject: RE: "Finesse is out of service" (FCS version)
    Replied by: Monawar Alhaque on 20-01-2012 08:20:52 PM
    Finesse is not supported on Generic PG.

    "Cisco Finesse is supported on, and has been tested on, a Call Manager Peripheral Gateway (PG)only."

    http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/finesse/finesse_853/installation/guide/fin853install.pdf
    page 29

    Partner has UCM pim (active) and VRU (cvp pim inactive)
    Finesse did not connect to CTI Server until all pims were active.

    Opened doc defect CSCtx49648 for clarification.