Route, Hypervisor, and VMs on same subnet

Version 1
    This document was generated from CDN thread

    Created by: John Quintanilla on 05-12-2011 09:08:41 AM
    I'm running SRE-V 1.5.1 on SRE-910 and IOS 15.1(4)M.  Customer has an existing 192.168.3.1/24 network and we'd like to place 2911, hypervisor, and all VMs on this same subnet.  Most of the user guides, how-to's, etc all discuss SRE-V setup using VLANs.  Is it possible to put the router, hypervisor, and all VMs on the existing subnet?  If so, can you offer some guidance or point me to some documentation?  Thanks much.
    John

    Subject: RE: New Message from Brett Tiller in Service Ready Engine Virtualization -
    Replied by: Radhika Miriyala on 05-12-2011 02:30:55 PM
    To Add to Brett¿s reply in this example the VM¿s would be in vSwitch0 and also you would need to add routes for the VM¿s Ip addresses in the router.





    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Monday, December 05, 2011 11:22 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Brett Tiller in Service Ready Engine Virtualization - SRE-V Technical Questions: RE: Route, Hypervisor, and VMs on same subnet



    Brett Tiller has created a new message in the forum "SRE-V Technical Questions":

    --------------------------------------------------------------
    Hi John,

    Yes this all-in-configuration is possible to do without VLANs. You can create a point-to-point connection between the Gigabit and SM interfaces, then set the IPs of the VM on the same subnet as well. I've provided a snippet below for the router configuration.

    --Router Configuration
    interface GigabitEthernet0/1
    ip address 192.168.3.20

    interface SM 1/0
    ip unnumbered GigabitEthernet0/1
    service-module ip address 192.168.3.21 255.255.255.0
    service-module ip default-gateway 192.168.3.20

    ip route 192.168.3.21 255.255.255.255 SM1/0

    --VM Configuration
    1. In the VM operating system set the IP to be on the same subnet as the Gigabit and SM interfaces.
    2. You now have the router, service module and VMs all on the same subnet.


    For optimal performance we recommend that you install an EtherSwitch card as it reduces the cpu load on the router. We've provided a white paper showing how to configure the router with the design you've mentioned in the paper 'EtherSwitch Configuration on SRE-V.pdf' located in our knowledge base at http://developer.cisco.com/web/srev/docs .

    Thank
    Brett
    --
    To respond to this post, please click the following link:

    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/4851063>

    or simply reply to this email.

    Subject: RE: Route, Hypervisor, and VMs on same subnet
    Replied by: Brett Tiller on 05-12-2011 02:21:34 PM
    Hi John,

    Yes this all-in-configuration  is possible to do without VLANs.  You can create a point-to-point connection between the Gigabit and SM interfaces, then set the IPs of the VM on the same subnet as well. I've provided a snippet below for the router configuration. 

    --Router Configuration
    interface GigabitEthernet0/1
    ip address 192.168.3.20

    interface SM 1/0
    ip unnumbered GigabitEthernet0/1
    service-module ip address 192.168.3.21 255.255.255.0
    service-module ip default-gateway 192.168.3.20

    ip route 192.168.3.21 255.255.255.255 SM1/0

    --VM Configuration
    1.  In the VM operating system set the IP to be on the same subnet as the Gigabit and SM interfaces.
    2.  You now have the router, service module and VMs all on the same subnet.


    For optimal performance we recommend that you install an EtherSwitch card as it reduces the cpu load on the router.  We've provided a white paper showing how to configure the router with the design you've mentioned in the paper 'EtherSwitch Configuration on SRE-V.pdf' located in our knowledge base at http://developer.cisco.com/web/srev/docs .

    Thanks,

    Brett

    Subject: RE: Route, Hypervisor, and VMs on same subnet
    Replied by: John Quintanilla on 05-12-2011 03:42:10 PM
    Brett and Radhika,
    Thanks for the response.  Based on your suggestions, I have the following configuration:

    interface GigabitEthernet0/1
    ip address 192.168.3.140 255.255.255.0
    duplex auto
    speed auto

    interface SM1/0
    ip unnumbered GigabitEthernet0/1
    service-module ip address 192.168.3.40 255.255.255.0
    !Application: VMware ESXi 4.1.0 build-348481 running on SRE
    service-module ip default-gateway 192.168.3.140

    ! gateway for 2911 is 192.168.3.1
    ip route 0.0.0.0 0.0.0.0 192.168.3.1
    !
    ! SRE-V IP is 192.168.3.40
    ip route 192.168.3.40 255.255.255.255 SM1/0
    !
    ! VM1 IP is 192.168.3.41
    ip route 192.168.3.41 255.255.255.255 SM1/0



    I set the default gateway for the VM to be 192.168.3.140.  I also set VM1 to use a VM network on vSwitch0.

    VM1 can ping other hosts on the 192.168.3.1/24 subnet but it cannot ping the gateway at 192.168.3.1, or beyond (ie. an internet address).  Have I missed a configuration item?
    Thanks.
    John

    Subject: RE: Route, Hypervisor, and VMs on same subnet
    Replied by: Brett Tiller on 05-12-2011 07:27:28 PM
    Hi John,

    Can you ping the 192.168.3.1 default gateway from the router and the service module (DCUI)?  Everything is on the same subnet so it all should be pingable.  You can try setting the service module default gateway to the 192.168.3.1 ip and see if that helps.  Regarding getting out to the internet, you'll need to set up NAT since the 192.168 ip address is private.

    Thanks,

    Brett

    Subject: Re: New Message from Brett Tiller in Service Ready Engine Virtualization -
    Replied by: John Quintanilla on 05-12-2011 08:46:55 PM
    Brett,
    I had an issue with my configuration, but my problem is now resolved. 
    Thanks for your assistance.
    John

    On 12/05/2011 06:27 PM, Cisco Developer Community Forums wrote:
    > Brett Tiller has created a new message in the forum "SRE-V Technical
    > Questions":
    >
    > --------------------------------------------------------------
    > Hi John,
    >
    > Can you ping the 192.168.3.1 default gateway from the router and the
    > service module (DCUI)? Everything is on the same subnet so it all
    > should be pingable. You can try setting the service module default
    > gateway to the 192.168.3.1 ip and see if that helps. Regarding getting
    > out to the internet, you'll need to set up NAT since the 192.168 ip
    > address is private.
    >
    > Thanks,
    >
    > Brett
    > --
    > To respond to this post, please click the following link:
    >
    > <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/4851659>
    >
    > or simply reply to this email.

    --

    *John Quintanilla
    *Sr. Systems Analyst
    AvFinity, L.L.C.
    Email: jqq@avfinity.com
    Web: http://www.AvFinity.com/
    Office: 512-535-3384

    AvFinity LLC, Your messages will fly too!
    LinkedIn <http://www.linkedin.com/company/avfinity-llc>  blogger.com
    <http://avfinity.blogspot.com/>  facebook.com
    <http://www.facebook.com/pages/AvFinity-LLC/130353393663865>  YouTube
    <http://www.youtube.com/user/avfinity>  Twitter
    <http://twitter.com/avfinity>  RSS Feed
    <http://www.prweb.com/rss2g/73794.xml>

    AvFinity LLC is an IATA Strategic Partner
    This communication, including attachments, is for the exclusive use of
    addressee and may contain proprietary, confidential or privileged
    information. If you are not the intended recipient, any use, copying,
    disclosure, dissemination or distribution is strictly prohibited. If you
    are not the intended recipient, please notify the sender immediately by
    return email and delete this communication and destroy all copies.

    Subject: RE: Route, Hypervisor, and VMs on same subnet
    Replied by: Charlie Jones on 15-03-2012 12:29:04 PM
    I am running a similar configuration, but I am having a different issue.  The difference in my config is that we are doing router on a stick.  Below is the pertinent config information:

    interface GigabitEthernet0/0
    no ip address
    ip nbar protocol-discovery
    ip flow ingress
    duplex full
    speed 100
    no snmp trap link-status

    interface GigabitEthernet0/0.100
    encapsulation dot1Q 100
    ip address 10.191.100.1 255.255.255.0
    ip helper-address 10.172.1.242
    ip flow ingress

    interface SM1/0
    ip unnumbered GigabitEthernet0/0.100
    service-module ip address 10.191.100.5 255.255.255.0
    !Application: VMware ESXi 5.0.0 build-474610 running on SRE
    service-module ip default-gateway 10.191.100.1
    !
    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk
    no ip address

    ip route 0.0.0.0 0.0.0.0 10.191.100.2
    ip route 10.191.100.5 255.255.255.255 SM1/0
    ip route 10.191.100.10 255.255.255.255 SM1/0

    From the VM (10.191.100.10), I cannot ping the DG (10.191.100.1).   In looking at the network configuration in vSphere, I have two switches, vswitch0 and vswitch1.   I don't know if this is the problem, but my management network is on vswitch0, and the VM is on vswitch1.

    Subject: RE: Route, Hypervisor, and VMs on same subnet
    Replied by: Jack Schluckbier on 14-05-2012 12:07:52 AM
    Hi John,

    I too am running into the same issue as you had originally, by setting everything into the same subnet. You say that your problems have all been resolved, that it was a config issue. Can you share what you found? I would be grateful for any reply! Thanks!