Dataset status is Failed (Database error)

Version 1
    This document was generated from CDN thread

    Created by: Sarah Barnes on 14-11-2013 01:56:03 PM
    I am in the process of creating a report based on an Agent Team report. It is a Daily report and I am running it as an anoymous Block report. That all creates fine, however when I create the report - put in the filter and run it i get the following error

    Dataset status is Failed (Database error)
    Having looked at the SQL on the report I have just run - half of the GROUP By is missing!

    WHen I go back to the report definition = everything is ok - and saves ok, so I have no idea why this is happening!

    Any ideasanyone?

    Subject: RE: Dataset status is Failed (Database error)
    Replied by: Nathan Luk on 14-11-2013 05:46:47 PM
    Hi Sarah,

    Check how many characters your SQL statement ends up being. CUIC has a 15000 character limit it enforces which can manifest in annoying ways like cutting your GROUP BY in half

    Cheers,
    Nathan

    Subject: RE: Dataset status is Failed (Database error)
    Replied by: Sarah Barnes on 15-11-2013 03:33:31 AM
    Thanks Nathan, I will take out some information that I don't need and see is that sorts the problem

    Good to know as when I ran the complete query in SQL Studio manager - there wasn't any problems.

    if this published anywhere and I missed it ?

    Subject: RE: New Message from Sarah Barnes in Contact Center Reporting (CCR) - Conta
    Replied by: Steven Maas on 15-11-2013 09:26:33 AM
    How long is your query? I believe there is a limit in the length of the query.

    -----Original Message-----
    From: Cisco Developer Community Forums [cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com>]
    Sent: Friday, November 15, 2013 02:39 AM US Mountain Standard Time
    To: cdicuser@developer.cisco.com
    Subject: New Message from Sarah Barnes in Contact Center Reporting (CCR) - Contact Center Reporting: RE: Dataset status is Failed (Database error)

    Sarah Barnes has created a new message in the forum "Contact Center Reporting": -------------------------------------------------------------- Thanks Nathan, I will take out some information that I don't need and see is that sorts the problem

    Good to know as when I ran the complete query in SQL Studio manager - there wasn't any problems.

    if this published anywhere and I missed it ?
    --
    To respond to this post, please click the following link: http://developer.cisco.com/web/ccr/community/-/message_boards/view_message/21346237 or simply reply to this email.