Connection Error

Document created by cdnadmin on Jan 25, 2014
Version 1Show Document
  • View in full screen mode
This document was generated from CDN thread

Created by: Han Shen on 23-10-2013 02:55:24 AM
I was assigned a IP and port number to connect to Nexus 3000 switch. It works well When I telnet it. However, when I tried to run "./bin/HelloElment -a X.X.X.X -u admin -p XXX -O 16011 -t tcp" , (-O is what I have defined for port number argument )it shows an error "Error: incompatible version: NE Version :0.6.0 Client Version: 1.0.0(2): connect". It occurs when calling "onep_element_connect".Do anyone have some idea about this problem? Thank you so much.

Subject: Re: New Message from Han Shen in onePK Developer - API and programming: Con
Replied by: Einar Nilsen-Nygaard on 23-10-2013 03:24:54 AM
The version of onep on your nexus switch is incompatible with your onePK SDK. You need either a newer switch image (preferred option) or an older SDK.

Cheers,

Einar

On 23 Oct 2013, at 08:55, "Cisco Developer Community Forums" <cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com>> wrote:

Han Shen has created a new message in the forum "API and programming": -------------------------------------------------------------- I was assigned a IP and port number to connect to Nexus 3000 switch. It works well When I telnet it. However, when I tried to run "./bin/HelloElment -a X.X.X.X -u admin -p XXX -O 16011 -t tcp" , (-O is what I have defined for port number argument )it shows an error "Error: incompatible version: NE Version :0.6.0 Client Version: 1.0.0(2): connect". It occurs when calling "onep_element_connect".Do anyone have some idea about this problem? Thank you so much.
--
To respond to this post, please click the following link: http://developer.cisco.com/web/onepk-developer/forum/-/message_boards/view_message/20533338 or simply reply to this email.

Subject: RE: Re: New Message from Han Shen in onePK Developer - API and programming:
Replied by: Han Shen on 23-10-2013 01:00:57 PM
[quote=
Einar Nilsen-Nygaard]The version of onep on your nexus switch is incompatible with your onePK SDK. You need either a newer switch image (preferred option) or an older SDK.

Cheers,

Einar

On 23 Oct 2013, at 08:55, "Cisco Developer Community Forums" <cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com>> wrote:

Han Shen has created a new message in the forum "API and programming": -------------------------------------------------------------- I was assigned a IP and port number to connect to Nexus 3000 switch. It works well When I telnet it. However, when I tried to run "./bin/HelloElment -a X.X.X.X -u admin -p XXX -O 16011 -t tcp" , (-O is what I have defined for port number argument )it shows an error "Error: incompatible version: NE Version :0.6.0 Client Version: 1.0.0(2): connect". It occurs when calling "onep_element_connect".Do anyone have some idea about this problem? Thank you so much.
--
To respond to this post, please click the following link: http://developer.cisco.com/web/onepk-developer/forum/-/message_boards/view_message/20533338 or simply reply to this email.Hi Einar,
       Thanks for your answer, however, when I checked the onep staus on n3k, it shows "version 1.1.0", and when I have installed the newest sdk, the problem remained the same. The prompt "NE version 0.6.0 " seems unreasonable because neither my sdk or n3k uses this version, any idea?
Thanks,
Han


Subject: RE: New Message from Han Shen in onePK Developer - API and programming: RE:
Replied by: Zachary Seils on 23-10-2013 01:03:22 PM
Han,

You need to use an older version of the SDK with the Nexus 3000 platform.  Please email me your CCO ID and I will post it for you.

Thanks,
Zach
seils@cisco.com

From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
Sent: Wednesday, October 23, 2013 2:01 PM
To: cdicuser@developer.cisco.com
Subject: New Message from Han Shen in onePK Developer - API and programming: RE: Re: New Message from Han Shen in onePK Developer - API and programming:

Han Shen has created a new message in the forum "API and programming": -------------------------------------------------------------- [quote=
Einar Nilsen-Nygaard]The version of onep on your nexus switch is incompatible with your onePK SDK. You need either a newer switch image (preferred option) or an older SDK.

Cheers,

Einar

On 23 Oct 2013, at 08:55, "Cisco Developer Community Forums" <cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com%3cmailto:cdicuser@developer.cisco.com>>> wrote:

Han Shen has created a new message in the forum "API and programming": -------------------------------------------------------------- I was assigned a IP and port number to connect to Nexus 3000 switch. It works well When I telnet it. However, when I tried to run "./bin/HelloElment -a X.X.X.X -u admin -p XXX -O 16011 -t tcp" , (-O is what I have defined for port number argument )it shows an error "Error: incompatible version: NE Version :0.6.0 Client Version: 1.0.0(2): connect". It occurs when calling "onep_element_connect".Do anyone have some idea about this problem? Thank you so much.
--
To respond to this post, please click the following link: http://developer.cisco.com/web/onepk-developer/forum/-/message_boards/view_message/20533338 or simply reply to this email.Hi Einar,
       Thanks for your answer, however, when I checked the onep staus on n3k, it shows "version 1.1.0", and when I have installed the newest sdk, the problem remained the same. The prompt "NE version 0.6.0 " seems unreasonable because neither my sdk or n3k uses this version, any idea?
Thanks,
Han

--
To respond to this post, please click the following link: http://developer.cisco.com/web/onepk-developer/forum/-/message_boards/view_message/20580231 or simply reply to this email.

Subject: RE: Connection Error
Replied by: Han Shen on 23-10-2013 04:42:08 PM
It was not about the problem of version but the wrong usage to involve the port number. 
I should use onep_session_config_set_port
Thanks for your help!

Attachments

    Outcomes