Data Exception when trying to update MWI - UCXN 9.1.2

Version 1
    This document was generated from CDN thread

    Created by: PATRICK NOWICKI on 15-10-2013 01:18:09 PM
    Having an issue setting the "UsePrimaryExtension" field for a user to "true", "t" or "1" on a 9.1.2 system. Interestingly enough, the same query works on a 9.1.1a system. I can set the field to "0" and specify a phone system and extension and that works fine. I can also set the "UsePrimaryExtension" to "true", "t" and "1" if that user's MWI is already set that way. When I try to make a user's MWI thier primary extension when it is currently not their primary, I get a data exception returned when I do the PUT update. My XML in my PUT is the below:
    <Mwi><UsePrimaryExtension>1</UsePrimaryExtension></Mwi>
    To the following URI
    https://192.168.1.13/vmrest/users/003890d5-dff6-4a53-933e-7a455f468c3c/mwis/867700da-0f96-4796-b10f-5b55db1cb9ae

    As I stated before, the same update works on a 9.1.1a system, so I'm not sure if a new field is required in 9.1.2 or if there is a bug or maybe I am just doing something wrong.
    Thanks for any thoughts!

    <update>
    My error - found that my restriction tables were different in my 9.1.2 system that was blocking the setting of primary extension on my MWI. Changing the outdial restriction tables to allow "+" dialing took care of it for me. Interestingly enough the other 9.1.2 system that I was testing with didnt kick out the same error as my lab, but we got it figured out.