CUIC - Failed login for linked server

Version 1

    Subject: RE: CUIC - Failed login for linked server
    Replied by: Edwin Andrews on 10-09-2013 10:37:06 AM
    All SQL Server acces uses only the CUIC User ID. Forwarding the end user's ID through the web, to CUIC , then on to the DB is probably not going to work at all.

    Is this system just coming up for the first time? User ID configuration for the CUIC user on the SQL Server is documented pretty well in the install instructions.
    This document was generated from CDN thread

    Created by: Ruzel Jamilon on 10-09-2013 09:51:51 AM
    Getting this error when trying to validate report defintion:
    "Invalid Query. Check the syntax. Login failed for user '_______'. "

    In the database, the linked server login for is set to impersonate, @useself = TRUE. When I try the query in MS SQL Studio, it is succcesfull. But in CUIC, I have the error above.

    I am very new at DB administration (security, linked servers) and I dont know how to go forward on this error.

    Do I need to use @useself = FALSE, and supply a username and password to be used to the linked server? Does this mean that anytime the DB connects to the linked server, it will use the supplied credentials regardless of which username actually connected to the database? (CUIC user)

    Or do I keep the @useself = TRUE, and have the CUIC user defined in the linked server?

    Or I am getting it wrong completely? Any other suggestions?

    Both request would entail requests approvals (and thus will consume time) so I would like to ask for your advice on what step to take before I make any requests.

    Thanks!

    Subject: RE: CUIC - Failed login for linked server
    Replied by: Ruzel Jamilon on 10-09-2013 11:04:07 AM
    Hi Edwin. Thank you for your reply.

    The system has been up for amost a year but was not extensively used at the time. I have been in the project recently and unfortunately without proper documentation except for what I can find in the net. \

    I finally got access to the linked server and saw that there is a SQL user for CUIC, but it does not match the user credentials being passed in the datasource set. I also cannot find the password for this CUIC SQL user.

    Meanwhile I got everything working (finally!) by adding a new user to the linked database, granting permission on that user fot the tables I need and setting the linked server login to use that credential. But these makes it difficult to maintain, so I will search (or maybe you can give me a link?) for the CUIC install instruction.

    Thank you!

    Subject: RE: CUIC - Failed login for linked server
    Replied by: Edwin Andrews on 10-09-2013 12:27:12 PM
    Match up the user ID, use only one. Use SQL Server management Studio --> Security --> Logins, find the ID, --> right-click --> properties... reset the password for the CUIC User ID.
    Then set the password in CUIC on that user for the datasource to match the new password.
    I think that's a plan...I have only set it up once.

    Version  8.0(4)
    http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/intelligence_suite/intelligence_suite_804/user/guide/CUICUserGuide_804.pdf
    Other Versions: {Get the Users' Guide)
    http://www.cisco.com/en/US/products/ps9755/products_user_guide_list.html

    "The database server must be set to allow SQL authentication and to enable TCP/IP protocol andremote network connection."

       The following are not supported:
    Windows integrated authentication connection to MS SQL Server. 
    Automatic failover to a different database. 
    A data source that points to more than one database.

    Subject: RE: CUIC - Failed login for linked server
    Replied by: Edwin Andrews on 10-09-2013 12:29:42 PM
    BTW. If the HDS {Historical DB} and AWDB {Admin DB} are on different servers the users password will need to be changed on both.