NTP Server

Version 1
    This document was generated from CDN thread

    Created by: jonathan stiefel on 29-05-2013 03:18:02 PM
    Does anyone know of a method or SQL string to add and remove NTP Servers. I tried run sql SELECT * FROM ntpserver to try to view current NTP servers, but do not see any even though they are configured.

    Subject: RE: NTP Server
    Replied by: Martin Sloan on 29-05-2013 03:29:20 PM
    Hi Jonathan,
    If you're trying to update the NTP info for the actual CUCM servers, you need to set this via cli with 'utils ntp server add <ip address> ' or via the OS Admin page.  The NTP servers listed in the CUCM DB table are there for SIP phones registered with the the cluster.
    Marty

    Subject: RE: NTP Server
    Replied by: jonathan stiefel on 29-05-2013 03:33:00 PM
    Yes I am trying to set the NTP Server listed in OS administration programatically through AXL, SQL, or some other option. The requirement is to set it from a program without logging and using utils or via OS administration page.

    Subject: RE: NTP Server
    Replied by: Martin Sloan on 29-05-2013 03:39:52 PM
    That's a tough one.  AFAIK those are the only 2 options.  Outside of scripting an ssh session to the servers, I'm not sure how you'd do this.

    Subject: RE: NTP Server
    Replied by: jonathan stiefel on 29-05-2013 03:45:04 PM
    While not ideal, scripting an ssh session would probably work. Now I have to look at the documentation for Java's SSH Factory and figure out how to execute the utils command. Thanks for the idea.

    Subject: RE: NTP Server
    Replied by: Martin Sloan on 29-05-2013 03:51:21 PM
    Np.  Good luck!

    Subject: RE: NTP Server
    Replied by: jonathan stiefel on 29-05-2013 04:11:45 PM
    After taking a look at the CLI for my CUCM version, 8.0(1), I do not have the utils ntp server add command available. I have : utils ntp :config, restart, start, status. utils ntp server throws an error.

    Subject: Re: New Message from jonathan stiefel in AXL Developer - Administration XML
    Replied by: Martin Sloan on 29-05-2013 07:13:34 PM
    I'm on 9.1 and my first instinct was to go to the 'set' commands but didn't find it there. I guess it changed from 8. I don't have that version running right now but check out what options you have under set, I think it's in there.

    Sent from my iPhone

    On May 29, 2013, at 5:13 PM, "Cisco Developer Community Forums" <cdicuser@developer.cisco.com> wrote:

    > jonathan stiefel has created a new message in the forum "Administration XML Questions": -------------------------------------------------------------- After taking a look at the CLI for my CUCM version, 8.0(1), I do not have the utils ntp server add command available. I have : utils ntp :config, restart, start, status. utils ntp server throws an error.
    > --
    > To respond to this post, please click the following link: http://developer.cisco.com/web/axl-developer/forums/-/message_boards/view_message/15704829 or simply reply to this email.

    Subject: RE: New Message from Martin Sloan in AXL Developer - Administration XML Que
    Replied by: Martin Sloan on 30-05-2013 07:09:34 AM
    I just checked the cli reference for 8.0 and I don’t see the option to add an ntp server.  That really surprises me as I thought it was definitely in there.  Sorry for the false information.  It is available in 9.1.



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Wednesday, May 29, 2013 8:14 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Martin Sloan in AXL Developer - Administration XML Questions: Re: New Message from jonathan stiefel in AXL Developer - Administration XML



    Martin Sloan has created a new message in the forum "Administration XML Questions": -------------------------------------------------------------- I'm on 9.1 and my first instinct was to go to the 'set' commands but didn't find it there. I guess it changed from 8. I don't have that version running right now but check out what options you have under set, I think it's in there.

    Sent from my iPhone

    On May 29, 2013, at 5:13 PM, "Cisco Developer Community Forums" <cdicuser@developer.cisco.com> wrote:

    > jonathan stiefel has created a new message in the forum "Administration XML Questions": -------------------------------------------------------------- After taking a look at the CLI for my CUCM version, 8.0(1), I do not have the utils ntp server add command available. I have : utils ntp :config, restart, start, status. utils ntp server throws an error.
    > --
    > To respond to this post, please click the following link: http://developer.cisco.com/web/axl-developer/forums/-/message_boards/view_message/15704829 or simply reply to this email.
    --
    To respond to this post, please click the following link: http://developer.cisco.com/web/axl-developer/forums/-/message_boards/view_message/15708596 or simply reply to this email.