RE: Can't hear ringing

Version 1
    This document was generated from CDN thread

    Created by: Yaw-Ming Chen on 17-05-2013 11:41:34 AM
    Your script has no problem, it works for me I can hear ringback. Maybe something to do with you router, confiurationm...etc

    Subject: RE: Can't hear ringing
    Replied by: Geevarghese Cheria on 20-05-2013 05:03:42 AM
    Hi Mark,
    Can you send a  debug ccsip messages . Also Can you confirm on the outbound call if your provider sends 180 with SDP or 183 or just 180
    Thanks and Regards
    Geevarghese
     

    Subject: RE: Can't hear ringing
    Replied by: Geevarghese Cheria on 20-05-2013 08:22:02 AM
    Hi Mark,

    Can you please try the following
    Please add "playtone leg_incoming tn_ringback" before you issue leg setup and once the IVR gets ev_setup_done stop the playtone using
    "playtone leg_incoming tn_none"

    Also can you get the debug voice ccapi inout along with sh run

    Thanks and Regards,
    Geevarghese

    Subject: RE: Can't hear ringing
    Replied by: Yaw-Ming Chen on 20-05-2013 06:50:15 PM
    we should the ringback but if not try to force it.
    do this for leg setup
      set callInfo(notifyEvents) "ev_alert ev_progress ev_proceeding"
     
    when you get ev_alert
     
    proc act_Alert { } {

      
       puts ">>> TCL: act_Alert <<<"
       set event [infotag get evt_event]
       puts ">>> event received: $event <<<"
       if {($event == "ev_alert") || ($event == "ev_progress")} {
       
           playtone leg_incoming tn_ringback

       } 
    }



     

    Subject: RE: Can't hear ringing
    Replied by: Geevarghese Cheria on 21-05-2013 05:06:14 AM
    Hi Mark,

         since Ringback is automatically generated by DSP when IVR is in the process of dialing the DNIS number. The other workaround i would recommend is to check the hardware or to try with a different IOS version.

    Thanks and Regards,
    Geevarghese

    Subject: RE: Can't hear ringing
    Replied by: Geevarghese Cheria on 28-05-2013 05:54:28 AM
    Hi Mark,
      Can you try the incoming dial peer with a progess indicator
    progress_ind setup enable 3

    under following dial peer

    dial-peer voice 18 voip
    service testcall
    voice-class codec 1
    session target ras
    incoming called-number .T
    progress_ind setup enable 3
    dtmf-relay rtp-nte
    no vad

    Thanks and Regards,
    Geevarghese

    Subject: RE: Can't hear ringing
    Replied by: Geevarghese Cheria on 28-05-2013 08:05:39 AM
    Hi Mark,
    The progress_ind alert and the progress_ind setup commands are hidden in some versions of Cisco IOS Software and are not visible within the help parser.  An alternate to the progress_ind setup command is the dial-peer voice # voip subcommand tone ringback alert-no-pi.

    Also can you  try to upgrade with the latest version of IOS 12.4.15T17(MD)


    Thanks and Regards,

    Geevarghese


    Subject: RE: Can't hear ringing
    Replied by: Yaw-Ming Chen on 28-05-2013 01:54:43 PM
    Notice that your incomg leg is SIP. According to programming guide playtone will be silently ignored. for VoIP leg.
     
    If you don't use Tcl did you see 180 ringing sent to calling party ?
    If Tcl is used, did you see 180 ringing sent ?

    Subject: RE: Can't hear ringing
    Replied by: Geevarghese Cheria on 30-05-2013 07:32:50 AM
    Hi Mark,

      As the Issue is not with the TCL Script, would request to you try out this configuration.

    dial-peer voice 18 voip
    voice cut-through alert
    tone ringback alert-no-PI
    service testcall
    voice-class codec 1
    session target ras
    incoming called-number .
    dtmf-relay rtp-nte
    no vad


    Thanks and Regards,
    Geevarghese