find new intresting issue on SRe 3945 router

Version 1
    This document was generated from CDN thread

    Created by: Kshitij Purwar on 15-11-2012 09:43:47 AM
    Hi, i have one 3945e router with default ios image 15.1 M4,when i connect one sre910,i can see int sm 1/0 on router console,but when i upgrade the router iso imge to 15.1 T2,then i can not see sre910 on router console. run the below comand hw-module oir-stop hw-module oir-start but no luck,then the slot from 1 to 2 but still no luck. can anybody please help me here. Thanks kshitij

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Brett Tiller on 15-11-2012 12:20:35 PM
    Hi Kshitij,
     
    The issue is most likely the 15.1.T2 IOS image you moved to is too early of a release.  Our guide recommends using IOS release 15.1(4)M or later.  If you prefer to use a 'T' release please try a later version.
    Thanks,
    Brett

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Kshitij Purwar on 15-11-2012 12:59:23 PM
    Hi Brett,
    Thanks for reply.
    but we want to test cme version 8.0 which is supported on this iso image only.
    is there any workaround to fix this issue.
    Thanks
    kshitij

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Brett Tiller on 15-11-2012 03:32:27 PM
    Hi Kshitij,
    Let me check with the CME team and I'll get back to you as soon I get a response.  Just to confirm, with the T2 image you are no longer seeing the SM interface correct?  I assume the hardware can still be seen? Please type 'show run' and 'show diag | inc FRU' and send me the data for each.
    Thanks,
    Brett

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Brett Tiller on 15-11-2012 04:36:31 PM
    Hi Kshitij,
    I found a link to a webpage that describes the CME releases and its corresponding IOS versions.  It has a footnote that says to get the latest release of the IOS rebuild, so you should be able to use a later IOS image.  Please also note that CME is currently on release 9.1, so I'm sure they'd recommend using a later release of CME as well.
    http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/requirements/guide/33matrix.htm
    Thanks,
    Brett

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Brett Tiller on 15-11-2012 07:24:05 PM
    Hi Kshitij,
    Our CME Product Manager has told me that CME can only run on IOS.  It is not currently supported on the SRE service module.  Please let us know your use case for wanting to run CME on SRE.
    Thanks,
    Brett

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Kshitij Purwar on 20-11-2012 08:49:45 AM
    Hi Brett,
    Sorry for my late reply.Please find the attached doc as you required.
    we want to install cuc on sre blade 910/900 for testing,and want to test it with different falouu of cme-srst image which are supported on router 3900/2900.
    I updated the router iso image to 15.1(1) T5,but still it in not working.
    please let me know,is there any way we can test sre blade with cuc on it and cme-srst 8.0 on router.
     
    Thanks
    kshitij

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Kshitij Purwar on 20-11-2012 08:52:52 AM
    Hi Brett,
    Sorry for my late reply.Please find the attached doc as you required.
    we
    want to install cuc on sre blade 910/900 for testing,and want to test
    it with different falouu of cme-srst image which are supported on router
    3900/2900.
    I updated the router iso image to 15.1(1) T5,but still it in not working.
    please let me know,is there any way we can test sre blade with cuc on it and cme-srst 8.0 on router.
     
    Thanks
    kshitij

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Brett Tiller on 20-11-2012 01:45:21 PM
    Hi Kshitij,
    Thanks for the data.  I can see that the SRE service module is not being recognized by the earlier IOS versions that you would like to use.  Our documentation specifies that you need to use IOS release 15.1(4)M at minimum.  I see from the CME chart that I provided to you that this IOS release contains CME 8.6 .   I don't have specifications for the T train; however I checked the SRE configuration guide at http://www.cisco.com/go/sre , and it appears that you could use IOS version 15.1(3)T; however this release contains CME version 8.5 .  In either case I don't think CME 8.0 is a viable candidate for use on the router with the SRE service module because a later IOS version is required for the SRE.
    Thanks,
    Brett

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Kshitij Purwar on 22-11-2012 12:47:18 PM
    Hi Brett,
    thanks your valuable inputs provided here.
    is there any command to find out the router chassis is 3945 or 3945e.
    as i know cisco 3945 has spe150 and 3945e has spe 250.
    Thanks
    kshitij

    Subject: Re: New Message from Kshitij Purwar in Service Ready Engine Virtualization
    Replied by: Anurag Gurtu on 22-11-2012 04:06:48 PM
    Try

    Sh ver or sh inv

    Thanks

    Anurag Gurtu

    On Nov 22, 2012, at 10:47 AM, "Cisco Developer Community Forums" <cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com>> wrote:

    Kshitij Purwar has created a new message in the forum "SRE-V Technical Questions": -------------------------------------------------------------- Hi Brett,
    thanks your valuable inputs provided here.
    is there any command to find out the router chassis is 3945 or 3945e.
    as i know cisco 3945 has spe150 and 3945e has spe 250.
    Thanks
    kshitij
    --
    To respond to this post, please click the following link: <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/8755425> http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/8755425 or simply reply to this email.

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Kshitij Purwar on 23-11-2012 08:58:26 AM
    Hi Anurga,
    Thanks for your input.
    but in show inv it is showing 3945 chassis but in show ver it is showing 3945e iso imsge.
    so still confused how to identify the chassis.
    or it can be identified only by iso image.
    Thanks
    kshitij

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Kshitij Purwar on 23-11-2012 09:43:51 AM
    Hi Brett, i used 15.1 (3) T,but still i can not install SRE-V on 910/900. getting below
    error-

    Warning: Router's ROMMON ne eds to be upgraded to suppport proper operation of module SM-SRE-900-K9 SM-SRE-9 10-K9 . Operation SM-SRE-900-K9 SM-SRE-910-K9  without upgrading ROMMON may caus e the module hard disk driver to become unstable.

    Thanks kshitij

    Subject: Re: New Message from Kshitij Purwar in Service Ready Engine Virtualization
    Replied by: Anurag Gurtu on 23-11-2012 03:53:48 PM
    See if there is sh hardware CLI if not you can go with sh ver. Hope that helps.

    Thanks

    Anurag Gurtu

    On Nov 23, 2012, at 6:58 AM, "Cisco Developer Community Forums" <cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com>> wrote:

    Kshitij Purwar has created a new message in the forum "SRE-V Technical Questions": -------------------------------------------------------------- Hi Anurga,
    Thanks for your input.
    but in show inv it is showing 3945 chassis but in show ver it is showing 3945e iso imsge.
    so still confused how to identify the chassis.
    or it can be identified only by iso image.
    Thanks
    kshitij
    --
    To respond to this post, please click the following link: <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/8774162> http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/8774162 or simply reply to this email.

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Brett Tiller on 26-11-2012 03:22:43 PM
    Hi Kshitij,
    You should be able to get the router chassis and hardware via the command: 'show diag | inc FRU'.
    It sounds like you need to upgrade the ROMMON software on the router, so that the SRE hardware is recognized.  You can download the ROMMON software from http://www.cisco.com/cisco/software/navigator.html?a=a&i=rpm .  You'll need to go through the selections to locate it such as what I've listed below. After downloading the IOS ROMMON software you can upgrade the router via command: "upgrade rom-monitor file ftp://<ip>/file"
    1.  Click 'Cisco IOS and NX-OS software'
    2. Click 'Cisco IOS'
    3. Click '<a>Cisco IOS Software Release 15M&T'</a>
    4. Click '<a>Cisco IOS 15.1M&T'</a>
    5. Click 'Routers'
    6. Click 'Branch Routers'
    7. Click 'Cisco 3900 Series Integrated Routers'
    8. Click 'Cisco 3945E Integrated Services Router'
    9. For Software Type click 'IOS ROMMON Software'
     
    Thanks,
    Brett

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Kshitij Purwar on 03-12-2012 09:33:57 AM
    Hi Brett,
    below is the O/P from router
    yourname#show diag | inc FRU
            Product (FRU) Number     : CISCO3945-CHASSIS
            Product (FRU) Number     : C3900-SPE250/K9
            Product (FRU) Number     : PWR-3900-AC
            Product (FRU) Number     : SM-SRE-910-K9


    it is showing 3945 router,but in show ver it shows 354e iso image.
    can you please here,is it 3945 or 3945e router.
     
    Thanks
    kshitij

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Brett Tiller on 03-12-2012 01:56:09 PM
    Hi Kshitij,

    Unfortunately I don't have a 3945e ISR in my lab; however an easy way to identify whether you have a 3945e or a 3945 ISR is by the number of GE Interfaces.  The 3945e has 4 while the 3945 has 3.  I've attached a link to a document that does a side-by-side comparison on page 2 of the different ISR routers including the 3945e/3945. 
    www.cisco.com/en/US/prod/collateral/routers/ps10538/aag_c45_556315.pdf
    Thanks,
    Brett

    Subject: RE: New Message from Manuka Jayakody in Service Ready Engine Virtualization
    Replied by: Kshitij Purwar on 03-12-2012 02:29:15 PM
    Thanks Manuka and Brett for helping me here.
    I got it I have 3945e.

    I have upgraded the router rommon 15.1 (1r)T5 from 15.1 (1r) T4 which was default.
    But still I am not able to install sre-v on sre 900,910.
    Kindly see the attached logs.

    Thanks
    kshitij
    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, December 04, 2012 1:44 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Manuka Jayakody in Service Ready Engine Virtualization - SRE-V Technical Questions: RE: find new intresting issue on SRe 3945 router

    Manuka Jayakody has created a new message in the forum "SRE-V Technical Questions": -------------------------------------------------------------- Hi Kshitij,
    PID "C3900-SPE250/K9" means that you have a 3945e router. 3925, 3945, 3925e, 3945e share the same chassis and that's why you see the "CISCO3945-CHASSIS" in the output.
    if you have a 3945 you should see the PID as C3900-SPE150/K9.
    3925 - C3900-SPE100/K9
    3925e - C3900-SPE200/K9
    thanks
    Manuka
    --
    To respond to this post, please click the following link: http://developer.cisco.com/web/srev/community/-/message_boards/view_message/9043375 or simply reply to this email.

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Manuka Jayakody on 03-12-2012 02:13:34 PM
    Hi Kshitij,
    PID "C3900-SPE250/K9" means that you have a 3945e router. 3925, 3945, 3925e, 3945e share the same chassis and that's why you see the "CISCO3945-CHASSIS" in the output.
    if you have a 3945 you should see the PID as C3900-SPE150/K9.
    3925 - C3900-SPE100/K9
    3925e - C3900-SPE200/K9
    thanks
    Manuka

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Brett Tiller on 03-12-2012 04:08:11 PM
    Hi Kshitij,

    Please try attaching the logs again.  I don't see them with your post.
     
    Thanks,
    Brett

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Kshitij Purwar on 04-12-2012 11:51:39 AM
    Brett Tiller:
    Hi Kshitij, Please try attaching the logs again.  I don't see them with your post.   Thanks, Brett

     
    Hi Brett,
    kindly find the attached logs.
    Thanks
    kshitij

    Subject: RE: New Message from Kshitij Purwar in Service Ready Engine Virtualization
    Replied by: Kshitij Purwar on 04-12-2012 12:17:35 PM
    Hi Brett,

    There are two text files,sre900 and sre910.

    Thanks
    kshitij

    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, December 04, 2012 11:22 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Kshitij Purwar in Service Ready Engine Virtualization - SRE-V Technical Questions: RE: find new intresting issue on SRe 3945 router

    Kshitij Purwar has created a new message in the forum "SRE-V Technical Questions": --------------------------------------------------------------
    Brett Tiller:
    Hi Kshitij, Please try attaching the logs again.  I don't see them with your post.   Thanks, Brett


    Hi Brett,
    kindly find the attached logs.
    Thanks
    kshitij
    --
    To respond to this post, please click the following link: http://developer.cisco.com/web/srev/community/-/message_boards/view_message/9080913 or simply reply to this email.

    Subject: RE: New Message from Kshitij Purwar in Service Ready Engine Virtualization
    Replied by: Radhika Miriyala on 04-12-2012 12:25:35 PM
    Brett,
    The attachments are not showing up in the email but if you go to the forum you should be able to download. I will send them  to you via  a separate email

    Thanks,
    Radhika

    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, December 04, 2012 10:18 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Kshitij Purwar in Service Ready Engine Virtualization - SRE-V Technical Questions: RE: New Message from Kshitij Purwar in Service Ready Engine Virtualization

    Kshitij Purwar has created a new message in the forum "SRE-V Technical Questions": -------------------------------------------------------------- Hi Brett,

    There are two text files,sre900 and sre910.

    Thanks
    kshitij

    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, December 04, 2012 11:22 PM
    To: cdicuser@developer.cisco.com<mailto:cdicuser@developer.cisco.com>
    Subject: New Message from Kshitij Purwar in Service Ready Engine Virtualization - SRE-V Technical Questions: RE: find new intresting issue on SRe 3945 router

    Kshitij Purwar has created a new message in the forum "SRE-V Technical Questions": --------------------------------------------------------------
    Brett Tiller:
    Hi Kshitij, Please try attaching the logs again. I don't see them with your post. Thanks, Brett


    Hi Brett,
    kindly find the attached logs.
    Thanks
    kshitij
    --
    To respond to this post, please click the following link: http://developer.cisco.com/web/srev/community/-/message_boards/view_message/9080913 or simply reply to this email.
    --
    To respond to this post, please click the following link: http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/9081229 or simply reply to this email.

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Brett Tiller on 04-12-2012 01:55:26 PM
    Hi Kshitij,

    I'm glad that the router now recognizes the 900 and 910 service modules.  If you haven't already done so you'll need to configure the SM interfaces for each service module.  I've provided a snippet of an example configuration below.  You can read more detail about the configuration in the Installation and Configuration Guide section "Configuring the Cisco SRE Service Module Interfaces on the Router".  This guide can be downloaded from http://developer.cisco.com/web/srev/documentation .  If you've already configured the interfaces, please send your router configuration.
    Router Configuration Snippet
    interface GigabitEthernet 0/0
      ip address 192.168.1.60 255.255.255.0
     
    interface SM1/0
       ip unnumbered GigabitEthernet0/0
       service-module ip address 192.168.1.61 255.255.255.0
       service-module ip default-gateway 192.168.1.60
     
    interface SM1/1
       switchport mode trunk
     
    interface SM2/0
       ip unnumbered GigabitEthernet0/0
       service-module ip address 192.168.1.65 255.255.255.0
       service-module ip default-gateway 192.168.1.60
     
    interface SM2/1
       switchport mode trunk
     
    ip route 192.168.1.61 255.255.255.255 SM1/0
    ip route 192.168.1.65 255.255.255.255 SM2/0
     
    Thanks,
    Brett

    Subject: RE: New Message from Brett Tiller in Service Ready Engine Virtualization -
    Replied by: Kshitij Purwar on 04-12-2012 09:04:35 PM
    Thanks Brett,

    I had tried, but still I am not able to install sre-v on any blade.

    As you can see for sre-910,I cannot see any hardware details. I put it on other 3934e router which has default ISO and already running one sre, but still it does not recognize hardware details.

    Thanks
    kshitij
    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Wednesday, December 05, 2012 1:25 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Brett Tiller in Service Ready Engine Virtualization - SRE-V Technical Questions: RE: find new intresting issue on SRe 3945 router

    Brett Tiller has created a new message in the forum "SRE-V Technical Questions": -------------------------------------------------------------- Hi Kshitij,

    I'm glad that the router now recognizes the 900 and 910 service modules.  If you haven't already done so you'll need to configure the SM interfaces for each service module.  I've provided a snippet of an example configuration below.  You can read more detail about the configuration in the Installation and Configuration Guide section "Configuring the Cisco SRE Service Module Interfaces on the Router".  This guide can be downloaded from http://developer.cisco.com/web/srev/documentation .  If you've already configured the interfaces, please send your router configuration.
    Router Configuration Snippet
    interface GigabitEthernet 0/0
      ip address 192.168.1.60 255.255.255.0

    interface SM1/0
       ip unnumbered GigabitEthernet0/0
       service-module ip address 192.168.1.61 255.255.255.0
       service-module ip default-gateway 192.168.1.60

    interface SM1/1
       switchport mode trunk

    interface SM2/0
       ip unnumbered GigabitEthernet0/0
       service-module ip address 192.168.1.65 255.255.255.0
       service-module ip default-gateway 192.168.1.60

    interface SM2/1
       switchport mode trunk

    ip route 192.168.1.61 255.255.255.255 SM1/0
    ip route 192.168.1.65 255.255.255.255 SM2/0

    Thanks,
    Brett
    --
    To respond to this post, please click the following link: http://developer.cisco.com/web/srev/community/-/message_boards/view_message/9084651 or simply reply to this email.

    Subject: RE: find new intresting issue on SRe 3945 router
    Replied by: Brett Tiller on 05-12-2012 12:56:59 PM
    Hi Kshitij,

    I'm sorry that you're having so much trouble getting everything set up.  I have a few steps below and requests for data.

    1.  Please send me your latest router configuration.  On the router type: 'show run' and send me the data.
    2.  On the SRE 910, please power down the router, remove the service module then reseat it.  Power back up the router. Then retry the status command.
    3.  Please verify that your ftp server is working correctly by downloading a file from it to another workstation.
     
    Thanks,
    Brett