No record in endusernumplanmap for enduser with device and DN

Version 1
    This document was generated from CDN thread

    Created by: Shivinder Singh on 31-10-2012 09:48:35 AM
    Using the backend database and SQL, I'm trying to find the misconfiguration (or query error) because of which some endusers (employees) are present in numplan, have an associated device and DN, but dont have an association in endusernumplanmap.
    For instance, the following the first query returns rows, but not the second one (based on enduser.pkid). Both endusers show up on end user configuration page and have one controlled device.
    select euser.firstname, euser.lastname,n.dnorpattern,enmap.tkdnusage
                from
                enduser euser,
                endusernumplanmap enmap,
                numplan n
                where 1=1
                and enmap.fkenduser=euser.pkid
                and enmap.fknumplan=n.pkid
                and euser.pkid='pkid1'

    select euser.firstname, euser.lastname,n.dnorpattern,enmap.tkdnusage
                from
                enduser euser,
                endusernumplanmap enmap,
                numplan n
                where 1=1
                and enmap.fkenduser=euser.pkid
                and enmap.fknumplan=n.pkid
                and euser.pkid='pkid2'

    Subject: RE: No record in endusernumplanmap for enduser with device and DN
    Replied by: David Staudt on 01-11-2012 06:24:31 PM
    Does seem unexpected...
    For a specific example, can you find out which table is missing its record?

    Subject: Automatic reply: New Message from David Staudt in Administration XML (AXL)
    Replied by: Erick Wellnitz on 01-11-2012 06:26:44 PM
    I will be in training on 11/1 and 11/2.  I will reply to all email upon my return.  Thank you!

    Subject: RE: New Message from Shivinder Singh in Administration XML (AXL) - Administ
    Replied by: Dennis Heim on 02-11-2012 10:50:44 AM
    Can you try unassociating their device to them and then adding it back?

    Dennis Heim | Sr. UC Engineer
    World Wide Technology | 314.212.1814 | dennis.heim@wwt.com<mailto:dennis.heim@wwt.com>
    “Creating Impact, Ignition & Scalability”

    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Friday, November 02, 2012 11:41 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Shivinder Singh in Administration XML (AXL) - Administration XML Questions: RE: New Message from David Staudt in Administration XML (AXL) - Administrat

    Shivinder Singh has created a new message in the forum "Administration XML Questions": -------------------------------------------------------------- David, the records are missing from the endusernumplanmap table.

    For e.g. one of the employee who’s records is missing from endusernumplanmap, this is what I found:


    - The person is present is enduser table (pulled from active directory)

    - Person has a device (verified in device, enduser and enduserdevicemap tables)

    - The line that rings on this device is present in numplan table (verified from device,numplan and devicenumplanmap tables)

    - But there is no record in endusernumplanmap (verified from enduser, numplan and endusernumplanmap tables)

    Any suggestions?
    --
    To respond to this post, please click the following link: http://developer.cisco.com/web/axl/forums/-/message_boards/view_message/8264932 or simply reply to this email.

    Subject: RE: New Message from David Staudt in Administration XML (AXL) - Administrat
    Replied by: Shivinder Singh on 02-11-2012 10:41:10 AM
    David, the records are missing from the endusernumplanmap table.

    For e.g. one of the employee who’s records is missing from endusernumplanmap, this is what I found:


    -          The person is present is enduser table (pulled from active directory)

    -          Person has a device (verified in device, enduser and enduserdevicemap tables)

    -          The line that rings on this device is present in numplan table (verified from device,numplan and devicenumplanmap tables)

    -          But there is no record in endusernumplanmap (verified from enduser, numplan and endusernumplanmap tables)

    Any suggestions?

    Subject: RE: New Message from Dennis Heim in Administration XML (AXL) - Administrati
    Replied by: Shivinder Singh on 02-11-2012 11:48:45 AM
    Our main callmanger guy (not the same guy who implemented – that was a contractor) found out the primary extension was set to None on the end user configuration page. Their device rings as expected though ☺

    Checked several users who were missing in endusernumplanmap, and all of them ended up having no primary extension on end user configuration page. Is there a way to automate the 107 users that are missing primary extension?

    Subject: Re: New Message from Dennis Heim in Administration XML (AXL) - Administrati
    Replied by: Sascha Monteiro on 03-11-2012 11:53:44 PM
    you might have to associate the line to the user?

    On Sat, Nov 3, 2012 at 4:50 AM, Cisco Developer Community Forums <
    cdicuser@developer.cisco.com> wrote:

    > Dennis Heim has created a new message in the forum "Administration XML
    > Questions": --------------------------------------------------------------
    > Can you try unassociating their device to them and then adding it back?
    >
    > Dennis Heim | Sr. UC Engineer
    > World Wide Technology | 314.212.1814 | dennis.heim@wwt.com<mailto:
    > dennis.heim@wwt.com>
    > “Creating Impact, Ignition & Scalability”
    >
    > From: Cisco Developer Community Forums [mailto:
    > cdicuser@developer.cisco.com]
    > Sent: Friday, November 02, 2012 11:41 AM
    > To: cdicuser@developer.cisco.com
    > Subject: New Message from Shivinder Singh in Administration XML (AXL) -
    > Administration XML Questions: RE: New Message from David Staudt in
    > Administration XML (AXL) - Administrat
    >
    > Shivinder Singh has created a new message in the forum "Administration XML
    > Questions": --------------------------------------------------------------
    > David, the records are missing from the endusernumplanmap table.
    >
    > For e.g. one of the employee who’s records is missing from
    > endusernumplanmap, this is what I found:
    >
    >
    > - The person is present is enduser table (pulled from active directory)
    >
    > - Person has a device (verified in device, enduser and enduserdevicemap
    > tables)
    >
    > - The line that rings on this device is present in numplan table (verified
    > from device,numplan and devicenumplanmap tables)
    >
    > - But there is no record in endusernumplanmap (verified from enduser,
    > numplan and endusernumplanmap tables)
    >
    > Any suggestions?
    > --
    > To respond to this post, please click the following link:
    > http://developer.cisco.com/web/axl/forums/-/message_boards/view_message/8264932or simply reply to this email.
    > --
    > To respond to this post, please click the following link:
    > http://developer.cisco.com/web/axl/forums/-/message_boards/view_message/8263805or simply reply to this email.

    Subject: Re: New Message from Sascha Monteiro in Administration XML (AXL) - Administ
    Replied by: Sascha Monteiro on 04-11-2012 12:30:44 AM
    you need to set it's directory number as primary extension on the enduser
    page

    On Sun, Nov 4, 2012 at 5:53 PM, Cisco Developer Community Forums <
    cdicuser@developer.cisco.com> wrote:

    > Sascha Monteiro has created a new message in the forum "Administration XML
    > Questions": --------------------------------------------------------------
    > you might have to associate the line to the user?
    >
    > On Sat, Nov 3, 2012 at 4:50 AM, Cisco Developer Community Forums <
    > cdicuser@developer.cisco.com> wrote:
    >
    > > Dennis Heim has created a new message in the forum "Administration XML
    > > Questions":
    > --------------------------------------------------------------
    > > Can you try unassociating their device to them and then adding it back?
    > >
    > > Dennis Heim | Sr. UC Engineer
    > > World Wide Technology | 314.212.1814 | dennis.heim@wwt.com<mailto:
    > > dennis.heim@wwt.com>
    > > “Creating Impact, Ignition & Scalability”
    > >
    > > From: Cisco Developer Community Forums [mailto:
    > > cdicuser@developer.cisco.com]
    > > Sent: Friday, November 02, 2012 11:41 AM
    > > To: cdicuser@developer.cisco.com
    > > Subject: New Message from Shivinder Singh in Administration XML (AXL) -
    > > Administration XML Questions: RE: New Message from David Staudt in
    > > Administration XML (AXL) - Administrat
    > >
    > > Shivinder Singh has created a new message in the forum "Administration
    > XML
    > > Questions":
    > --------------------------------------------------------------
    > > David, the records are missing from the endusernumplanmap table.
    > >
    > > For e.g. one of the employee who’s records is missing from
    > > endusernumplanmap, this is what I found:
    > >
    > >
    > > - The person is present is enduser table (pulled from active directory)
    > >
    > > - Person has a device (verified in device, enduser and enduserdevicemap
    > > tables)
    > >
    > > - The line that rings on this device is present in numplan table
    > (verified
    > > from device,numplan and devicenumplanmap tables)
    > >
    > > - But there is no record in endusernumplanmap (verified from enduser,
    > > numplan and endusernumplanmap tables)
    > >
    > > Any suggestions?
    > > --
    > > To respond to this post, please click the following link:
    > >
    > http://developer.cisco.com/web/axl/forums/-/message_boards/view_message/8264932orsimply reply to this email.
    > > --
    > > To respond to this post, please click the following link:
    > >
    > http://developer.cisco.com/web/axl/forums/-/message_boards/view_message/8263805orsimply reply to this email.
    > --
    > To respond to this post, please click the following link:
    > http://developer.cisco.com/web/axl/forums/-/message_boards/view_message/8290507or simply reply to this email.