Can I export traffic to mgf interface?

Version 1
    This document was generated from CDN thread

    Created by: Vijay Raman on 01-08-2012 11:35:23 AM
     
    Hi,
    In our router 3900 we have sre-900-k9.  If we configure the interfaces following the instructions in Installation and Configuration Guide for Cisco Service Ready Engine Virtualization as follows, can we use RITE to export traffic to sm 1/1?:
     
    interface SM1/0
     ip address 172.25.192.130 255.255.255.240
     service-module ip address 172.25.192.131 255.255.255.240
     !Application: VMware ESXi 5.0.0 build-474610 running on SRE
     service-module ip default-gateway 172.25.192.130
     hold-queue 60 out
    end
    interface SM1/1
     description Internal switch interface connected to Service Module
     switchport mode trunk
     no ip address
    end
    interface Vlan30
     ip address 172.25.192.147 255.255.255.240
    end
    If we create virtual interface vlan1, traffic is exported to sm1/1, but if we use vlan30 we don't see any exported traffic at sm1/1.
     
    Thanks!
     

    Subject: RE: New Message from Vijay Raman in Service Ready Engine Virtualization - S
    Replied by: Brett Tiller on 01-08-2012 04:13:45 PM
    Hi Vijay,

    I don’t see the configuration for RITE in the running configuration you provided.  Please include your actual configuration.  You mentioned that the export to the SM 1/1 interface works when you have configured vlan1, but not vlan30 in the router.  I’d like to see the configuration for each as well.

    Thanks,

    Brett Tiller
    Custom Application Engineer
    http://developer.cisco.com/web/axp
    http://developer.cisco.com/web/srev
    [cid:image001.png@01CD6FE7.6CE30C00]

    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Wednesday, August 01, 2012 8:35 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Vijay Raman in Service Ready Engine Virtualization - SRE-V Technical Questions: Can I export traffic to mgf interface?

    Vijay Raman has created a new message in the forum "SRE-V Technical Questions":

    --------------------------------------------------------------

    Hi,
    In our router 3900 we have sre-900-k9.  If we configure the interfaces following the instructions in Installation and Configuration Guide for Cisco Service Ready Engine Virtualization as follows, can we use RITE to export traffic to sm 1/1?:

    interface SM1/0
    ip address 172.25.192.130 255.255.255.240
    service-module ip address 172.25.192.131 255.255.255.240
    !Application: VMware ESXi 5.0.0 build-474610 running on SRE
    service-module ip default-gateway 172.25.192.130
    hold-queue 60 out
    end
    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk
    no ip address
    end
    interface Vlan30
    ip address 172.25.192.147 255.255.255.240
    end
    If we create virtual interface vlan1, traffic is exported to sm1/1, but if we use vlan30 we don't see any exported traffic at sm1/1.

    Thanks!

    --
    To respond to this post, please click the following link:

    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/6215255>

    or simply reply to this email.

    Subject: RE: Can I export traffic to mgf interface?
    Replied by: Vijay Raman on 02-08-2012 09:36:17 AM
    Hi Brett,

    Here is the configuration:

    interface GigabitEthernet0/0
    description *** PRIMARY -AT&T/86/KQGN/572108//PT/DMARC-3RD SERVER ROOM SUITE 300 WALLMOUNT  ***
    no ip address
    ip traffic-export apply RITE
    duplex auto
    speed auto
    service-policy output WAN-EDGE-4-CLASS
    !
    interface GigabitEthernet0/0.100
    encapsulation dot1Q 100
    ip vrf forwarding campus-NCN
    ip address 10.95.189.128 255.255.255.254
    ip wccp vrf campus-NCN 62 redirect in
    ip traffic-export apply RITE
    snmp trap link-status
    •             The policy was added to sub interface.
    ip traffic-export profile RITE
      interface SM1/0
      bidirectional
      mac-address 0080.8c00.0001
    interface Vlan30
    description *** ESXi-01-VM Servers VLAN 198.55.147.32/29 ***
    ip vrf forwarding campus-NCN
    ip address 198.55.147.38 255.255.255.248
    ip traffic-export apply RITE

    Thanks!

    Subject: RE: Can I export traffic to mgf interface?
    Replied by: Brett Tiller on 02-08-2012 05:31:19 PM
    Hi Vijay,

    Thanks for your configuration.  I see that you are collecting packets from Vlan30 and GigabitEthernet0/0.100 for the SM1/0 interface.  Regarding your question about Vlan30, in the example provided in the Installation and Configuration Guide, the assumption is that packets are coming from the switch on vlan30 and that you want these to reach a particular VM.  For this to work within ESXI you need to create a VM Port Group with ID 30, and assign that as the Network Adapter of your particular VM. 

    If you've already completed the steps above and still see the issue with RITE, please try adding the campus-NCN vrf to the SM 1/0 interface and see if that resolves the issue.  If it's still not working, please send the following:

    1.  The version of SRE-V being employed.

    2.  The router IOS version

    3.  Enclose a screen shot from the vSphere client of your network configuration.  You can get this by clicking on the host, then the Configuration tab, and finally click on the Networking link on the left.

    Thanks,

    Brett

    Subject: RE: Can I export traffic to mgf interface?
    Replied by: Brett Tiller on 02-08-2012 08:10:32 PM
    Hi Vijay,

    I forgot to mention that once you assign your VM to the Network Adapter that has the vlan ID, that in your router you may need to create a route to the VM.  I've provided an example below where IP 198.55.147.39 is the IP of the VM.

    config t
    ip route 198.55.147.39 255.255.255.255 Vlan30
    exit
    copy run start

    Thanks,

    Brett