Dataset Status is Failed - CUIC Error

Version 1
    This document was generated from CDN thread

    Created by: Joseph Walsh on 08-07-2012 08:29:21 PM
    Hey all...
     
    I'm hoping someone has seen this type of error and has some insight.  This is occuring every time a user tries to run a report in CUIC.  The page shows "Dataset Status is Failed" and when you click "Error Details" the following shows:
     

    <table border="0">
    <tbody>
    <tr>
    <td style="padding-left: 10px;" align="left">Error information:</td>
    </tr>
    <tr>
    <td id="errMsg" style="padding-left: 10px;" align="left">com.cisco.ccbu.cuic.businesslogic.engine.CuicLowResourcesException: The number of rows requested is not available. Requested: 50 Available: 49 at com.cisco.ccbu.cuic.businesslogic.engine.CuicEngineRowsThrottler.checkoutRows(CuicEngineRowsThrottler.java:216) at com.cisco.ccbu.cuic.objectmodel.engine.CuicDataSetBuilderJexl.loadData(CuicDataSetBuilderJexl.java:93) at com.cisco.ccbu.cuic.businesslogic.datasource.CuicDataSourceServiceManagerImpl.getDataSetBuilder(CuicDataSourceServiceManagerImpl.java:1005) at com.cisco.ccbu.cuic.businesslogic.engine.CuicDataProcessingCenterWorkerRunnable.runReport(CuicDataProcessingCenterWorkerRunnable.java:335) at com.cisco.ccbu.cuic.businesslogic.engine.CuicDataProcessingCenterWorkerRunnable.run(CuicDataProcessingCenterWorkerRunnable.java:142) at com.cisco.ccbu.infra.threads.InstrumentedRunnable.run(InstrumentedRunnable.java:88) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) at java.lang.Thread.run(Thread.java:619) at com.cisco.ccbu.infra.threads.ThreadPoolThread.run(ThreadPoolThread.java:164)</td>
    </tr>
    </tbody>
    </table>

     
    Please let me know if anyone has any insight into what may be causing this.
     
    Thanks!

    Subject: RE: Dataset Status is Failed - CUIC Error
    Replied by: Senthil Kumar Natarajan on 19-07-2012 10:50:29 AM
    have you tried to copy the SQL to the query engine and see what rows are returned in HDS?

    Subject: RE: Dataset Status is Failed - CUIC Error
    Replied by: GREG GREBIN on 01-08-2012 12:49:00 PM
    I get the same error as Joe. Pasting the SQL into an HDS qry window works fine.

    I believe I fixed the issue by changing the BeginDate and EndDate in the Data Source from a DateTime specification to just Date. The custom DateTime option in CUIS 7.5 does not translate very well to CUIC.

    Subject: RE: Dataset Status is Failed - CUIC Error
    Replied by: GREG GREBIN on 03-08-2012 04:52:34 PM
    The error came back, so I guess removing the custom format fixed the issue for just a day. The same report running the same parameters that worked yesterday, fails today. Is this a bug in CUIC ? We are currently running 8.5.2 until we get all the CUIS V7.x reports migrated

    Subject: Dataset status is Failed (Database error)- CUIC Bug?
    Replied by: Rhonda Walker on 16-08-2012 11:17:31 AM
    have you tried to copy the SQL to the query engine and see what rows are returned in HDS?

     
    Hi Senthil,
     
    We are running 8.5(4) build 1 and have also been getting this error sporadically with certain reports.  For hours instead of results we will get "Dataset status is Failed (Database error)," then occasionally the report will run.  I've been wondering if it fails related to some kind of background refresh within CUIC.
     
    Have you found out what's causing the problem?  Is this a known bug in CUIC?

    I saw that Greg was leaning towards the problem being related to converting CUIS datetime fields to CUIC, but that his solution did not provide long-term results.  
     
    Is someone at Cisco researching this issue?  If so, hopefully they will post something here. 

    Subject: RE: Dataset Status is Failed - CUIC Error
    Replied by: Terrance Bailey on 12-07-2013 09:51:43 AM
    I am a novice User, and not a programmer. I just came across a similiar error.  Our IT dept downloaded a patch.  If this is not correct please accept my apologies.  I will delete the thread.

    Is it CUIC rowcount resource leak

    http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCua78974

    The link to the patch:  Ultimately this is fixed by installing a patch found at cisco.com
    [url=http://software.cisco.com/download/release.html?mdfid=282163829&softwareid=282377062&release=9.1(1)&relind=AVAILABLE&rellifecycle=&reltype=latest]http://software.cisco.com/download/release.html?mdfid=282163829&softwareid=282377062&release=9.1(1)&relind=AVAILABLE&rellifecycle=&reltype=latest

    CUIC rowcount resource leak 
    Symptom:
    CUIC rowcount resource leak

    Conditions:
    When multiple fetching reports at a time

    Workaround:

    Need to restart  CUIC service by using the following CLI:

    utils service stop Intelligence Center Reporting Service
    utils service start Intelligence Center Reporting Service