My VMs (CentOS6.2) residing on two different SRE are unable to talk to each

Version 1
    This document was generated from CDN thread

    Created by: Himanshu Jain on 13-06-2012 06:55:10 AM
    I have two ISR G2 (Cisco3900) routers.
    there network domain being 10.104.231.64-79 255.255.255.240
     
    my default router is 10.104.231.65
    My two ISR G2 have IP assigned as
    ---10.104.231.71 (ISR G2 )
    -------- 10.104.231.74 (SRE module having EXSI 4.1) (its SM 3/0)
    --------------10.104.231.75 (VM runing centos 6.2)
    ---10.104.231.72 (ISR G2 )
    -------- 10.104.231.76 (SRE module having EXSI 4.1) (its SM 4/0)
    --------------10.104.231.77 (VM runing centos 6.2)
     
    (a) The problem is i am unable to ping 10.104.231.75 from outside network.
    same thing goes with  10.104.231.77 (unable to ping from outside)
    (b) i am able to ping both the ISRs (ip 71 and 72 from outside network)
    (c) i am able to ping both the SRE (ip 74 and 76 from outside network)
    (d) i am able to ping both the VMs (ip address 75 and 77) from both the ISRs respectively (ip 71 and 72)
    (e) i am able to ping SRE (both) and ISR(both) from any of the VMs (ip 75 and 77)
    (f) Traceroute (tracert 10.104.231.75) shows i am able to reach upto isr with ip 71 but after that packets get lost.
     
    PS:
    (1) i have attached the route table of both the ISRs.
    (2) i have attached the tracert for vm with ip 75.
    (3) i have attached the setup (VM hypervisor) snapshop.
     
    Question:-
    why i am unable to ping the VM as stated in (a). can somebdy plz point me to what i am missing??
    Also is it because i am using the same vmk0 interface??

    Subject: RE: My VMs (CentOS6.2) residing on two different SRE are unable to talk to
    Replied by: Brett Tiller on 07-08-2012 08:56:01 PM
    Hi Himanshu,

    If you haven't resolved this issue, it looks to me like your configuration is correct for SM 3/0, but I don't see any ip routes or the configuration for your SM4/0 interface.   You'll need to add IP routes for the SM4/0 interface as well.

    Thanks,

    Brett

    Subject: RE: My VMs (CentOS6.2) residing on two different SRE are unable to talk to
    Replied by: Kshitij Purwar on 08-08-2012 02:12:18 PM
    Hi Himanshu,

    you have to create one more vm network from vswitch0 and add your vm to that network and vm route to sm 4/0.

    Regards
    Kshitij