Voice Mail import - cannot re-import after removing the alias

Version 1
    This document was generated from CDN thread

    Created by: Chun Hung Wong on 21-05-2012 08:45:49 PM
     
    I am using Unity connection (8.5).  The followins is the problem scenario:
     
    a) phonenum 28251000 removes the voice mail feature, so the system send
    delete VM API to CUPI. This step is ok without problem.
     
    request: DELETE /vmrest/users/d842a51c-8b46-4187-a3da-4df6fe8abd2b
    response ->  statusCode:204, result:
     
    b) Later on, we want to add the VM feature again to this phonenum. The
    problem is that the CUPI import list API cannot find the phonenum (there is
    no alias showing 28251000 as below). In normal case, it should show the
    record<ImportUser....>  with alias "28251000" (just like the newly added on
    80000002).
     
    request: GET /vmrest/import/users/ldap
    response ->  statusCode:200, result:<?xml version="1.0" encoding="UTF-8"
    standalone="yes"?><ImportUsers
    total="2"><ImportUser><alias>80000002</alias><firstName></firstName><lastNam
    e>80000002</lastName><pkid>4e8b928c-9835-4433-9b40-9976b6a45192</pkid></Impo
    rtUser><ImportUser><alias>90000002</alias><firstName></firstName><lastName>9
    0000002</lastName><pkid>e9e8c758-b50b-4270-89f0-3fc015ad719b</pkid></ImportU
    ser></ImportUsers>
     
    It seems that I hit the bug (CSCsy32273) and it seems that it is not fix in this version.  Do Cisco have any patch or something for fixing this bug, since this bug is fixed in 7.0, 7.1, even 8.0, since it is very strange that the bug fixed in early version but not in latest version.  Please advice.