7926G Emulator and NetBeans 7.1.1

Version 1
    This document was generated from CDN thread

    Created by: badojang2000 (simulated) on 13-04-2012 04:56:22 AM
    Are there any compatibility issues with the 7926G emulator and the latest version of Netbeans?
     
    Using  the 7926G Emulator Skin Guide for installation of the emulator skin, I get the following error message in device-manager.log:
     

    [    736]  DEBUG - un.jme.toolkit.bootstrap.Batch - Initializing object device-adapter.Cisco7926 
    [    736]  DEBUG - strap.BasicObjectConfiguration - Setting field name to device-adapter.Cisco7926 using class com.sun.jme.toolkit.propertyeditors.StringEditor 
    [    736]  DEBUG - strap.BasicObjectConfiguration - Setting field deviceRegistrationManager 
    [    737]  DEBUG - strap.BasicObjectConfiguration - Setting field deviceAdapter 
    [    737]   WARN - strap.BasicObjectConfiguration - Could not find object device-class-adapter-CldcFxEmulator 
    [    738]  ERROR - oolkit.bootstrap.MainNamespace - java.lang.IllegalArgumentException: Could not find object device-class-adapter-CldcFxEmulator 
    java.lang.IllegalArgumentException: Could not find object device-class-adapter-CldcFxEmulator
    at com.sun.jme.toolkit.bootstrap.BasicObjectConfiguration.initializeField(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.BasicObjectConfiguration.initializeField(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.BasicObjectConfiguration.initializeFields(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.ObjectConfiguration.initializeObject(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.Batch.initializeObject(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.Batch.initializeObjects(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.Namespace.startBatch(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.Namespace.runModules(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.MainNamespace.runModules(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.MainNamespace.run(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.Container.run(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.Container.start(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.Container.main(Unknown Source)
    [    739]   INFO - un.jme.toolkit.bootstrap.Batch - Flushing... 

    Subject: RE: 7926G Emulator and NetBeans 7.1.1
    Replied by: David Staudt on 20-04-2012 02:18:47 PM
    Is the default emulator/skin working?  Only the 7926 skin is failing?

    Subject: RE: 7926G Emulator and NetBeans 7.1.1
    Replied by: Nate Strech on 16-05-2012 10:21:14 AM
    I couldn't get the 7926G emulator to work with the latest release of NetBeans 7.x.  It's working just fine after downgrading to NetBeans 6.9.1.

    Subject: RE: 7926G Emulator and NetBeans 7.1.1
    Replied by: Kevin Penrose on 03-07-2012 03:38:50 PM
    I have NetBeans 7.2 RC1 installed, and after following the instructions for installing the emulator, I don't get any error messages, but after the NetBeans emulator loader does its thing, I still don't see the Cisco 7926 emulator in the list of available emulators.  There doesn't appear to any message or warning that there is anything out of sorts.
     
    Some feedback on this from Cisco would be helpful.  I hate to maintain different versions of IDEs just to use a particular development tool.
     
     
    Are there any compatibility issues with the 7926G emulator and the latest version of Netbeans?
     
    Using  the 7926G Emulator Skin Guide for installation of the emulator skin, I get the following error message in device-manager.log:
     

    [    736]  DEBUG - un.jme.toolkit.bootstrap.Batch - Initializing object device-adapter.Cisco7926 
    [    736]  DEBUG - strap.BasicObjectConfiguration - Setting field name to device-adapter.Cisco7926 using class com.sun.jme.toolkit.propertyeditors.StringEditor 
    [    736]  DEBUG - strap.BasicObjectConfiguration - Setting field deviceRegistrationManager 
    [    737]  DEBUG - strap.BasicObjectConfiguration - Setting field deviceAdapter 
    [    737]   WARN - strap.BasicObjectConfiguration - Could not find object device-class-adapter-CldcFxEmulator 
    [    738]  ERROR - oolkit.bootstrap.MainNamespace - java.lang.IllegalArgumentException: Could not find object device-class-adapter-CldcFxEmulator 
    java.lang.IllegalArgumentException: Could not find object device-class-adapter-CldcFxEmulator
    at com.sun.jme.toolkit.bootstrap.BasicObjectConfiguration.initializeField(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.BasicObjectConfiguration.initializeField(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.BasicObjectConfiguration.initializeFields(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.ObjectConfiguration.initializeObject(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.Batch.initializeObject(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.Batch.initializeObjects(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.Namespace.startBatch(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.Namespace.runModules(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.MainNamespace.runModules(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.MainNamespace.run(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.Container.run(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.Container.start(Unknown Source)
    at com.sun.jme.toolkit.bootstrap.Container.main(Unknown Source)
    [    739]   INFO - un.jme.toolkit.bootstrap.Batch - Flushing... 


    Subject: RE: 7926G Emulator and NetBeans 7.1.1
    Replied by: Kevin Penrose on 03-07-2012 04:27:25 PM
    Is the default emulator/skin working?  Only the 7926 skin is failing?

     
    The default emulator works for me on NetBeans 7.2RC1; loading the new emulator doesn't work - it doesn't show up in the list of emulators.

    Subject: RE: 7926G Emulator and NetBeans 7.1.1
    Replied by: David Staudt on 12-07-2012 05:51:15 PM
    After some testing we've found that the 7926 skin will work with the following:
     
    - Netbeans 7.1.2 (latest)
    - Oracle Wireless Toolkit 3.0 (latest is 3.0.5)
     
    Two caveats of note:
     
    - The 'complete' Netbeans installation includes the Mobility features, and automatically installs the complete WTK 3.0.5.  It may be possible to also install the WTK 3.0 side-by-side, but care must be taken to install the 7926 skin files only in the WTK 3.0 SDK area.  In our setup we installed the base Netbeans 7.1.2, then added the Mobility plugin and installed the standalone WTK 3.0.
    - After adding the 7926 skin files to the WTK 3.0 directory structure, the 'Java ME SDK 3.0 Device Manager' tray icon must be 'Exit'-ed before restarting Netbeans and performing the 'Manage Emulators/Refresh' sequence.
     
    We are evaluating further updates to the skin to work with WTK 3.0.5, but the above at least allows use of the latest Netbeans.