Unable to change Agent state to "Not Ready"

Version 1
    This document was generated from CDN thread

    Created by: Anatoli Suckau on 30-11-2011 06:26:31 AM
    Hi guys,
     
    After installing Finesse 8.5.3 sucessfully I logged in an angent and changed state to "ready".
     
    Everytime I try to change the state to "not ready" I get the following error message:
     
    "The operation timed out or failed. Please try again or contact the administrator".
     
    Do anyone know, how to fix this error? Or is this a known issue?
     
    I would also deliver logfiles, but I'm not sure, which of them are relevant for this error.
     
    Thank you in advance for your help.
     
    Regards,
    Anatoli

    Subject: RE: New Message from Anatoli Suckau in 2385312 - General Questions: Unable
    Replied by: David Lender on 30-11-2011 04:07:13 PM
    Which Build are you using.  Build 400 or Build 629?.  The webservices and desktop log files would be helpful in determining the issue.  Refer to the Finesse Installation Guide on How to Obtain Logs using the CLI command



    file get activelog desktop recurs compress

    Subject: RE: New Message from Anatoli Suckau in 2385312 - General Questions: Unable
    Replied by: David Lender on 01-12-2011 09:47:13 AM
    From the logs It looks like agent 100 you logged in is a supervisor.  There are issues with supervisor and agent teams in build 400.  Please upgrade to latest build and retest.

    Subject: RE: Unable to change Agent state to "Not Ready"
    Replied by: David Lender on 01-12-2011 09:47:47 AM
    Also, Finesse build 629 requires UCCE 8.5(3) and UCM 8.6(1)

    Subject: RE: New Message from Anatoli Suckau in 2385312 - General Questions: Unable
    Replied by: Anatoli Suckau on 01-12-2011 05:37:38 AM
    Hi David,
     
    thank you for your response. We are using Build 400 with UCCE 7.5.1.
    I attached the relevant logs and reproduced the error today 12/01/2011 at 11:00 a.m. (GMT + 1)
     
    Hope the logs would help to determine the cause of the error.
     
    Regards,
    Anatoli

    Subject: RE: New Message from Anatoli Suckau in 2385312 - General Questions: Unable
    Replied by: David Lender on 01-12-2011 09:37:13 AM
    Build 400 has been deprecated.  Please download and install build 629.

    Subject: RE: New Message from Anatoli Suckau in 2385312 - General Questions: RE: Una
    Replied by: David Lender on 22-12-2011 09:53:27 AM
    Correct, the UCCEREalm.properties file is no longer to be edited. Use Finesse Administration to configure the CTI Server and other properties.
     
    Thank you.
     
    After configuration of the CTI-Parameter and AWDB connection I have now the problem, that I'm not able to login.
      
    Regarding the logs, it looks like the CTI-connection is working properly. The agents are also configured correct and a test login with CTIOS is also working.
     
    I have attached the logfiles and hope you can help me again in this case.
     
    Kind regards,
    Anatoli

    Subject: RE: Unable to change Agent state to "Not Ready"
    Replied by: Anatoli Suckau on 22-12-2011 06:54:01 AM
    Hi David,
     
    After upgrading our UCCE and CUCM and reinstalling Finesse (now Build -629) I've got the problem, that I can't find the UCCERealm.properties file in the directory. Is that configuration no more required?
     
    Configuring the finesse server without that file, I get the error message: "Invalid username or password..."
     
    Thank you in advance for your help.
     
    Kind regards,
    Anatoli