RE: recordutterance property

Version 1
    This document was generated from CDN thread

    Created by: Huthesha K on 13-09-2010 09:46:35 AM
    Hi,
     
    I am trying to get the uttarence in application.lastresult$.recording element. Following is my VXML script.

     
     
    <? xml version="1.0" encoding="UTF-8"?>
    <vxml version="2.1">
    <property name="recordutterance" value="true"/>
                 <form id="start">
                         <block>
                            <prompt>Please count from 0 to 9</prompt>
                         </block>
                      <field name="getDigits" type="digits" >
                               <filled> 
                                <prompt>Recording was <audio expr="application.lastresult$.recording"/></prompt>
                             </filled>
                      </field> 
                 </form>
    </vxml>
     
    When I run this script I am getting application.lastresult$.recording is undefined.
    Could you please tell me what is the problem with the above VXML script?

    Subject: RE: recordutterance property
    Replied by: Raghavendra Gutty Veeranagappa on 13-09-2010 12:51:41 PM
    Hi Huthesha,
     
    We have tested your script it is working fine for us.
    Have you installed ASR and HTTP server because The recordutterance property requires an HTTP server on your automatic speech recognition (ASR) server. You must install and start your HTTP server before the recordutterance property can be supported

    Thanks,
    Raghavendra

    Subject: RE: recordutterance property
    Replied by: Huthesha K on 14-09-2010 06:38:59 AM
    Hi Raghavendra,
     
                We are using nuance speech server. It  has recognizer, verifier, Speech server 5.0. Under verifier we have tomcat server up and running. And also we have deployed all the vxml applications in this tomcat server.  Is this setup correct? Could you please let me know what might be the issue?
     
    Thanks,
    Huthesh.

    Subject: RE: recordutterance property
    Replied by: Raghavendra Gutty Veeranagappa on 14-09-2010 07:17:51 AM
    Hi Huthesh,
     
    Please verify ASR configuration done in Voice Gateway,If possible please let us know your running config and logs by running following commands
     
    show running-config
    deb voip appli vxml all
     
    Thanks,
    Raghavendra

    Subject: RE: recordutterance property
    Replied by: Huthesha K on 15-09-2010 07:54:43 AM
    Hi Raghavendra,
     Thanks for your early response. I have attached the running configuration and vxml debug log. Please let me know if there any changes need to be made
     
    Thanks,
    Huthesh

    Subject: RE: recordutterance property
    Replied by: Anusha Kannappan on 15-09-2010 12:56:26 PM
    Hi,
     
    Thanks for sharing the running config as well as the debug logs as requested. 
     
    Assuming you have set the asr server IP Address in the running config, We found few discripencies. Please modify them and give a try and it should work.
     
    * In ASR server set the following configuration to the hostname addressable from
    router, instead of localhost: 
     
            Server/config/NSSserver.cfg:
     
                        Server.session.ossweb.machine <ip address>
     and                server.session.ossweb.port  VXIInteger 80
     
    * Also the directory where the recorded files must be saved should be same in NSSserver.cfg  and httpd.config
     for example in the NSSserver.cfg it should be 
    server.session.osswfm.directory    VXIString $(NSSSVRSDK)/session
     
    and in httpd.config it should be 
     
    DocumentRoot "C:\Program Files\Nuance\Speech Server 5.0\server\session"
     
     
    Thanks,
    Anusha

    Subject: RE: recordutterance property
    Replied by: Huthesha K on 16-09-2010 08:10:59 AM
    Hi,
     
    Thanks a lot, now its working.
     
    I made following changes in httpd.conf 
     
    DocumentRoot "C:/Program Files/Nuance/Speech Server 5.0/server/session"
    <Directory "C:/Program Files/Nuance/Speech Server 5.0/server/session">
     
    and also in Server/config/NSSserver.cfg  I changed  Server.session.ossweb.machine  to ip address of HTTP server and server.session.ossweb.port to port which is being used by HTTP server.
     
    Thanks,
    Huthesh