SRE-V failing to boot

Version 1

    Subject: RE: SRE-V failing to boot
    Replied by: Raghavendra Gutty Veeranagappa on 01-07-2011 07:19:11 AM
    Hi Sean,

    To return to router CLI Press Control-Alt-6 x.
    make sure that Cisco SRE-V installed by issuing "service-module sm 1/0 status" command on router.

    Thanks,
    Raghavendra

    Subject: RE: SRE-V failing to boot
    Replied by: Raghavendra Gutty Veeranagappa on 01-07-2011 07:41:33 AM
    Hi Sean,

    from the output it shows that SRE-V is not installed, please install SRE-V after configuring the module.

    please refer installation document in below link for steps to configure and install .

    http://developer.cisco.com/web/srev/docs

    Thanks,
    Raghavendra

    Subject: RE: New Message from Raghavendra Gutty Veeranagappa in Service Ready Engine
    Replied by: SEAN BYRNE on 01-07-2011 11:52:12 AM
    hello

    I appreciate your help

    when I try to download from the tftp-server flash: x location

    the SRE software reports a corrupt helper file

    I downloaded the file twice from cco

    I would like to use the external interface for the tftp

    Q have you done this before ?

    Q have you been able to break the SRE out of boot chainlink sequence ?

    regards

    ________________________________
    From: Cisco Developer Community Forums [cdicuser@developer.cisco.com]
    Sent: 01 July 2011 12:41
    To: cdicuser@developer.cisco.com
    Subject: New Message from Raghavendra Gutty Veeranagappa in Service Ready Engine Virtualization - Technical Questions: RE: SRE-V failing to boot

    Raghavendra Gutty Veeranagappa has created a new message in the forum "Technical Questions":

    --------------------------------------------------------------
    Hi Sean,

    from the output it shows that SRE-V is not installed, please install SRE-V after configuring the module.

    please refer installation document in below link for steps to configure and install .

    http://developer.cisco.com/web/srev/docs

    Thanks,
    Raghavendra
    --
    To respond to this post, please click the following link:

    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/4149431>

    or simply reply to this email.

    Subject: RE: New Message from SEAN BYRNE in Service Ready Engine Virtualization - Te
    Replied by: Radhika Miriyala on 01-07-2011 12:33:12 PM
    Hi Sean,

    What command are you using to install sre-v? You need use the sre install command from IOS ¿ service-module sm x/0 install url <url of the ftp server where the packahe in installed>



    What version of SRE-v Are you trying to install?



    Also in your previous email I see that you trying to issue ¿boot disk¿ for booting the image for sre-v you need to use ¿boot chainloder¿ once the image is installed successfully the default boot will be set to ¿chainloader¿



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Friday, July 01, 2011 8:52 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from SEAN BYRNE in Service Ready Engine Virtualization - Technical Questions: RE: New Message from Raghavendra Gutty Veeranagappa in Service Ready Engine



    SEAN BYRNE has created a new message in the forum "Technical Questions":
    --------------------------------------------------------------
    hello

    I appreciate your help

    when I try to download from the tftp-server flash: x location

    the SRE software reports a corrupt helper file

    I downloaded the file twice from cco

    I would like to use the external interface for the tftp

    Q have you done this before ?

    Q have you been able to break the SRE out of boot chainlink sequence ?

    regards

    ________________________________
    From: Cisco Developer Community Forums [cdicuser@developer.cisco.com]
    Sent: 01 July 2011 12:41
    To: cdicuser@developer.cisco.com
    Subject: New Message from Raghavendra Gutty Veeranagappa in Service Ready Engine Virtualization - Technical Questions: RE: SRE-V failing to boot

    Raghavendra Gutty Veeranagappa has created a new message in the forum "Technical Questions":

    --------------------------------------------------------------
    Hi Sean,

    from the output it shows that SRE-V is not installed, please install SRE-V after configuring the module.

    please refer installation document in below link for steps to configure and install .

    http://developer.cisco.com/web/srev/docs

    Thanks,
    Raghavendra
    --
    To respond to this post, please click the following link:

    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/4149431>

    or simply reply to this email.
    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/4149915>
    or simply reply to this email.
    This document was generated from CDN thread

    Created by: SEAN BYRNE on 01-07-2011 07:04:23 AM
    hello
     
    I have installed an SRE-V module in a cisco 2911
     
    I cannot access the command line
     
    the errors below are produced
     
    what disk is the bootup process looking for ?
     
     
    ServicesEngine boot-loader> boot disk
    Loading disk:/bzImage ... Unable to load image
    Error: Selected disk does not exist (21)
    Unable to boot image

    ServicesEngine boot-loader>
     
    ServicesEngine boot-loader> verify
    Loading disk:/bzImage ... Unable to load image
    Error: Selected disk does not exist (21)
    Unable to boot image
    Unrecognized command
    ServicesEngine boot-loader>

     

    Subject: RE: New Message from Raghavendra Gutty Veeranagappa in Service Ready Engine
    Replied by: SEAN BYRNE on 01-07-2011 07:28:12 AM
    hello

    thanks for your help

    service-module sm 1/0 status

    SteepleRd-router#ser
    SteepleRd-router#service-module s
    SteepleRd-router#service-module sM 1/0 status
    Service Module is Cisco SM1/0
    Service Module supports session via TTY line 67
    Service Module is failed
    Service Module heartbeat-reset is enabled
    Service Module is in fail open
    Service Module status is not available
    Module resource information:
      CPU Frequency: 1865 MHz
      Memory Size: 2530 MB
      Disk 0 Size: 500107 MB
      Disk 1 Size: 2055 MB
    No install/uninstall in progress
    Local Partition Info - (0 apps)
    =====================
      Retrieving partition information
    SteepleRd-router#

    ________________________________
    From: Cisco Developer Community Forums [cdicuser@developer.cisco.com]
    Sent: 01 July 2011 12:19
    To: cdicuser@developer.cisco.com
    Subject: New Message from Raghavendra Gutty Veeranagappa in Service Ready Engine Virtualization - Technical Questions: RE: SRE-V failing to boot

    Raghavendra Gutty Veeranagappa has created a new message in the forum "Technical Questions":

    --------------------------------------------------------------
    Hi Sean,

    To return to router CLI Press Control-Alt-6 x.
    make sure that Cisco SRE-V installed by issuing "service-module sm 1/0 status" command on router.

    Thanks,
    Raghavendra
    --
    To respond to this post, please click the following link:

    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/4149399>

    or simply reply to this email.

    Subject: RE: SRE-V failing to boot
    Replied by: Raghavendra Gutty Veeranagappa on 04-07-2011 06:48:44 AM
    Hi Sean,

    please try to install srev from router with below command and let us know if you got any errors.

    service-module sm slot/0 install url <The URL should point to the .pkg file on the FTP server>

    check the status with below command

    service-module sm 1/0 status

    Thanks,
    Raghavendra

    Subject: RE: New Message from Radhika Miriyala in Service Ready Engine Virtualizatio
    Replied by: SEAN BYRNE on 04-07-2011 06:18:13 AM
    Hello

    The version is sre-v-k9.smv.1.1.1

    regards


    Sean Byrne
    Network Engineer
    BT Ireland
    mobile 0044 7739446691

    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: 01 July 2011 17:33
    To: cdicuser@developer.cisco.com
    Subject: New Message from Radhika Miriyala in Service Ready Engine Virtualization - Technical Questions: RE: New Message from SEAN BYRNE in Service Ready Engine Virtualization - Te

    Radhika Miriyala has created a new message in the forum "Technical Questions":
    --------------------------------------------------------------
    Hi Sean,

    What command are you using to install sre-v? You need use the sre install command from IOS ¿ service-module sm x/0 install url <url of the ftp server where the packahe in installed>



    What version of SRE-v Are you trying to install?



    Also in your previous email I see that you trying to issue ¿boot disk¿ for booting the image for sre-v you need to use ¿boot chainloder¿ once the image is installed successfully the default boot will be set to ¿chainloader¿



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Friday, July 01, 2011 8:52 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from SEAN BYRNE in Service Ready Engine Virtualization - Technical Questions: RE: New Message from Raghavendra Gutty Veeranagappa in Service Ready Engine



    SEAN BYRNE has created a new message in the forum "Technical Questions":
    --------------------------------------------------------------
    hello

    I appreciate your help

    when I try to download from the tftp-server flash: x location

    the SRE software reports a corrupt helper file

    I downloaded the file twice from cco

    I would like to use the external interface for the tftp

    Q have you done this before ?

    Q have you been able to break the SRE out of boot chainlink sequence ?

    regards

    ________________________________
    From: Cisco Developer Community Forums [cdicuser@developer.cisco.com]
    Sent: 01 July 2011 12:41
    To: cdicuser@developer.cisco.com
    Subject: New Message from Raghavendra Gutty Veeranagappa in Service Ready Engine Virtualization - Technical Questions: RE: SRE-V failing to boot

    Raghavendra Gutty Veeranagappa has created a new message in the forum "Technical Questions":

    --------------------------------------------------------------
    Hi Sean,

    from the output it shows that SRE-V is not installed, please install SRE-V after configuring the module.

    please refer installation document in below link for steps to configure and install .

    http://developer.cisco.com/web/srev/docs

    Thanks,
    Raghavendra
    --
    To respond to this post, please click the following link:

    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/4149431>

    or simply reply to this email.
    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/4149915>
    or simply reply to this email.
    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/4150000>
    or simply reply to this email.

    Subject: RE: SRE-V failing to boot
    Replied by: vov vov on 27-09-2011 07:59:45 AM
    hello, i have this problem. i install sre-v version 1.5.1. but i see:


    yourname#service-module sm 1/0 status
    Service Module is Cisco SM1/0
    Service Module supports session via TTY line 67
    Service Module is trying to recover from error
    Service Module heartbeat-reset is enabled
    Service Module status is not available
    Install of ftp://10.0.23.112/sre-v-k9.SPA.smv.1.5.1.pkg in progress
    Install status : Waiting for RBIP registration

    if service-module sm 1/0 session i sew:
    SRE step 1 - SM registration...
    Finding (hd1,3)/296e03bc-3236-4a68-a178-688e56400a1e, failed
    Local install not supported

    Time-out from RBIP response wait loop
    .....................................
    Time-out from RBIP response wait loop
    SRE installation step 1 failed
    SRE installation failed - Recovery now...
    Restoring orignial configuration...
    Updating flash with bootloader configuration.
    Please wait ................... done.
    ServicesEngine Bootloader Version : 2.1.36
    ServicesEngine boot-loader>

    please help me!

    Subject: RE: SRE-V failing to boot
    Replied by: Raghavendra Gutty Veeranagappa on 27-09-2011 10:50:11 AM
    Hi,

    please try with below ftp url and also make sure that all files present in same dirctory from the zip file

    ftp://username:password@10.0.23.112/sre-v-k9.SPA.smv.1.5.1.pkg

    Thanks,
    Raghavendra

    Subject: RE: SRE-V failing to boot
    Replied by: vov vov on 27-09-2011 12:20:08 PM
    Thanks Raghavendra, this does not solve my problem. I did everything exactly as you describe.

    Subject: RE: New Message from vov vov in Service Ready Engine Virtualization - Techn
    Replied by: Radhika Miriyala on 27-09-2011 12:35:00 PM
    Hi,

    Can you please provide the following information.

    1)      Output of the CLI ¿Show version¿ from IOS

    2)      Can you also send the configuration of the interface service-module.  The output of ¿show running¿ on the IOS will have the information

    3)      Can you give the console output when you execute the install CLI.

    4)      Also once you start the install please session into the SM  module and give us console log from here.





    Thanks,

    Radhika





    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, September 27, 2011 9:20 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from vov vov in Service Ready Engine Virtualization - Technical Questions: RE: SRE-V failing to boot



    vov vov has created a new message in the forum "Technical Questions":

    --------------------------------------------------------------
    Thanks Raghavendra, this does not solve my problem. I did everything exactly as you describe.
    --
    To respond to this post, please click the following link:

    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/4541499>

    or simply reply to this email.

    Subject: RE: New Message from vov vov in Service Ready Engine Virtualization - Techn
    Replied by: Radhika Miriyala on 28-09-2011 11:57:30 AM
    Hi Vov,

    Can you please upgrade the IOS Image to 15.1(4)M and later versions as suggested by Raghavendra and if you still have issues with the install can you please turn on the following debugs on the IOS while you are doing an install and send them to us:



    The debugs are: debug scp all

                            debug sre-install all      



    Can you also send us the output of the cli ¿show interface sm 1/0¿



    Thanks,

    Radhika                       





    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Wednesday, September 28, 2011 12:33 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from vov vov in Service Ready Engine Virtualization - Technical Questions: RE: New Message from vov vov in Service Ready Engine Virtualization - Techn



    vov vov has created a new message in the forum "Technical Questions":

    --------------------------------------------------------------


    1) Output of the CLI ¿Show version¿ from IOS




    Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9_NPE-M), Version 15.0(1)M2, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2010 by Cisco Systems, Inc.
    Compiled Thu 11-Mar-10 00:04 by prod_rel_team
    ROM: System Bootstrap, Version 15.0(1r)M6, RELEASE SOFTWARE (fc1)
    yourname uptime is 13 minutes
    System returned to ROM by power-on
    System image file is "flash0:c2900-universalk9_npe-mz.SPA.150-1.M2.bin"
    Last reload type: Normal Reload
    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.

    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

    If you require further assistance please contact us by sending email to
    export@cisco.com.

    Cisco CISCO2911/K9 (revision 1.0) with 479232K/45056K bytes of memory.
    Processor board ID FCZ142271R1
    3 Gigabit Ethernet interfaces
    1 terminal line
    1 Services Module (SM) with Services Ready Engine (SRE)
       Cisco SRE-V Software 1.5.1.0 in slot 1
    DRAM configuration is 64 bits wide with parity enabled.
    255K bytes of non-volatile configuration memory.
    254464K bytes of ATA System CompactFlash 0 (Read/Write)


    License Info:

    License UDI:

    -------------------------------------------------
    Device#   PID                   SN
    -------------------------------------------------
    *0        CISCO2911/K9          FCZ142271R1



    Technology Package License Information for Module:'c2900'

    ----------------------------------------------------------------
    Technology    Technology-package          Technology-package
                  Current       Type          Next reboot
    -----------------------------------------------------------------
    ipbase        ipbasek9      Permanent     ipbasek9
    security      None          None          None
    uc            None          None          None
    data          None          None          None

    Configuration register is 0x2102





    2) Can you also send the configuration of the interface service-module. The output of ¿show running¿ on the IOS will have the information




    interface GigabitEthernet0/0
    description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
    ip address 10.0.10.66 255.255.255.0 secondary
    ip address 10.10.0.10 255.255.255.0 secondary
    ip address 10.0.23.33 255.255.255.0
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    no ip address
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/2
    ip dhcp relay information check-reply
    ip dhcp client route track 500
    ip dhcp client authentication mode md5
    ip address dhcp
    ip helper-address 10.0.21.1
    ip helper-address 10.0.21.255
    duplex auto
    speed auto
    vlan-id dot1q 3
      exit-vlan-config
    !
    !
    interface SM1/0
    ip address 10.10.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    service-module ip address 10.10.1.2 255.255.255.0
    !Application: VMware ESXi 4.1.0 build-348481 running on SRE
    service-module ip default-gateway 10.10.1.1
    !
    interface SM1/1
    ip address 10.10.10.1 255.255.255.0
    service-module ip address 10.10.10.2 255.255.255.0
    !
    ip forward-protocol nd
    !
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    ip nat pool net-20 10.0.21.130 10.0.21.150 netmask 255.255.255.0
    ip nat inside source list 1 interface GigabitEthernet0/0 overload
    ip nat inside source list 10 interface GigabitEthernet0/0 overload
    ip nat outside source static 192.168.0.250 10.0.21.199
    ip route 0.0.0.0 0.0.0.0 10.0.23.251
    ip route 0.0.0.0 0.0.0.0 10.0.21.126
    ip route 10.0.0.0 255.255.255.0 10.10.10.123
    ip route 10.0.23.33 255.255.255.255 SM1/0
    ip route 10.10.1.1 255.255.255.255 SM1/0
    ip route 10.10.10.2 255.255.255.255 SM1/0
    ip route 10.10.10.2 255.255.255.255 SM1/1
    !
    access-list 1 permit 10.10.0.0 0.0.0.255
    access-list 1 permit 10.10.1.0 0.0.0.255
    access-list 1 permit 10.10.10.0 0.0.0.255





    3) Can you give the console output when you execute the install CLI.




    Loading sre/sre-v-k9.SPA.smv.1.5.1.pkg.install.sre !
    [OK - 6016/4096 bytes]

    Service module installation
    ios_version     15.0(1)M2,
    ios_image       c2900-universalk9_npe-mz
    pkg_name        sre-v-k9.SPA.smv.1.5.1.pkg
    key_file        sre-v-k9.SPA.smv.1.5.1.key
    helper_file     sre-v-installer.SPA.smv.1.5.1
    pid             SM-SRE-700-K9

    Check target platform capabilities
    cpu      1864
    Resource check completed successfully. Proceeding to Install ...





    4) Also once you start the install please session into the SM module and give us console log from here.




    yourname#service-module sm 1/0 status
    Service Module is Cisco SM1/0
    Service Module supports session via TTY line 67
    Service Module is trying to recover from error
    Service Module heartbeat-reset is enabled
    Service Module status is not available
    Install of ftp://test:test@10.0.23.114/sre/sre-v-k9.SPA.smv.1.5.1.pkg in progress
    Install status : Waiting for file request


    yourname#service-module sm 1/0 session

    Username:
    Password:


    Please wait...
    Please press P to select Primary Boot Loader ...
              or S to select Secondary Boot Loader ...
              or wait to boot from default configuration ...
    .......................................................................................................
    SRE module get located and run....
    Now booting from secondary boot loader....
    Authenticating boot loader....
    Secondary Boot Loader authenticated - booting....
    Please enter '***' to change boot configuration:
    Detect and Initialize network device


    Backup current platform configurations....


    SRE step 1 - SM registration...
    Finding (hd1,3)/296e03bc-3236-4a68-a178-688e56400a1e, failed
    Local install not supported


    Time-out from RBIP response wait loop

    .......................................................(repeat)
    Time-out from RBIP response wait loop



    SRE installation step 1 failed


    Abort initiated due to RBIP timeout


    Time-out from RBIP response wait loop


    Initializing memory #1. Please wait...


    Initializing memory #2. Please wait...


    This may take a minute....




    DDR Memory 4096 MB detected
    Intel(R) Core(TM)2 Solo CPU    L3400  @ 1.86GHz
    BIOS SM 3.52.8,  BIOS Build date: 02/08/2011
    System now booting...
    Please wait...
    Please press P to select Primary Boot Loader ...
              or S to select Secondary Boot Loader ...
              or wait to boot from default configuration ...
    .......................................................................................................
    SRE module get located and run....
    Now booting from secondary boot loader....
    Authenticating boot loader....


    Secondary Boot Loader authenticated - booting....


    Please enter '***' to change boot configuration:



    Detect and Initialize network device
    Backup current platform configurations....
    SRE step 1 - SM registration...
    Finding (hd1,3)/296e03bc-3236-4a68-a178-688e56400a1e, failed
    Local install not supported


    Time-out from RBIP response wait loop

    .......................................................(repeat)


    Time-out from RBIP response wait loop
    SRE installation step 1 failed
    --
    To respond to this post, please click the following link:

    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/4546620>

    or simply reply to this email.

    Subject: RE: New Message from vov vov in Service Ready Engine Virtualization - Techn
    Replied by: vov vov on 28-09-2011 03:32:42 AM

    1)      Output of the CLI ¿Show version¿ from IOS

     

    Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9_NPE-M), Version 15.0(1)M2, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2010 by Cisco Systems, Inc.
    Compiled Thu 11-Mar-10 00:04 by prod_rel_team
    ROM: System Bootstrap, Version 15.0(1r)M6, RELEASE SOFTWARE (fc1)
    yourname uptime is 13 minutes
    System returned to ROM by power-on
    System image file is "flash0:c2900-universalk9_npe-mz.SPA.150-1.M2.bin"
    Last reload type: Normal Reload
    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.
     
    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
     
    If you require further assistance please contact us by sending email to
    export@cisco.com.
     
    Cisco CISCO2911/K9 (revision 1.0) with 479232K/45056K bytes of memory.
    Processor board ID FCZ142271R1
    3 Gigabit Ethernet interfaces
    1 terminal line
    1 Services Module (SM) with Services Ready Engine (SRE)
       Cisco SRE-V Software 1.5.1.0 in slot 1
    DRAM configuration is 64 bits wide with parity enabled.
    255K bytes of non-volatile configuration memory.
    254464K bytes of ATA System CompactFlash 0 (Read/Write)
     
     
    License Info:
     
    License UDI:
     
    -------------------------------------------------
    Device#   PID                   SN
    -------------------------------------------------
    *0        CISCO2911/K9          FCZ142271R1
     
     
     
    Technology Package License Information for Module:'c2900'
     
    ----------------------------------------------------------------
    Technology    Technology-package          Technology-package
                  Current       Type          Next reboot
    -----------------------------------------------------------------
    ipbase        ipbasek9      Permanent     ipbasek9
    security      None          None          None
    uc            None          None          None
    data          None          None          None
     
    Configuration register is 0x2102




    2)      Can you also send the configuration of the interface service-module.  The output of ¿show running¿ on the IOS will have the information

     

    interface GigabitEthernet0/0
     description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
     ip address 10.0.10.66 255.255.255.0 secondary
     ip address 10.10.0.10 255.255.255.0 secondary
     ip address 10.0.23.33 255.255.255.0
     ip nat outside
     ip virtual-reassembly
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/1
     no ip address
     ip virtual-reassembly
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/2
     ip dhcp relay information check-reply
     ip dhcp client route track 500
     ip dhcp client authentication mode md5
     ip address dhcp
     ip helper-address 10.0.21.1
     ip helper-address 10.0.21.255
     duplex auto
     speed auto
     vlan-id dot1q 3
      exit-vlan-config
     !
    !
    interface SM1/0
     ip address 10.10.1.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly
     service-module ip address 10.10.1.2 255.255.255.0
     !Application: VMware ESXi 4.1.0 build-348481 running on SRE
     service-module ip default-gateway 10.10.1.1
    !
    interface SM1/1
     ip address 10.10.10.1 255.255.255.0
     service-module ip address 10.10.10.2 255.255.255.0
    !
    ip forward-protocol nd
    !
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    ip nat pool net-20 10.0.21.130 10.0.21.150 netmask 255.255.255.0
    ip nat inside source list 1 interface GigabitEthernet0/0 overload
    ip nat inside source list 10 interface GigabitEthernet0/0 overload
    ip nat outside source static 192.168.0.250 10.0.21.199
    ip route 0.0.0.0 0.0.0.0 10.0.23.251
    ip route 0.0.0.0 0.0.0.0 10.0.21.126
    ip route 10.0.0.0 255.255.255.0 10.10.10.123
    ip route 10.0.23.33 255.255.255.255 SM1/0
    ip route 10.10.1.1 255.255.255.255 SM1/0
    ip route 10.10.10.2 255.255.255.255 SM1/0
    ip route 10.10.10.2 255.255.255.255 SM1/1
    !
    access-list 1 permit 10.10.0.0 0.0.0.255
    access-list 1 permit 10.10.1.0 0.0.0.255
    access-list 1 permit 10.10.10.0 0.0.0.255




    3)      Can you give the console output when you execute the install CLI.

     

    Loading sre/sre-v-k9.SPA.smv.1.5.1.pkg.install.sre !
    [OK - 6016/4096 bytes]
     
    Service module installation
    ios_version     15.0(1)M2,
    ios_image       c2900-universalk9_npe-mz
    pkg_name        sre-v-k9.SPA.smv.1.5.1.pkg
    key_file        sre-v-k9.SPA.smv.1.5.1.key
    helper_file     sre-v-installer.SPA.smv.1.5.1
    pid             SM-SRE-700-K9
     
    Check target platform capabilities
    cpu      1864
    Resource check completed successfully. Proceeding to Install ...




    4)      Also once you start the install please session into the SM  module and give us console log from here.

     

    yourname#service-module sm 1/0 status
    Service Module is Cisco SM1/0
    Service Module supports session via TTY line 67
    Service Module is trying to recover from error
    Service Module heartbeat-reset is enabled
    Service Module status is not available
    Install of ftp://test:test@10.0.23.114/sre/sre-v-k9.SPA.smv.1.5.1.pkg in progress
    Install status : Waiting for file request


    yourname#service-module sm 1/0 session

    Username: 
    Password:


    Please wait...
    Please press P to select Primary Boot Loader ...
              or S to select Secondary Boot Loader ...
              or wait to boot from default configuration ...
    .......................................................................................................
    SRE module get located and run....
    Now booting from secondary boot loader....
    Authenticating boot loader....
    Secondary Boot Loader authenticated - booting....
    Please enter '***' to change boot configuration:
    Detect and Initialize network device


    Backup current platform configurations....


    SRE step 1 - SM registration...
    Finding (hd1,3)/296e03bc-3236-4a68-a178-688e56400a1e, failed
    Local install not supported


    Time-out from RBIP response wait loop

    .......................................................(repeat)
    Time-out from RBIP response wait loop



    SRE installation step 1 failed


     Abort initiated due to RBIP timeout


    Time-out from RBIP response wait loop


    Initializing memory #1. Please wait...


    Initializing memory #2. Please wait...


    This may take a minute....




    DDR Memory 4096 MB detected
    Intel(R) Core(TM)2 Solo CPU    L3400  @ 1.86GHz
    BIOS SM 3.52.8,  BIOS Build date: 02/08/2011
    System now booting...
    Please wait...
    Please press P to select Primary Boot Loader ...
              or S to select Secondary Boot Loader ...
              or wait to boot from default configuration ...
    .......................................................................................................
    SRE module get located and run....
    Now booting from secondary boot loader....
    Authenticating boot loader....


    Secondary Boot Loader authenticated - booting....


    Please enter '***' to change boot configuration:



    Detect and Initialize network device
    Backup current platform configurations....
    SRE step 1 - SM registration...
    Finding (hd1,3)/296e03bc-3236-4a68-a178-688e56400a1e, failed
    Local install not supported


    Time-out from RBIP response wait loop

    .......................................................(repeat)


    Time-out from RBIP response wait loop
    SRE installation step 1 failed

    Subject: RE: SRE-V failing to boot
    Replied by: Raghavendra Gutty Veeranagappa on 28-09-2011 05:01:12 AM
    Hi,

    please upgrade IOS to 15.1(4)M and later versions and also configure below config.

    interface SM1/1
    switchport mode trunk

    for more information please refer Installation and configuration guide from Knowledge Base section.

    Thanks,
    Raghavendra

    Subject: RE: SRE-V failing to boot
    Replied by: vov vov on 29-09-2011 06:17:34 AM
    Thanks for trying to help me. if I type the command  boot diag, see:



    ServicesEngine boot-loader> boot diag
    Verifying ... done.
    Starting Kernel.
       [NetBSD-elf, <0x100020:0x316c0:0x89220>, entry=0x100020]
    Diagnostics is a standalone utility that runs on the module independent of the operating system or applications running on the module. All tests are non-destructive but there is a possibility of hard disk data corruption during power failure when the tests are in progress. Therefore, making a backup of the data on the drive is recommended before executing the tests.
    For any questions or concerns with the utility, please open a Service Request with Cisco TAC at
    http://www.cisco.com/cisco/web/support/index.html
    Yes to continue test - No to exit (y/n) y
    Test will start and result of each test will appear on the screen. Please do not interrupt test while in progress!
    Main memory test (1 of 5) is in progress...
    Main memory test passed.
    USB test (2 of 5) is in progress...
    USB test passed.
    Boot flash test (3 of 5) is in progress...
    Boot flash test passed.
    GE PHY loopback test (4 of 5) is in progress...
    GE PHY loopback test passed.
    Hard disk test (5 of 5) is in progress...
    No PRIMARY Hard Disk found. Skipping the PRIMARY Hard Disk test.
    No SECONDARY Hard Disk found. Skipping the SECONDARY Hard Disk test.
    Hard disk test failed.

    Subject: RE: New Message from vov vov in Service Ready Engine Virtualization - Techn
    Replied by: Radhika Miriyala on 29-09-2011 11:37:30 AM
    Vov, Looks like the two hard disks are missing from the diag message.   IF you got the module from Cisco by ordering you might need to contact TAC to see how to proceed.



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Thursday, September 29, 2011 3:18 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from vov vov in Service Ready Engine Virtualization - Technical Questions: RE: SRE-V failing to boot



    vov vov has created a new message in the forum "Technical Questions":

    --------------------------------------------------------------
    Thanks for trying to help me. if I type the command boot diag, see:



    ServicesEngine boot-loader> boot diag
    Verifying ... done.
    Starting Kernel.
    [NetBSD-elf, <0x100020:0x316c0:0x89220>, entry=0x100020]
    Diagnostics is a standalone utility that runs on the module independent of the operating system or applications running on the module. All tests are non-destructive but there is a possibility of hard disk data corruption during power failure when the tests are in progress. Therefore, making a backup of the data on the drive is recommended before executing the tests.
    For any questions or concerns with the utility, please open a Service Request with Cisco TAC at
    http://www.cisco.com/cisco/web/support/index.html
    Yes to continue test - No to exit (y/n) y
    Test will start and result of each test will appear on the screen. Please do not interrupt test while in progress!
    Main memory test (1 of 5) is in progress...
    Main memory test passed.
    USB test (2 of 5) is in progress...
    USB test passed.
    Boot flash test (3 of 5) is in progress...
    Boot flash test passed.
    GE PHY loopback test (4 of 5) is in progress...
    GE PHY loopback test passed.
    Hard disk test (5 of 5) is in progress...
    No PRIMARY Hard Disk found. Skipping the PRIMARY Hard Disk test.
    No SECONDARY Hard Disk found. Skipping the SECONDARY Hard Disk test.
    Hard disk test failed.
    --
    To respond to this post, please click the following link:

    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/4550244>

    or simply reply to this email.