Translation rule not working

Version 1
    This document was generated from CDN thread

    Created by: srikanth satturi on 19-04-2011 09:13:03 AM
    Hi everyone,
     
    I have a issue with translation rule.
     

    voice translation-rule 1
     rule 1 /\+/ //
     rule 2 /^999999999/ /DD/
    !        
     
    This rule is working fine and translated CLI and CLD are coming into tcl script when I was not doing sip header-passing.
     
    but when I am doing sip header passing I could not see translated CLI and CLD in the script.

     
    Here is debug voice translation..
     

    Apr 19 12:16:35.937: //-1/B47E5EA38A8F/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x6848070C; count=1
    Apr 19 12:16:35.937: //-1/B47E5EA38A8F/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0xC36D6204
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_stack_push_RegXruleNumInfo_internal: stack=0x6848070C; count=1
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_profile_translate_internal: number=+123456 type=unknown plan=unknown numbertype=calling
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_profile_match_internal: Matched with rule 1 in ruleset 1
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_profile_match_internal: Matched with rule 1 in ruleset 1
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/sed_subst: Successful substitution; pattern=+123456 matchPattern=\+ replacePattern= replaced pattern=123456
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_subst_num_type: Match Type = none, Replace Type = none Input Type = unknown
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_subst_num_plan: Match Plan = none, Replace Plan = none Input Plan = unknown
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_profile_translate_internal: xlt_number=123456 xlt_type=unknown xlt_plan=unknown
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_profile_translate_internal: number= type=unknown plan=unknown numbertype=redirect-called
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_get_RegXrule: Invalid translation ruleset tag=0
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_profile_match_internal: Error: ruleset for redirect-called number not found
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_profile_translate_internal: No match: number= type=unknown plan=unknown
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_profile_translate_internal: number=8888 type=unknown plan=unknown numbertype=called
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_match: No match; number=8888 rule precedence=1
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_profile_match_internal: Matched with rule 2 in ruleset 7
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_match: No match; number=8888 rule precedence=1
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_profile_match_internal: Matched with rule 2 in ruleset 7
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_match: No match; number=8888 rule precedence=1
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/sed_subst: Successful substitution; pattern=8888 matchPattern=^8888 replacePattern=DD replaced pattern=DD
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_subst_num_type: Match Type = none, Replace Type = none Input Type = unknown
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_subst_num_plan: Match Plan = none, Replace Plan = none Input Plan = unknown
    Apr 19 12:16:35.941: //-1/B47E5EA38A8F/RXRULE/regxrule_profile_translate_internal: xlt_number=DD xlt_type=unknown xlt_plan=unknown
    Apr 19 12:16:35.945: //302926//TCL :/tcl_PutsObjCmd: CLI: sip:+123456@domain.com
     
    Apr 19 12:16:35.945: 
    Apr 19 12:16:35.945: //302926//TCL :/tcl_PutsObjCmd: TotalLanguages: 1
     
    Apr 19 12:16:35.945: 
    Apr 19 12:16:35.945: //302926//TCL :/tcl_PutsObjCmd: DNIS: sip:8888@ip:port
     
     
    please correct me anything went wrong here and help me out
     
    Srikanth

    Subject: RE: Translation rule not working
    Replied by: srikanth satturi on 19-04-2011 09:26:04 AM
    please help me out

    Subject: RE: Translation rule not working
    Replied by: Yaw-Ming Chen on 19-04-2011 10:35:45 AM
    You might hit this defect CSCth69475. What is your IOS version ?

    Thanks

    Subject: RE: Translation rule not working
    Replied by: Yaw-Ming Chen on 19-04-2011 11:27:44 AM
    I am not sure which version of 15.x T will include this fix since this is 5400. You may wnat to ask Cisco TAC they maybe able to point you the right version. I was facing the same issue so I knew there was a bug.

    Thanks,

    Yawming

    Subject: RE: Translation rule not working
    Replied by: srikanth satturi on 19-04-2011 12:16:27 PM
    Thanks very much