Issues with Configuring multiple VLANS on the SRE-v.

Version 1
    This document was generated from CDN thread

    Created by: WARD COBLEIGH on 29-03-2011 10:52:33 AM
    Hi,
     
    We are having problems configuring virtual machines on different VLANS. The configuration is similar in concept to the Cisco documentation on "Configuring VLANS with Cisco IOS Layer 3 Routed Configuration"
     
    We are unable to ping to our virtual machine on vlan 40. The VM on Vlan1 (on which the hypervisor is as well) seems to respond.
     
    Please see the config below.. (We have two SREs on the router. You need to look at sm2/0 and sm2/1).
    I have also a dump of sm2/1 switchport.
    How can we troubleshoot this?  There is also a dump of sm
     
     
    *************SM2/1 SWITCHPORT DUMP *****************************
    3900_router#sh int sm2/1 switchport
    Name: SM2/1
    Switchport: Enabled
    Administrative Mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: dot1q
    Operational Trunking Encapsulation: dot1q
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: 1-1048
    Trunking VLANs Active: 1,40
    Protected: false
    Priority for untagged frames: 0
    Override vlan tag priority: FALSE
    Voice VLAN: none
    Appliance trust: none
    3900_router#
     
    ************* ROUTER CONFIG *****************************
    3900_router# sh run
    Building configuration...

    Current configuration : 6328 bytes
    !
    ! Last configuration change at 14:46:56 UTC Tue Mar 29 2011
    !
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname 3900_router
    !
    boot-start-marker
    boot system flash c3900-universalk9-mz.SPA.151-3.T.bin
    boot-end-marker
    !
    !
    card type t1 0 1
    logging buffered 51200 warnings
    enable password fluke
    !
    no aaa new-model
    no network-clock-participate wic 1
    !
    ipv6 unicast-routing
    ipv6 cef
    ip source-route
    !
    ip traffic-export profile g01_to_g02
      interface GigabitEthernet0/2
      mac-address 5475.d0c9.7702
    !
    ip traffic-export profile g02_to_g01
      interface GigabitEthernet0/1
      mac-address 5475.d0c9.7701
    !
    ip traffic-export profile g01_wan
      interface Vlan1
      bidirectional
      mac-address 000c.295e.93ee
    ip cef
    !
    !
    !
    !
    !
    ip domain name yourdomain.com
    multilink bundle-name authenticated
    !
    !
    crypto pki token default removal timeout 0
    !
    crypto pki trustpoint TP-self-signed-417311045
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-417311045
     revocation-check none
     rsakeypair TP-self-signed-417311045
    !
    license udi pid C3900-SPE150/K9 sn FOC14173AA5
    hw-module sm 1
    !
    hw-module sm 2
    !
    !
    !
    username admin privilege 15 secret 5 $1$P4jj$yHwRu7304TMoYc1ffuJuM/
    !
    !
    controller T1 0/1/0
     cablelength long 0db
     channel-group 0 timeslots 1-24
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
     description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
     ip address 10.250.64.85 255.255.248.0
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/0.1
     shutdown
    !
    interface GigabitEthernet0/0.40
     encapsulation dot1Q 40
     shutdown
     no cdp enable
    !
    interface GigabitEthernet0/1
     ip address 9.9.9.1 255.255.255.0
     duplex full
     speed 100
     ipv6 address FD4A:4297:EEBC:85FF::1/64
     ipv6 enable
    !
    interface GigabitEthernet0/2
     ip address 8.8.8.1 255.255.255.0
     ip traffic-export apply g01_wan
     duplex full
     speed 100
     ipv6 address FD3A:9290:84F:31F7::1/64
     ipv6 enable
    !
    interface Serial0/1/0:0
     ip address 20.20.20.1 255.255.255.252
     encapsulation ppp
    !
    interface GigabitEthernet0/0/0
    !
    interface GigabitEthernet0/0/1
    !
    interface GigabitEthernet0/0/2
    !
    interface GigabitEthernet0/0/3
    !
    interface SM1/0
     ip unnumbered GigabitEthernet0/0
     service-module ip address 10.250.64.83 255.255.248.0
     !Application: SRE-V Running on SMV
     service-module ip default-gateway 10.250.64.85
     service-module mgf ip address 10.250.80.202 255.255.255.248
     ipv6 enable
    !
    interface SM1/1
     description Internal switch interface connected to Service Module
     switchport mode trunk
     no cdp enable
    !
    interface SM2/0
     ip unnumbered GigabitEthernet0/0
     service-module ip address 10.250.64.93 255.255.248.0
     !Application: SRE-V Running on SMV
     service-module ip default-gateway 10.250.64.85
     service-module mgf ip address 10.250.80.205 255.255.255.248
    !
    interface SM2/1
     description Internal switch interface connected to Service Module
     switchport trunk allowed vlan 1-1048
     switchport mode trunk
    !
    interface Vlan1
     ip address 10.250.80.201 255.255.255.248
    !
    interface Vlan40
     ip address 10.250.80.193 255.255.255.248
     no autostate
     vlan-id dot1q 40
      exit-vlan-config
     !
    !
    interface Vlan50
     ip address 17.17.17.1 255.255.255.0
     no autostate
    !
    ip forward-protocol nd
    !
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    ip route 10.10.10.0 255.255.255.0 GigabitEthernet0/1
    ip route 10.31.23.0 255.255.255.0 9.9.9.2
    ip route 10.31.27.0 255.255.255.0 8.8.8.2
    ip route 10.50.12.0 255.255.255.0 8.8.8.2
    ip route 10.50.14.2 255.255.255.255 8.8.8.2
    ip route 10.50.116.0 255.255.255.0 9.9.9.2
    ip route 10.50.118.2 255.255.255.255 9.9.9.2
    ip route 10.250.64.83 255.255.255.255 SM1/0
    ip route 10.250.64.93 255.255.255.255 SM2/0
    ip route 10.250.74.25 255.255.255.255 Serial0/1/0:0
    ip route 10.250.80.0 255.255.255.0 10.250.64.1
    ip route 10.250.80.2 255.255.255.255 8.8.8.2
    ip route 10.250.80.3 255.255.255.255 9.9.9.2
    ip route 10.250.80.194 255.255.255.255 Vlan40
    ip route 10.250.80.202 255.255.255.255 Vlan1
    ip route 10.250.80.205 255.255.255.255 Vlan1
    ip route 20.20.20.0 255.255.255.0 Serial0/1/0:0
    ip route 100.100.3.0 255.255.255.0 8.8.8.2
    ip route 129.196.200.0 255.255.255.0 8.8.8.2
    ip route 129.196.200.0 255.255.255.0 10.250.80.1
    !
    !
    no cdp run

    !
    !
    control-plane
    !
    !
    alias exec c config t
    !
    line con 0
     login local
    line aux 0
    line 67
     no activation-character
     no exec
     transport preferred none
     transport input all
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line 131
     no activation-character
     no exec
     transport preferred none
     transport input all
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line vty 0 4
     password fluke
     login
     transport input telnet
    line vty 5 15
     password visual
     login
     transport input telnet
    !
    scheduler allocate 20000 1000
    end

    Subject: RE: New Message from WARD COBLEIGH in Service Ready Engine Virtualization -
    Replied by: Radhika Miriyala on 29-03-2011 12:31:24 PM
    Hi WARD,

    Your IOS side config looks good to me. Did you create a new VM network port group with Vlan 40 in ESXI?  Can you also send the SRE-V/ESXI side of the networking configuration?   Can You send the output of ¿show hypervisor vswitch¿  from the sre-v console manager.



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, March 29, 2011 7:53 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from WARD COBLEIGH in Service Ready Engine Virtualization - Technical Questions: Issues with Configuring multiple VLANS on the SRE-v.



    WARD COBLEIGH has created a new message in the forum "Technical Questions":

    --------------------------------------------------------------
    Hi,

    We are having problems configuring virtual machines on different VLANS. The configuration is similar in concept to the Cisco documentation on "Configuring VLANS with Cisco IOS Layer 3 Routed Configuration"

    We are unable to ping to our virtual machine on vlan 40. The VM on Vlan1 (on which the hypervisor is as well) seems to respond.

    Please see the config below.. (We have two SREs on the router. You need to look at sm2/0 and sm2/1).
    I have also a dump of sm2/1 switchport.
    How can we troubleshoot this?  There is also a dump of sm


    *************SM2/1 SWITCHPORT DUMP *****************************
    3900_router#sh int sm2/1 switchport
    Name: SM2/1
    Switchport: Enabled
    Administrative Mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: dot1q
    Operational Trunking Encapsulation: dot1q
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: 1-1048
    Trunking VLANs Active: 1,40
    Protected: false
    Priority for untagged frames: 0
    Override vlan tag priority: FALSE
    Voice VLAN: none
    Appliance trust: none
    3900_router#

    ************* ROUTER CONFIG *****************************
    3900_router# sh run
    Building configuration...

    Current configuration : 6328 bytes
    !
    ! Last configuration change at 14:46:56 UTC Tue Mar 29 2011
    !
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname 3900_router
    !
    boot-start-marker
    boot system flash c3900-universalk9-mz.SPA.151-3.T.bin
    boot-end-marker
    !
    !
    card type t1 0 1
    logging buffered 51200 warnings
    enable password fluke
    !
    no aaa new-model
    no network-clock-participate wic 1
    !
    ipv6 unicast-routing
    ipv6 cef
    ip source-route
    !
    ip traffic-export profile g01_to_g02
      interface GigabitEthernet0/2
      mac-address 5475.d0c9.7702
    !
    ip traffic-export profile g02_to_g01
      interface GigabitEthernet0/1
      mac-address 5475.d0c9.7701
    !
    ip traffic-export profile g01_wan
      interface Vlan1
      bidirectional
      mac-address 000c.295e.93ee
    ip cef
    !
    !
    !
    !
    !
    ip domain name yourdomain.com
    multilink bundle-name authenticated
    !
    !
    crypto pki token default removal timeout 0
    !
    crypto pki trustpoint TP-self-signed-417311045
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-417311045
    revocation-check none
    rsakeypair TP-self-signed-417311045
    !
    license udi pid C3900-SPE150/K9 sn FOC14173AA5
    hw-module sm 1
    !
    hw-module sm 2
    !
    !
    !
    username admin privilege 15 secret 5 $1$P4jj$yHwRu7304TMoYc1ffuJuM/
    !
    !
    controller T1 0/1/0
    cablelength long 0db
    channel-group 0 timeslots 1-24
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
    description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
    ip address 10.250.64.85 255.255.248.0
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/0.1
    shutdown
    !
    interface GigabitEthernet0/0.40
    encapsulation dot1Q 40
    shutdown
    no cdp enable
    !
    interface GigabitEthernet0/1
    ip address 9.9.9.1 255.255.255.0
    duplex full
    speed 100
    ipv6 address FD4A:4297:EEBC:85FF::1/64
    ipv6 enable
    !
    interface GigabitEthernet0/2
    ip address 8.8.8.1 255.255.255.0
    ip traffic-export apply g01_wan
    duplex full
    speed 100
    ipv6 address FD3A:9290:84F:31F7::1/64
    ipv6 enable
    !
    interface Serial0/1/0:0
    ip address 20.20.20.1 255.255.255.252
    encapsulation ppp
    !
    interface GigabitEthernet0/0/0
    !
    interface GigabitEthernet0/0/1
    !
    interface GigabitEthernet0/0/2
    !
    interface GigabitEthernet0/0/3
    !
    interface SM1/0
    ip unnumbered GigabitEthernet0/0
    service-module ip address 10.250.64.83 255.255.248.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.250.64.85
    service-module mgf ip address 10.250.80.202 255.255.255.248
    ipv6 enable
    !
    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk
    no cdp enable
    !
    interface SM2/0
    ip unnumbered GigabitEthernet0/0
    service-module ip address 10.250.64.93 255.255.248.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.250.64.85
    service-module mgf ip address 10.250.80.205 255.255.255.248
    !
    interface SM2/1
    description Internal switch interface connected to Service Module
    switchport trunk allowed vlan 1-1048
    switchport mode trunk
    !
    interface Vlan1
    ip address 10.250.80.201 255.255.255.248
    !
    interface Vlan40
    ip address 10.250.80.193 255.255.255.248
    no autostate
    vlan-id dot1q 40
      exit-vlan-config
    !
    !
    interface Vlan50
    ip address 17.17.17.1 255.255.255.0
    no autostate
    !
    ip forward-protocol nd
    !
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    ip route 10.10.10.0 255.255.255.0 GigabitEthernet0/1
    ip route 10.31.23.0 255.255.255.0 9.9.9.2
    ip route 10.31.27.0 255.255.255.0 8.8.8.2
    ip route 10.50.12.0 255.255.255.0 8.8.8.2
    ip route 10.50.14.2 255.255.255.255 8.8.8.2
    ip route 10.50.116.0 255.255.255.0 9.9.9.2
    ip route 10.50.118.2 255.255.255.255 9.9.9.2
    ip route 10.250.64.83 255.255.255.255 SM1/0
    ip route 10.250.64.93 255.255.255.255 SM2/0
    ip route 10.250.74.25 255.255.255.255 Serial0/1/0:0
    ip route 10.250.80.0 255.255.255.0 10.250.64.1
    ip route 10.250.80.2 255.255.255.255 8.8.8.2
    ip route 10.250.80.3 255.255.255.255 9.9.9.2
    ip route 10.250.80.194 255.255.255.255 Vlan40
    ip route 10.250.80.202 255.255.255.255 Vlan1
    ip route 10.250.80.205 255.255.255.255 Vlan1
    ip route 20.20.20.0 255.255.255.0 Serial0/1/0:0
    ip route 100.100.3.0 255.255.255.0 8.8.8.2
    ip route 129.196.200.0 255.255.255.0 8.8.8.2
    ip route 129.196.200.0 255.255.255.0 10.250.80.1
    !
    !
    no cdp run

    !
    !
    control-plane
    !
    !
    alias exec c config t
    !
    line con 0
    login local
    line aux 0
    line 67
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line 131
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line vty 0 4
    password fluke
    login
    transport input telnet
    line vty 5 15
    password visual
    login
    transport input telnet
    !
    scheduler allocate 20000 1000
    end
    --
    To respond to this post, please click the following link:

    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/3350614>

    or simply reply to this email.

    Subject: RE: New Message from WARD COBLEIGH in Service Ready Engine Virtualization -
    Replied by: Christopher Daniel on 29-03-2011 01:27:04 PM
    Hi Radhika,
     
    I had logged in as WARD (our Business account manager). Now reverting to my own account (Christopher Daniel).
     
    No I have NOT created a new VM network port group with Vlan 40 in ESXI. Do I need to do this?
    Currently the way we have it...
     
    Virtual Machine 1 (Vlan1)-----|
    Virtual Machine 2 (Vlan40)----|         All three are on the same virtual switch i.e vSwitch0
    Management Network----------|         and belong to the "Virtual Machine Port Group"
     
     
    What is the SRE-V/ESXI side of the configuration?
    Is this not seen from the router CLI?
     
    Please find below the output of SH HYPERVISOR VSWITCH.
     
    se-10-250-64-93# sh hypervisor vswitch
    Switch Name      Num Ports   Used Ports  Configured Ports  MTU     Uplinks
    vSwitch0                    128         5                 128                   1500      vmnic2

      PortGroup Name        VLAN  ID  Used Ports  Uplinks
      VM Network                   0               2                 vmnic2
      Management Network    0              1                  vmnic2

    Switch Name      Num Ports   Used Ports  Configured Ports  MTU     Uplinks
    ciscoSwitchLocal  8           3           8                 1500

      PortGroup Name        VLAN ID  Used Ports  Uplinks
      CiscoReservedLocal    0        2

    Switch Name      Num Ports   Used Ports  Configured Ports  MTU     Uplinks
    ciscoSwitch           8                  3                        8                  1500       vmnic1

      PortGroup Name        VLAN ID  Used Ports  Uplinks
      CiscoReserved            0                     1           vmnic1
     
    Please let me know if you need anything else.
     
    Thanks,
    Chris
     
     
    Hi WARD,

    Your IOS side config looks good to me. Did you create a new VM network port group with Vlan 40 in ESXI?  Can you also send the SRE-V/ESXI side of the networking configuration?   Can You send the output of ¿show hypervisor vswitch¿  from the sre-v console manager.



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, March 29, 2011 7:53 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from WARD COBLEIGH in Service Ready Engine Virtualization - Technical Questions: Issues with Configuring multiple VLANS on the SRE-v.



    WARD COBLEIGH has created a new message in the forum "Technical Questions":

    --------------------------------------------------------------
    Hi,

    We are having problems configuring virtual machines on different VLANS. The configuration is similar in concept to the Cisco documentation on "Configuring VLANS with Cisco IOS Layer 3 Routed Configuration"

    We are unable to ping to our virtual machine on vlan 40. The VM on Vlan1 (on which the hypervisor is as well) seems to respond.

    Please see the config below.. (We have two SREs on the router. You need to look at sm2/0 and sm2/1).
    I have also a dump of sm2/1 switchport.
    How can we troubleshoot this?  There is also a dump of sm


    *************SM2/1 SWITCHPORT DUMP *****************************
    3900_router#sh int sm2/1 switchport
    Name: SM2/1
    Switchport: Enabled
    Administrative Mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: dot1q
    Operational Trunking Encapsulation: dot1q
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: 1-1048
    Trunking VLANs Active: 1,40
    Protected: false
    Priority for untagged frames: 0
    Override vlan tag priority: FALSE
    Voice VLAN: none
    Appliance trust: none
    3900_router#

    ************* ROUTER CONFIG *****************************
    3900_router# sh run
    Building configuration...

    Current configuration : 6328 bytes
    !
    ! Last configuration change at 14:46:56 UTC Tue Mar 29 2011
    !
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname 3900_router
    !
    boot-start-marker
    boot system flash c3900-universalk9-mz.SPA.151-3.T.bin
    boot-end-marker
    !
    !
    card type t1 0 1
    logging buffered 51200 warnings
    enable password fluke
    !
    no aaa new-model
    no network-clock-participate wic 1
    !
    ipv6 unicast-routing
    ipv6 cef
    ip source-route
    !
    ip traffic-export profile g01_to_g02
      interface GigabitEthernet0/2
      mac-address 5475.d0c9.7702
    !
    ip traffic-export profile g02_to_g01
      interface GigabitEthernet0/1
      mac-address 5475.d0c9.7701
    !
    ip traffic-export profile g01_wan
      interface Vlan1
      bidirectional
      mac-address 000c.295e.93ee
    ip cef
    !
    !
    !
    !
    !
    ip domain name yourdomain.com
    multilink bundle-name authenticated
    !
    !
    crypto pki token default removal timeout 0
    !
    crypto pki trustpoint TP-self-signed-417311045
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-417311045
    revocation-check none
    rsakeypair TP-self-signed-417311045
    !
    license udi pid C3900-SPE150/K9 sn FOC14173AA5
    hw-module sm 1
    !
    hw-module sm 2
    !
    !
    !
    username admin privilege 15 secret 5 $1$P4jj$yHwRu7304TMoYc1ffuJuM/
    !
    !
    controller T1 0/1/0
    cablelength long 0db
    channel-group 0 timeslots 1-24
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
    description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
    ip address 10.250.64.85 255.255.248.0
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/0.1
    shutdown
    !
    interface GigabitEthernet0/0.40
    encapsulation dot1Q 40
    shutdown
    no cdp enable
    !
    interface GigabitEthernet0/1
    ip address 9.9.9.1 255.255.255.0
    duplex full
    speed 100
    ipv6 address FD4A:4297:EEBC:85FF::1/64
    ipv6 enable
    !
    interface GigabitEthernet0/2
    ip address 8.8.8.1 255.255.255.0
    ip traffic-export apply g01_wan
    duplex full
    speed 100
    ipv6 address FD3A:9290:84F:31F7::1/64
    ipv6 enable
    !
    interface Serial0/1/0:0
    ip address 20.20.20.1 255.255.255.252
    encapsulation ppp
    !
    interface GigabitEthernet0/0/0
    !
    interface GigabitEthernet0/0/1
    !
    interface GigabitEthernet0/0/2
    !
    interface GigabitEthernet0/0/3
    !
    interface SM1/0
    ip unnumbered GigabitEthernet0/0
    service-module ip address 10.250.64.83 255.255.248.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.250.64.85
    service-module mgf ip address 10.250.80.202 255.255.255.248
    ipv6 enable
    !
    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk
    no cdp enable
    !
    interface SM2/0
    ip unnumbered GigabitEthernet0/0
    service-module ip address 10.250.64.93 255.255.248.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.250.64.85
    service-module mgf ip address 10.250.80.205 255.255.255.248
    !
    interface SM2/1
    description Internal switch interface connected to Service Module
    switchport trunk allowed vlan 1-1048
    switchport mode trunk
    !
    interface Vlan1
    ip address 10.250.80.201 255.255.255.248
    !
    interface Vlan40
    ip address 10.250.80.193 255.255.255.248
    no autostate
    vlan-id dot1q 40
      exit-vlan-config
    !
    !
    interface Vlan50
    ip address 17.17.17.1 255.255.255.0
    no autostate
    !
    ip forward-protocol nd
    !
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    ip route 10.10.10.0 255.255.255.0 GigabitEthernet0/1
    ip route 10.31.23.0 255.255.255.0 9.9.9.2
    ip route 10.31.27.0 255.255.255.0 8.8.8.2
    ip route 10.50.12.0 255.255.255.0 8.8.8.2
    ip route 10.50.14.2 255.255.255.255 8.8.8.2
    ip route 10.50.116.0 255.255.255.0 9.9.9.2
    ip route 10.50.118.2 255.255.255.255 9.9.9.2
    ip route 10.250.64.83 255.255.255.255 SM1/0
    ip route 10.250.64.93 255.255.255.255 SM2/0
    ip route 10.250.74.25 255.255.255.255 Serial0/1/0:0
    ip route 10.250.80.0 255.255.255.0 10.250.64.1
    ip route 10.250.80.2 255.255.255.255 8.8.8.2
    ip route 10.250.80.3 255.255.255.255 9.9.9.2
    ip route 10.250.80.194 255.255.255.255 Vlan40
    ip route 10.250.80.202 255.255.255.255 Vlan1
    ip route 10.250.80.205 255.255.255.255 Vlan1
    ip route 20.20.20.0 255.255.255.0 Serial0/1/0:0
    ip route 100.100.3.0 255.255.255.0 8.8.8.2
    ip route 129.196.200.0 255.255.255.0 8.8.8.2
    ip route 129.196.200.0 255.255.255.0 10.250.80.1
    !
    !
    no cdp run

    !
    !
    control-plane
    !
    !
    alias exec c config t
    !
    line con 0
    login local
    line aux 0
    line 67
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line 131
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line vty 0 4
    password fluke
    login
    transport input telnet
    line vty 5 15
    password visual
    login
    transport input telnet
    !
    scheduler allocate 20000 1000
    end
    --
    To respond to this post, please click the following link:

    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/3350614>

    or simply reply to this email.


    Subject: RE: New Message from Christopher Daniel in Service Ready Engine Virtualizat
    Replied by: Radhika Miriyala on 29-03-2011 01:38:24 PM
    Hi Christopher,

    Yes you will need to Add a new Vm network port group under the Vswitch0. You can do this from Vsphere using the following steps

    1)      Login to Vsphere client using the esx-admin account (default password is change_it)

    2)      Go to home-> inventory-> configuration tab and then select networking.

    3)      Then select properties of vswitch 0

    4)      Then choose add -> Virtual Machine radio button -> next->in this page give a label to Vmport group and than for the Vlan ID enter: 40

    5)      Once you create the VMnetwork group. Move the VM that you want in this VALN to this Vm network group  you just created (you can do this edit settings of the Virtual machine.



    Let me know if you have any more questions.



    Thanks,

    Radhika

    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, March 29, 2011 10:27 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Christopher Daniel in Service Ready Engine Virtualization - Technical Questions: RE: New Message from WARD COBLEIGH in Service Ready Engine Virtualization -



    Christopher Daniel has created a new message in the forum "Technical Questions":

    --------------------------------------------------------------
    Hi Radhika,

    I had logged in as WARD (our Business account manager). Now reverting to my own account (Christopher Daniel).

    No I have NOT created a new VM network port group with Vlan 40 in ESXI. Do I need to do this?
    Currently the way we have it...

    Virtual Machine 1 (Vlan1)-----|
    Virtual Machine 2 (Vlan40)----|         All three are on the same virtual switch i.e vSwitch0
    Management Network----------|         and belong to the "Virtual Machine Port Group"


    What is the SRE-V/ESXI side of the configuration?
    Is this not seen from the router CLI?

    Please find below the output of SH HYPERVISOR VSWITCH.

    se-10-250-64-93# sh hypervisor vswitch
    Switch Name      Num Ports   Used Ports  Configured Ports  MTU     Uplinks
    vSwitch0                    128         5                 128                   1500      vmnic2

      PortGroup Name        VLAN  ID  Used Ports  Uplinks
      VM Network                   0               2                 vmnic2
      Management Network    0              1                  vmnic2

    Switch Name      Num Ports   Used Ports  Configured Ports  MTU     Uplinks
    ciscoSwitchLocal  8           3           8                 1500

      PortGroup Name        VLAN ID  Used Ports  Uplinks
      CiscoReservedLocal    0        2

    Switch Name      Num Ports   Used Ports  Configured Ports  MTU     Uplinks
    ciscoSwitch           8                  3                        8                  1500       vmnic1

      PortGroup Name        VLAN ID  Used Ports  Uplinks
      CiscoReserved            0                     1           vmnic1

    Please let me know if you need anything else.

    Thanks,
    Chris



    Hi WARD,

    Your IOS side config looks good to me. Did you create a new VM network port group with Vlan 40 in ESXI? Can you also send the SRE-V/ESXI side of the networking configuration? Can You send the output of ¿show hypervisor vswitch¿ from the sre-v console manager.



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, March 29, 2011 7:53 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from WARD COBLEIGH in Service Ready Engine Virtualization - Technical Questions: Issues with Configuring multiple VLANS on the SRE-v.



    WARD COBLEIGH has created a new message in the forum "Technical Questions":

    --------------------------------------------------------------
    Hi,

    We are having problems configuring virtual machines on different VLANS. The configuration is similar in concept to the Cisco documentation on "Configuring VLANS with Cisco IOS Layer 3 Routed Configuration"

    We are unable to ping to our virtual machine on vlan 40. The VM on Vlan1 (on which the hypervisor is as well) seems to respond.

    Please see the config below.. (We have two SREs on the router. You need to look at sm2/0 and sm2/1).
    I have also a dump of sm2/1 switchport.
    How can we troubleshoot this? There is also a dump of sm


    *************SM2/1 SWITCHPORT DUMP *****************************
    3900_router#sh int sm2/1 switchport
    Name: SM2/1
    Switchport: Enabled
    Administrative Mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: dot1q
    Operational Trunking Encapsulation: dot1q
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: 1-1048
    Trunking VLANs Active: 1,40
    Protected: false
    Priority for untagged frames: 0
    Override vlan tag priority: FALSE
    Voice VLAN: none
    Appliance trust: none
    3900_router#

    ************* ROUTER CONFIG *****************************
    3900_router# sh run
    Building configuration...

    Current configuration : 6328 bytes
    !
    ! Last configuration change at 14:46:56 UTC Tue Mar 29 2011
    !
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname 3900_router
    !
    boot-start-marker
    boot system flash c3900-universalk9-mz.SPA.151-3.T.bin
    boot-end-marker
    !
    !
    card type t1 0 1
    logging buffered 51200 warnings
    enable password fluke
    !
    no aaa new-model
    no network-clock-participate wic 1
    !
    ipv6 unicast-routing
    ipv6 cef
    ip source-route
    !
    ip traffic-export profile g01_to_g02
    interface GigabitEthernet0/2
    mac-address 5475.d0c9.7702
    !
    ip traffic-export profile g02_to_g01
    interface GigabitEthernet0/1
    mac-address 5475.d0c9.7701
    !
    ip traffic-export profile g01_wan
    interface Vlan1
    bidirectional
    mac-address 000c.295e.93ee
    ip cef
    !
    !
    !
    !
    !
    ip domain name yourdomain.com
    multilink bundle-name authenticated
    !
    !
    crypto pki token default removal timeout 0
    !
    crypto pki trustpoint TP-self-signed-417311045
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-417311045
    revocation-check none
    rsakeypair TP-self-signed-417311045
    !
    license udi pid C3900-SPE150/K9 sn FOC14173AA5
    hw-module sm 1
    !
    hw-module sm 2
    !
    !
    !
    username admin privilege 15 secret 5 $1$P4jj$yHwRu7304TMoYc1ffuJuM/
    !
    !
    controller T1 0/1/0
    cablelength long 0db
    channel-group 0 timeslots 1-24
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
    description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
    ip address 10.250.64.85 255.255.248.0
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/0.1
    shutdown
    !
    interface GigabitEthernet0/0.40
    encapsulation dot1Q 40
    shutdown
    no cdp enable
    !
    interface GigabitEthernet0/1
    ip address 9.9.9.1 255.255.255.0
    duplex full
    speed 100
    ipv6 address FD4A:4297:EEBC:85FF::1/64
    ipv6 enable
    !
    interface GigabitEthernet0/2
    ip address 8.8.8.1 255.255.255.0
    ip traffic-export apply g01_wan
    duplex full
    speed 100
    ipv6 address FD3A:9290:84F:31F7::1/64
    ipv6 enable
    !
    interface Serial0/1/0:0
    ip address 20.20.20.1 255.255.255.252
    encapsulation ppp
    !
    interface GigabitEthernet0/0/0
    !
    interface GigabitEthernet0/0/1
    !
    interface GigabitEthernet0/0/2
    !
    interface GigabitEthernet0/0/3
    !
    interface SM1/0
    ip unnumbered GigabitEthernet0/0
    service-module ip address 10.250.64.83 255.255.248.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.250.64.85
    service-module mgf ip address 10.250.80.202 255.255.255.248
    ipv6 enable
    !
    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk
    no cdp enable
    !
    interface SM2/0
    ip unnumbered GigabitEthernet0/0
    service-module ip address 10.250.64.93 255.255.248.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.250.64.85
    service-module mgf ip address 10.250.80.205 255.255.255.248
    !
    interface SM2/1
    description Internal switch interface connected to Service Module
    switchport trunk allowed vlan 1-1048
    switchport mode trunk
    !
    interface Vlan1
    ip address 10.250.80.201 255.255.255.248
    !
    interface Vlan40
    ip address 10.250.80.193 255.255.255.248
    no autostate
    vlan-id dot1q 40
    exit-vlan-config
    !
    !
    interface Vlan50
    ip address 17.17.17.1 255.255.255.0
    no autostate
    !
    ip forward-protocol nd
    !
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    ip route 10.10.10.0 255.255.255.0 GigabitEthernet0/1
    ip route 10.31.23.0 255.255.255.0 9.9.9.2
    ip route 10.31.27.0 255.255.255.0 8.8.8.2
    ip route 10.50.12.0 255.255.255.0 8.8.8.2
    ip route 10.50.14.2 255.255.255.255 8.8.8.2
    ip route 10.50.116.0 255.255.255.0 9.9.9.2
    ip route 10.50.118.2 255.255.255.255 9.9.9.2
    ip route 10.250.64.83 255.255.255.255 SM1/0
    ip route 10.250.64.93 255.255.255.255 SM2/0
    ip route 10.250.74.25 255.255.255.255 Serial0/1/0:0
    ip route 10.250.80.0 255.255.255.0 10.250.64.1
    ip route 10.250.80.2 255.255.255.255 8.8.8.2
    ip route 10.250.80.3 255.255.255.255 9.9.9.2
    ip route 10.250.80.194 255.255.255.255 Vlan40
    ip route 10.250.80.202 255.255.255.255 Vlan1
    ip route 10.250.80.205 255.255.255.255 Vlan1
    ip route 20.20.20.0 255.255.255.0 Serial0/1/0:0
    ip route 100.100.3.0 255.255.255.0 8.8.8.2
    ip route 129.196.200.0 255.255.255.0 8.8.8.2
    ip route 129.196.200.0 255.255.255.0 10.250.80.1
    !
    !
    no cdp run

    !
    !
    control-plane
    !
    !
    alias exec c config t
    !
    line con 0
    login local
    line aux 0
    line 67
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line 131
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line vty 0 4
    password fluke
    login
    transport input telnet
    line vty 5 15
    password visual
    login
    transport input telnet
    !
    scheduler allocate 20000 1000
    end
    --
    To respond to this post, please click the following link:

    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/3350614>

    or simply reply to this email.


    --
    To respond to this post, please click the following link:

    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/3351970>

    or simply reply to this email.

    Subject: RE: Issues with Configuring multiple VLANS on the SRE-v.
    Replied by: Christopher Daniel on 29-03-2011 02:19:01 PM
    Thanks for your help!

    That worked!