getting an error while exposing as grid service

Version 1
    This document was generated from CDN thread

    Created by: gayatri88 (simulated) on 25-03-2011 12:39:16 AM
    hii everyone,
             I need to expose kmeans algortihm as a grid service as part of my project. I attached java source code of kmeans algorithm and its wsdl file. I am getting the following error while building and deploying  my Kmeansgrid project. It seems there is an error in my wsdl file. I couldnt figure it out. Please help me, Thank you.
    rocessing WSDL in main1.wsdl
          ERROR: Couldn't find main1PortType porttype.
           ERROR wsdl.WSDLPreprocessor  - ERROR: Couldn't find main1PortType porttype.
          java.lang.Exception: PortType not found: main1PortType
              at org.globus.wsrf.tools.wsdl.TypesProcessor.getPortType(TypesProcessor.java:476)
              at org.globus.wsrf.tools.wsdl.WSDLPreprocessor.main(WSDLPreprocessor.java:192)

    BUILD FAILED
    C:\eclipse\workspace1\KmenasGrid\buildservice.xml:11: The following error occurred while executing this line:
    C:\eclipse\GTK\etc\build.xml:228: The following error occurred while executing this line:
    C:\eclipse\GTK\share\globus_wsrf_tools\build-stubs.xml:160: Java returned: 1

    Subject: RE: getting an error while exposing as grid service
    Replied by: David Staudt on 25-03-2011 05:03:09 PM
    It seems you may have found this forum in error.  This forum is intended to provide discussion and dev-to-dev support for the AXL SOAP interface on the Cisco Unified Communications Manager product.