Basic TCL Script No Longer Working

Version 1
    This document was generated from CDN thread

    Created by: Ryan LaFountain on 23-03-2011 10:48:43 AM
    Hi,
     
    I am attempting to create a very simple TCL script that accepts a call, plays a prompt and then disconnects. I had this working then upgraded code and it stopped working. I then downgraded code back to the original version and it is still not working.
     
    It seems as though 'set queueID [infotag get mod_handle_service B-ACD-SERVICE]' is failing and returning 'unavailable'.
     
    I receive the following in the logs:
     
    *Mar 23 14:28:25.291: //2//TCL :/tcl_PutsObjCmd: TCL AA: +++ B-ACD-SERVICE not registered, Starting B-ACD-SERVICE +++
    *Mar 23 14:28:25.291: //2//TCL :/tcl_HandoffObjCmd:  handoff appl leg_incoming aa2 -s aa2
     
    Which then seems to loop.
     
    My config is:
     

      service aa2 tftp://172.18.108.26/rlafount/app-b-acd-aa-2.1.2.3_rlafount.tcl
      param voice-mail 5000
      param handoff-string aa2
      paramspace english index 1
      paramspace english language en
      param service-name aa2
      param aa-pilot 6465552001
      paramspace english location flash:cme-b-acd-2.1.2.3/
      !
     
    I am open to a more simpler script. I hacked this one together from the default app-b-acd-aa application.
     
    Any help would be greatly appreciated.

    Subject: RE: Basic TCL Script No Longer Working
    Replied by: Yaw-Ming Chen on 23-03-2011 01:30:41 PM
    Modify BACD script for this simple task is not recommended. Write a new script in stead.

    Thanks !