how to configure router for multiple SRE instances

Version 1
    This document was generated from CDN thread

    Created by: Jiasi Li on 01-03-2011 12:35:15 PM
    Hi,
     
    We installed our first SRE module into the Cisco 3900 without any issues with the SM2/0 mgf ip hanging off of interface Vlan1 .  However, when we added a second SRE-V to our existing setup we ran into connectivity issues.  How should we configure the router side and mgf interfaces to accommodate additional SRE modules.
     
    Thanks

    Subject: RE: how to configure router for multiple SRE instances
    Replied by: Jiasi Li on 01-03-2011 12:47:53 PM
    Cisco IOS Software, C3900 Software (C3900-UNIVERSALK9-M), Version 15.1(3)T, RELE
    ASE SOFTWARE (fc1)

    show run

    interface SM1/0
    ip unnumbered GigabitEthernet0/0
    service-module ip address 10.250.64.83 255.255.248.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.250.64.85
    service-module mgf ip address 10.250.80.202 255.255.255.248
    !
    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk
    !
    interface Vlan1
    ip address 10.250.80.201 255.255.255.248
    !
    ip route 10.250.64.83 255.255.255.255 SM1/0
    ip route 10.250.80.202 255.255.255.255 Vlan1


    this is the module that works... 

    Please give some hints as to the config of 2nd module SM2/0.

    Subject: RE: New Message from Jiasi Li in Service Ready Engine Virtualization - Tech
    Replied by: Radhika Miriyala on 01-03-2011 01:02:39 PM
    Jiasi,

    You should be able to configure the second SM in the same way as the SM 1. You need to have the SM 2 mgf Ip address also in the same subnet as Vlan1.



    Here is a sample config from our setup here:



    interface SM1/0

    ip unnumbered GigabitEthernet0/2

    service-module fail-open

    service-module ip address 10.50.80.125 255.255.0.0

    service-module ip default-gateway 10.50.80.1

    service-module mgf ip address 10.10.150.10 255.255.255.0

    !        

    interface SM1/1

    description Internal switch interface connected to Service Module

    !        

    interface SM2/0

    ip unnumbered GigabitEthernet0/0

    service-module ip address 192.168.100.151 255.255.255.0

    !Application: FNDN Running on SMV

    service-module ip default-gateway 192.168.100.150

    service-module mgf ip address 10.10.150.2 255.255.255.0

    !        

    interface SM2/1

    description Internal switch interface connected to Service Module

    !        

    interface Vlan1

    ip address 10.10.150.1 255.255.255.0

    !        



    If you have tried this and still seeing an issue. Please give us the IOS configuration with both SM¿s configured and also what is the exact issue you are seeing. 

    1)      Have you installed the sre-v image? Or is there some other application on the SRE?

    2)      Have you activated the license on the second SM?





    Thanks,

    Radhika

    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, March 01, 2011 9:48 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Jiasi Li in Service Ready Engine Virtualization - Technical Questions: RE: how to configure router for multiple SRE instances



    Jiasi Li has created a new message in the forum "Technical Questions":

    --------------------------------------------------------------
    Cisco IOS Software, C3900 Software (C3900-UNIVERSALK9-M), Version 15.1(3)T, RELE
    ASE SOFTWARE (fc1)

    show run

    interface SM1/0
    ip unnumbered GigabitEthernet0/0
    service-module ip address 10.250.64.83 255.255.248.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.250.64.85
    service-module mgf ip address 10.250.80.202 255.255.255.248
    !
    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk
    !
    interface Vlan1
    ip address 10.250.80.201 255.255.255.248
    !
    ip route 10.250.64.83 255.255.255.255 SM1/0
    ip route 10.250.80.202 255.255.255.255 Vlan1


    this is the module that works...

    Please give some hints as to the config of 2nd module SM2/0.
    --
    To respond to this post, please click the following link:

    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/3115672>

    or simply reply to this email.

    Subject: RE: New Message from Jiasi Li in Service Ready Engine Virtualization - Tech
    Replied by: Anurag Gurtu on 01-03-2011 02:15:39 PM
    If you can share your current config we can add to it and let you know how to configure the modules.



    Thanks



    Anurag Gurtu, CISSP

    Subject: RE: New Message from Jiasi Li in Service Ready Engine Virtualization - Tech
    Replied by: Anurag Gurtu on 01-03-2011 02:19:39 PM
    You can do the following for SM 2/0





    interface SM2/0
    ip address 10.10.10.1 255.255.255.0
    service-module ip address 10.10.10.2 255.255.255.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.10.10.1
    service-module mgf ip address 10.250.80.203 255.255.255.248
    !
    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk
    !
    interface Vlan1
    ip address 10.250.80.201 255.255.255.248
    !



    What I did was configure IP for SM2/0 and used the same VLAN1 and configured 10.250.80.203 for ESXi.



    Thanks



    Anurag Gurtu, CISSP



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, March 01, 2011 9:48 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Jiasi Li in Service Ready Engine Virtualization - Technical Questions: RE: how to configure router for multiple SRE instances



    Jiasi Li has created a new message in the forum "Technical Questions":

    --------------------------------------------------------------
    Cisco IOS Software, C3900 Software (C3900-UNIVERSALK9-M), Version 15.1(3)T, RELE
    ASE SOFTWARE (fc1)

    show run

    interface SM1/0
    ip unnumbered GigabitEthernet0/0
    service-module ip address 10.250.64.83 255.255.248.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.250.64.85
    service-module mgf ip address 10.250.80.202 255.255.255.248
    !
    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk
    !
    interface Vlan1
    ip address 10.250.80.201 255.255.255.248
    !
    ip route 10.250.64.83 255.255.255.255 SM1/0
    ip route 10.250.80.202 255.255.255.255 Vlan1


    this is the module that works...

    Please give some hints as to the config of 2nd module SM2/0.
    --
    To respond to this post, please click the following link:

    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/3115672>

    or simply reply to this email.

    Subject: RE: how to configure router for multiple SRE instances
    Replied by: Jiasi Li on 01-03-2011 02:53:07 PM
    Thanks Anurag for the pointers.   The issue it turns out was due to a typo in the first SM's mgf ip subnet mask.
    It is probably confusing the router as to which interface to send the packets.
    !
    interface SM1/0
    service-module mgf ip address 10.250.80.202 255.255.255.240 !!!!!
    ! ! ##### this is the 2nd non-working SM #####
    interface SM2/0
    service-module mgf ip address 10.250.80.205 255.255.255.248 !!!!!
    !

    Subject: RE: New Message from Jiasi Li in Service Ready Engine Virtualization - Tech
    Replied by: Radhika Miriyala on 01-03-2011 12:38:39 PM
    Hi Jiasi,

    What is the IOS image are you using?  When you also send the output of ¿ show run¿ from the IOS.



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, March 01, 2011 9:35 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Jiasi Li in Service Ready Engine Virtualization - Technical Questions: how to configure router for multiple SRE instances



    Jiasi Li has created a new message in the forum "Technical Questions":

    --------------------------------------------------------------
    Hi,

    We installed our first SRE module into the Cisco 3900 without any issues with the SM2/0 mgf ip hanging off of interface Vlan1 .  However, when we added a second SRE-V to our existing setup we ran into connectivity issues.  How should we configure the router side and mgf interfaces to accommodate additional SRE modules.

    Thanks
    --
    To respond to this post, please click the following link:

    <http://developer.cisco.com/web/srev/forums/-/message_boards/view_message/3115611>

    or simply reply to this email.