CTI Port - Customer Ends Call in IVR and no instant event!

Version 1

    Subject: RE: New Message from Rodrigo Boavida in Unified Contact Center Express CTI
    Replied by: David Lender on 28-02-2011 03:04:39 PM
    UCCX CTI reports events for agents and their devices not for IVR or CTI ports.  Are you developing a bridge-mode application?  You can monitor all agents and  calls but not CTI ports.



    If the call is routed to an agent before the caller hangs up, it could take a while to clear the call.  There may be a timer to configure for this.  Suggest posing your question to myciscocommunity.cisco.com here https://www.myciscocommunity.com/community/technology/collaboration
    This document was generated from CDN thread

    Created by: Rodrigo Boavida on 28-02-2011 10:57:36 AM
    Hi all,
     
    I'm having a problem using the CTI Protocol and thinking if it's a UCCX bug or it's simply missed configuration.
     
    I'm using version 8.5
     
    If a customer calls to the IVR and then hangs up while in the script application, there isn't any END_CALL_EVENT event or CLEARED or any other event.
     
    Only after 1,5 - 2 minutes I get the END_CALL_EVENT.
     
    There's no problem with my code since I get the same problem if I got directly to the UCCX stats report and see that the call in considered on queue even after the customer has hanged up the call a minute ago.
     
    Can anyone help me on this and give me a hint??
     
    Many thanks,
    Rodrigo
     
    ¿
    ¿ 
     
     
     
     
     

    Subject: RE: New Message from Rodrigo Boavida in Unified Contact Center Express CTI
    Replied by: Rodrigo Boavida on 28-02-2011 04:05:16 PM
    Hi David,

    I really don't need to use the CTI Protocol, but since I'm using it to control the agents, I also tried using it to monitor the calls in the queue. And this means the Customer is in the IVR.

    I'm using the bridge mode.

    I first tried just querying the real time tables, and this is the only time I get delay in real time tables. The reports says there is a call on the queue and is updated only 2 minutes after.

    I also think this could be a wrong configuration since I have a colleague that has a UCCX 7.0 in the Client and this issue does not occur.


    Thanks for the answer.


    Rodrigo

    Subject: RE: New Message from Rodrigo Boavida in Unified Contact Center Express CTI
    Replied by: David Lender on 01-03-2011 12:20:39 PM
    I suggest you try opening a TAC case on the call still in queue for 2 minutes.