CUC8.5 CUPI XML schema

Version 1

    Subject: Re: New Message from Sascha Monteiro in Cisco Unity Connection Provisioning
    Replied by: David Wanagel on 07-02-2011 06:37:32 AM
    There were some differences in import behavior between the GUI and the API
    up until 8.5.1ES14.  You will need a fairly recent version of the Connection
    server to get the change that populates the first name and last name fields.

    -Dave


    On 2/7/11 1:10 AM, "Cisco Developer Community Forums"
    <cdicuser@developer.cisco.com> wrote:

    > Sascha Monteiro has created a new message in the forum "CUPI Questions":
    >
    > --------------------------------------------------------------
    > when will the XML schema be available?
    > I am testing importing ldap users, which is a new feature in 8.5, but when I
    > import the user,
    > the first and last name are empty, and display name is populated with the
    > alias..
    > The fields should just be coming from the internal database, and don't have to
    > be provided.
    > After the next ldap sync the first and last name appear to be correct again
    > :-|
    >  
    > I just try to find out if the xml body is correct
    >  
    > this is the data I use;
    > POST
    > https://9.1.1.233/vmrest/import/users/ldap?templateAlias=voicemailusertemplate
    > Authorization: Basic xxxxx
    > Content-Type: application/xml
    >  
    > <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    > <ImportUser>
    > <alias>testuser1</alias>
    > <firstName>Test</firstName>
    > <lastName>User1</lastName>
    > <pkid>f8748dab-52fb-4f47-a5e1-d8677abcbccc</pkid>
    > <dtmfAccessId>5522</dtmfAccessId>
    > <displayName>Test User1</displayName>
    > </ImportUser>
    >  
    > I get 201 created, so all seems okay, I tried remving the first/lastnames but
    > same issue
    > --
    > To respond to this post, please click the following link:
    >
    > <http://developer.cisco.com/web/cupi/forums/-/message_boards/view_message/3022
    > 757>
    >
    > or simply reply to this email.
    This document was generated from CDN thread

    Created by: Sascha Monteiro on 07-02-2011 01:10:16 AM
    when will the XML schema be available?
    I am testing importing ldap users, which is a new feature in 8.5, but when I import the user,
    the first and last name are empty, and display name is populated with the alias..
    The fields should just be coming from the internal database, and don't have to be provided.
    After the next ldap sync the first and last name appear to be correct again :-|
     
    I just try to find out if the xml body is correct
     
    this is the data I use;
    POST https://9.1.1.233/vmrest/import/users/ldap?templateAlias=voicemailusertemplate
    Authorization: Basic xxxxx
    Content-Type: application/xml
     
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <ImportUser>
    <alias>testuser1</alias>
    <firstName>Test</firstName>
    <lastName>User1</lastName>
    <pkid>f8748dab-52fb-4f47-a5e1-d8677abcbccc</pkid>
    <dtmfAccessId>5522</dtmfAccessId>
    <displayName>Test User1</displayName>
    </ImportUser>
     
    I get 201 created, so all seems okay, I tried remving the first/lastnames but same issue