New Cisco 2951 / SRE-V configuration

Version 1
    This document was generated from CDN thread

    Created by: Nachiket Deshpande on 12-01-2011 12:07:00 AM
    Hi, 
     
    I'm trying to setup the latest SRE-V we received yesterday with a new 2951. I do not seem to see the SM in the "show run" of the router:
     

    yourname#sh run
    Building configuration...
     
     
    Current configuration : 5030 bytes
    !
    ! Last configuration change at 00:03:16 UTC Wed Jan 12 2011 by cisco
    !
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname yourname
    !
    boot-start-marker
    boot-end-marker
    !
    !
    ! card type command needed for slot/vwic-slot 0/0
    logging buffered 51200 warnings
    !
    no aaa new-model
    !
    no ipv6 cef
    ip source-route
     
    yourname#en
    yourname#sh run
    Building configuration...
     
     
    Current configuration : 5030 bytes
    !
    ! Last configuration change at 00:03:16 UTC Wed Jan 12 2011 by cisco
    !
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname yourname
    !
    boot-start-marker
    boot-end-marker
    !
    !
    ! card type command needed for slot/vwic-slot 0/0
    logging buffered 51200 warnings
    !
    no aaa new-model
    !
    no ipv6 cef
    ip source-route
    ip cef    
    !
    !
    !
    !
    !
    ip domain name yourdomain.com
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    crypto pki token default removal timeout 0
    !
    crypto pki trustpoint TP-self-signed-906767808
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-906767808
     revocation-check none
    !
    !
    crypto pki certificate chain TP-self-signed-906767808
     certificate self-signed 01
      3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
      30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274 
      69666963 6174652D 39303637 36373830 38301E17 0D313031 32313732 30333331 
      365A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F 
      532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3930 36373637 
      38303830 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100 
      AD342683 74CD80AC B629C93F 33381520 B08D99C2 FBA2E68C 72616A0A 447BD694 
      356DFCAD B8B162FE 94487B86 F08D244F 9A5F4EC7 CB7BD64B A15B5012 35A8F8B5 
      14620278 5474B550 EDA0402C F8BD2EF0 EDA9F197 281E59D8 1214F859 5BB427F3 
      F79A8DE0 CC37056E 20694361 8ECD248F D3CF5458 68ACD637 24CDFE17 9D2E65F1 
      02030100 01A37730 75300F06 03551D13 0101FF04 05300301 01FF3022 0603551D 
      11041B30 19821779 6F75726E 616D652E 796F7572 646F6D61 696E2E63 6F6D301F 
      0603551D 23041830 168014C6 2FEB2830 49510B96 DBB9C7CB 722E22FA 46B4F530 
      1D060355 1D0E0416 0414C62F EB283049 510B96DB B9C7CB72 2E22FA46 B4F5300D 
      06092A86 4886F70D 01010405 00038181 00311DB0 1E4C8FC8 3DCBE745 21EC7D33 
      9A9CF146 F312637D 1287DECB 3389CC6F 65BBF0DC A0E737EF 308A23D4 FA17C1EF 
      8C1498FE EAFC1CD5 C3C21F6B F38EDA30 1ED1263B 27CD1F13 EED65AAA 4FFA8171 
      0E87961A 474EB239 233D4ED5 4AB17EE8 2CC0DA70 30FC490F 51DB774C EC7C5E98 
      098CD58B F7EA4DCE CB435EE7 BEB2AE51 26
       quit
    voice-card 0
    !
    !
    !         
    !
    !
    !
    !
    license udi pid CISCO2951/K9 sn FTX1451AM0V
    hw-module pvdm 0/0
    !
    !
    !
    username cisco privilege 15 secret 5 $1$aUqy$aOjafgL./kGg8ATVSgSqw0
    !
    redundancy
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
     description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
     ip address 10.10.10.1 255.255.255.248
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/2
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    ip forward-protocol nd
    !
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    !
    access-list 23 permit 10.10.10.0 0.0.0.7
    !
    nls resp-timeout 1
    cpd cr-id 1
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    gatekeeper
     shutdown
    !
    banner exec ^C
    % Password expiration warning.
    -----------------------------------------------------------------------
     
    Cisco Configuration Professional (Cisco CP) is installed on this device 
    and it provides the default username "cisco" for  one-time use. If you have 
    already used the username "cisco" to login to the router and your IOS image 
    supports the "one-time" user option, then this username has already expired. 
    You will not be able to login to the router with this username after you exit 
    this session.
     
    It is strongly suggested that you create a new username with a privilege level 
    of 15 using the following command.
     
    username <myuser> privilege 15 secret 0 <mypassword>
     
    Replace <myuser> and <mypassword> with the username and password you want to 
    use.
     
    -----------------------------------------------------------------------
    ^C
    banner login ^C
    -----------------------------------------------------------------------
    Cisco Configuration Professional (Cisco CP) is installed on this device. 
    This feature requires the one-time use of the username "cisco" with the 
    password "cisco". These default credentials have a privilege level of 15.
     
    YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE  PUBLICLY-KNOWN 
    CREDENTIALS
     
    Here are the Cisco IOS commands.
     
    username <myuser>  privilege 15 secret 0 <mypassword>
    no username cisco
     
    Replace <myuser> and <mypassword> with the username and password you want 
    to use. 
     
    IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE 
    TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.
     
    For more information about Cisco CP please follow the instructions in the 
    QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp 
    -----------------------------------------------------------------------
    ^C
    !
    line con 0
     login local
    line aux 0
    line vty 0 4
     access-class 23 in
     privilege level 15
     login local
     transport input telnet ssh
    line vty 5 15
     access-class 23 in
     privilege level 15
     login local
     transport input telnet ssh
    !
    scheduler allocate 20000 1000
    end


    Is my IOS image out of date? This is what I have:



    yourname#dir flash0:
    Directory of flash0:/


        1  -rw-    57011012  Dec 17 2010 20:14:40 +00:00  c2951-universalk9_npe-mz.SPA.151-2.T2.bin
        2  -rw-        2903  Dec 17 2010 20:29:30 +00:00  cpconfig-29xx.cfg
        3  -rw-     2941440  Dec 17 2010 20:29:46 +00:00  cpexpress.tar
        4  -rw-        1038  Dec 17 2010 20:29:56 +00:00  home.shtml
        5  -rw-      115712  Dec 17 2010 20:30:02 +00:00  home.tar
        6  -rw-     1697952  Dec 17 2010 20:30:18 +00:00  securedesktop-ios-3.1.1.45-k9.pkg
        7  -rw-      415956  Dec 17 2010 20:30:30 +00:00  sslclient-win-1.1.4.176.pkg



    Thanks,


    Nash

    Subject: RE: New Message from Nachiket Deshpande in Service Ready Engine Virtualizat
    Replied by: Brett Tiller on 12-01-2011 01:40:01 AM
    Hi Nachiket,



    Please first make sure that you are using the correct IOS release in your router.  It should be at least 15.1.T3 and is provided on the CDN site: http://developer.cisco.com/web/srev/docs .  Secondly, once the correct IOS release is installed, if the SM interface still does not appear, please power down the router, then remove and reseat the service module.   Power the router back on and check if the interface has appeared.   If this step doesn¿t resolve the issue, please type ¿show diag | include FRU¿ on the router and include that data in your response.  In addition, please type ¿show version | sec image¿ on the router and include that data as well.



    Thanks,



    Brett

    Custom Application Engineer

    http://developer.cisco.com/web/axp

    http://developer.cisco.com/web/srev





    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, January 11, 2011 4:07 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Nachiket Deshpande in Service Ready Engine Virtualization - Technical Questions: New Cisco 2951 / SRE-V configuration



    Nachiket Deshpande has created a new message in the forum "Technical Questions":
    --------------------------------------------------------------
    Hi,

    I'm trying to setup the latest SRE-V we received yesterday with a new 2951. I do not seem to see the SM in the "show run" of the router:


    yourname#sh run
    Building configuration...


    Current configuration : 5030 bytes
    !
    ! Last configuration change at 00:03:16 UTC Wed Jan 12 2011 by cisco
    !
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname yourname
    !
    boot-start-marker
    boot-end-marker
    !
    !
    ! card type command needed for slot/vwic-slot 0/0
    logging buffered 51200 warnings
    !
    no aaa new-model
    !
    no ipv6 cef
    ip source-route

    yourname#en
    yourname#sh run
    Building configuration...


    Current configuration : 5030 bytes
    !
    ! Last configuration change at 00:03:16 UTC Wed Jan 12 2011 by cisco
    !
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname yourname
    !
    boot-start-marker
    boot-end-marker
    !
    !
    ! card type command needed for slot/vwic-slot 0/0
    logging buffered 51200 warnings
    !
    no aaa new-model
    !
    no ipv6 cef
    ip source-route
    ip cef   
    !
    !
    !
    !
    !
    ip domain name yourdomain.com
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    crypto pki token default removal timeout 0
    !
    crypto pki trustpoint TP-self-signed-906767808
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-906767808
    revocation-check none
    !
    !
    crypto pki certificate chain TP-self-signed-906767808
    certificate self-signed 01
      3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 39303637 36373830 38301E17 0D313031 32313732 30333331
      365A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
      532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3930 36373637
      38303830 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
      AD342683 74CD80AC B629C93F 33381520 B08D99C2 FBA2E68C 72616A0A 447BD694
      356DFCAD B8B162FE 94487B86 F08D244F 9A5F4EC7 CB7BD64B A15B5012 35A8F8B5
      14620278 5474B550 EDA0402C F8BD2EF0 EDA9F197 281E59D8 1214F859 5BB427F3
      F79A8DE0 CC37056E 20694361 8ECD248F D3CF5458 68ACD637 24CDFE17 9D2E65F1
      02030100 01A37730 75300F06 03551D13 0101FF04 05300301 01FF3022 0603551D
      11041B30 19821779 6F75726E 616D652E 796F7572 646F6D61 696E2E63 6F6D301F
      0603551D 23041830 168014C6 2FEB2830 49510B96 DBB9C7CB 722E22FA 46B4F530
      1D060355 1D0E0416 0414C62F EB283049 510B96DB B9C7CB72 2E22FA46 B4F5300D
      06092A86 4886F70D 01010405 00038181 00311DB0 1E4C8FC8 3DCBE745 21EC7D33
      9A9CF146 F312637D 1287DECB 3389CC6F 65BBF0DC A0E737EF 308A23D4 FA17C1EF
      8C1498FE EAFC1CD5 C3C21F6B F38EDA30 1ED1263B 27CD1F13 EED65AAA 4FFA8171
      0E87961A 474EB239 233D4ED5 4AB17EE8 2CC0DA70 30FC490F 51DB774C EC7C5E98
      098CD58B F7EA4DCE CB435EE7 BEB2AE51 26
       quit
    voice-card 0
    !
    !
    !        
    !
    !
    !
    !
    license udi pid CISCO2951/K9 sn FTX1451AM0V
    hw-module pvdm 0/0
    !
    !
    !
    username cisco privilege 15 secret 5 $1$aUqy$aOjafgL./kGg8ATVSgSqw0
    !
    redundancy
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
    description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
    ip address 10.10.10.1 255.255.255.248
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/2
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    ip forward-protocol nd
    !
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    !
    access-list 23 permit 10.10.10.0 0.0.0.7
    !
    nls resp-timeout 1
    cpd cr-id 1
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    gatekeeper
    shutdown
    !
    banner exec ^C
    % Password expiration warning.
    -----------------------------------------------------------------------

    Cisco Configuration Professional (Cisco CP) is installed on this device
    and it provides the default username "cisco" for  one-time use. If you have
    already used the username "cisco" to login to the router and your IOS image
    supports the "one-time" user option, then this username has already expired.
    You will not be able to login to the router with this username after you exit
    this session.

    It is strongly suggested that you create a new username with a privilege level
    of 15 using the following command.

    username <myuser> privilege 15 secret 0 <mypassword>

    Replace <myuser> and <mypassword> with the username and password you want to
    use.

    -----------------------------------------------------------------------
    ^C
    banner login ^C
    -----------------------------------------------------------------------
    Cisco Configuration Professional (Cisco CP) is installed on this device.
    This feature requires the one-time use of the username "cisco" with the
    password "cisco". These default credentials have a privilege level of 15.

    YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE  PUBLICLY-KNOWN
    CREDENTIALS

    Here are the Cisco IOS commands.

    username <myuser>  privilege 15 secret 0 <mypassword>
    no username cisco

    Replace <myuser> and <mypassword> with the username and password you want
    to use.

    IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE
    TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.

    For more information about Cisco CP please follow the instructions in the
    QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp
    -----------------------------------------------------------------------
    ^C
    !
    line con 0
    login local
    line aux 0
    line vty 0 4
    access-class 23 in
    privilege level 15
    login local
    transport input telnet ssh
    line vty 5 15
    access-class 23 in
    privilege level 15
    login local
    transport input telnet ssh
    !
    scheduler allocate 20000 1000
    end


    Is my IOS image out of date? This is what I have:



    yourname#dir flash0:
    Directory of flash0:/


        1  -rw-    57011012  Dec 17 2010 20:14:40 +00:00  c2951-universalk9_npe-mz.SPA.151-2.T2.bin
        2  -rw-        2903  Dec 17 2010 20:29:30 +00:00  cpconfig-29xx.cfg
        3  -rw-     2941440  Dec 17 2010 20:29:46 +00:00  cpexpress.tar
        4  -rw-        1038  Dec 17 2010 20:29:56 +00:00  home.shtml
        5  -rw-      115712  Dec 17 2010 20:30:02 +00:00  home.tar
        6  -rw-     1697952  Dec 17 2010 20:30:18 +00:00  securedesktop-ios-3.1.1.45-k9.pkg
        7  -rw-      415956  Dec 17 2010 20:30:30 +00:00  sslclient-win-1.1.4.176.pkg



    Thanks,


    Nash
    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/web/srev/forums/-/message_boards/message/2894997>
    or simply reply to this email.