RTP stream using <StartMedia> on 6961

Version 1
    This document was generated from CDN thread

    Created by: Gerald Chong on 09-12-2010 06:44:52 AM
    Try to init multicast RTP stream via <StartMedia> push method, tested working on 7975 and 7965 handset however getting "<?xml version="1.0" encoding="utf-8"?><CiscoIPPhoneError Number="1"/>" from 6961.
     
    Anything facing similar issue ? or had successfully RTP RX or TX with 6961 handset ?
     
    I've tried on both 9.0.3 and 9.1.1 firmware on 6961, but still no luck so far.

    Subject: RE: RTP stream using <StartMedia> on 6961
    Replied by: douglas conklin on 09-12-2010 07:07:43 PM
    Try to init multicast RTP stream via <StartMedia> push method, tested working on 7975 and 7965 handset however getting "<?xml version="1.0" encoding="utf-8"?><CiscoIPPhoneError Number="1"/>" from 6961.
     
    Anything facing similar issue ? or had successfully RTP RX or TX with 6961 handset ?
     
    I've tried on both 9.0.3 and 9.1.1 firmware on 6961, but still no luck so far.


    I believe error 1 is an error parsing the request. If you post the request you are sending, someone may be able to spot what the problem is.
     
     

    Subject: RE: RTP stream using <StartMedia> on 6961
    Replied by: Gerald Chong on 10-12-2010 04:09:06 AM
     


    I believe error 1 is an error parsing the request. If you post the request you are sending, someone may be able to spot what the problem is. 
     
     




     
    The XML look like this :
    <startMedia>
    <mediaStream onStopped='Notify:http:172.24.1.19:80:Notify.aspx' receiveVolume='80'>
    <type>audio</type>
    <codec>G.711</codec>
    <mode>send</mode>
    <address>239.1.2.3</address>
    <port>20480</port>
    </mediaStream>
    </startMedia>
     
     
    If there are malformed xml, how come it work on the 79XX handsets but not on 6961 ?

    Subject: RE: RTP stream using <StartMedia> on 6961
    Replied by: douglas conklin on 10-12-2010 06:56:33 PM
     



    I believe error 1 is an error parsing the request. If you post the request you are sending, someone may be able to spot what the problem is. 
     
     





     
    The XML look like this :
    <startMedia>
    <mediaStream onStopped='Notify:http:172.24.1.19:80:Notify.aspx' receiveVolume='80'>
    <type>audio</type>
    <codec>G.711</codec>
    <mode>send</mode>
    <address>239.1.2.3</address>
    <port>20480</port>
    </mediaStream>
    </startMedia>
     
     
    If there are malformed xml, how come it work on the 79XX handsets but not on 6961 ?


    Chapter 4 in this document:
     
    http://developer.cisco.com/c/document_library/get_file?folderId=32264&name=DLFE-25638.pdf
     
    It appears that RTP streaming is classified under component services, and is not supported on the 6961.
     
     
     

    Subject: RE: RTP stream using <StartMedia> on 6961
    Replied by: abhishek saxena on 13-12-2010 05:28:10 AM
    hI
     
    WHICH IS THE MEDIA SERVER YOU ARE USING.....??????
     
    Regards
    ABHISHEK SAXENA
     


     



    I believe error 1 is an error parsing the request. If you post the request you are sending, someone may be able to spot what the problem is. 
     
     





     
    The XML look like this :
    <startMedia>
    <mediaStream onStopped='Notify:http:172.24.1.19:80:Notify.aspx' receiveVolume='80'>
    <type>audio</type>
    <codec>G.711</codec>
    <mode>send</mode>
    <address>239.1.2.3</address>
    <port>20480</port>
    </mediaStream>
    </startMedia>
     
     
    If there are malformed xml, how come it work on the 79XX handsets but not on 6961 ?



    Chapter 4 in this document:
     
    http://developer.cisco.com/c/document_library/get_file?folderId=32264&name=DLFE-25638.pdf
     
    It appears that RTP streaming is classified under component services, and is not supported on the 6961.
     
     
     


    Subject: RE: RTP stream using <StartMedia> on 6961
    Replied by: Hasan Ghamloush on 10-05-2011 05:02:39 AM
    Try to init multicast RTP stream via <StartMedia> push method, tested working on 7975 and 7965 handset however getting "<?xml version="1.0" encoding="utf-8"?><CiscoIPPhoneError Number="1"/>" from 6961.

    Anything facing similar issue ? or had successfully RTP RX or TX with 6961 handset ?

    I've tried on both 9.0.3 and 9.1.1 firmware on 6961, but still no luck so far.

    Dublicate Your quotations

    Subject: RE: RTP stream using <StartMedia> on 6961
    Replied by: Hasan Ghamloush on 10-05-2011 05:02:39 AM
    Try to init multicast RTP stream via <StartMedia> push method, tested working on 7975 and 7965 handset however getting "<?xml version="1.0" encoding="utf-8"?><CiscoIPPhoneError Number="1"/>" from 6961.

    Anything facing similar issue ? or had successfully RTP RX or TX with 6961 handset ?

    I've tried on both 9.0.3 and 9.1.1 firmware on 6961, but still no luck so far.

    Dublicate Your quotations