Timeout on RBIP in live Customer PoC

Version 1
    This document was generated from CDN thread

    Created by: Geoff Yates on 20-11-2010 01:34:34 AM
    Hi All,
     
    Customer has started evaluating themselves in a field PoC acenario and I'm not able to get onsite at the moment. I did have this running in my lab but for their environment they have made substantial changes and some of those we not supporting but I'd like to be able guide them a bit better.
     
    The SM is not registering:
     
     <!--StartFragment-->Initializing memory #1. Please wait...

    Initializing memory #2. Please wait...

    This may take a minute....

     Serial ATA Port 0 : Hitachi HTE545050B9A300                

     Serial ATA Port 1 : Hitachi HTE545050B9A300                 

    DDR Memory 4096 MB detected

    Intel(R) Core(TM)2 Duo CPU     L9400  @ 1.86GHz

    BIOS SM 3.52.6,  BIOS Build date: 08/03/2010

    Intel(R) Core(TM)2 Duo CPU     L9400  @ 1.86GHz

    BIOS SM 3.52.6,  BIOS Build date: 08/03/2010

    System now booting...

    Please wait...  

    Please press P to select Primary Boot Loader ...   

              or S to select Secondary Boot Loader ...   

              or wait to boot from default configuration ...   

    .......................................................................................................

    Now booting from primary boot loader....   

    Authenticating boot loader....   

    Primary Boot Loader Authenticated - booting....   

    Please enter '***' to change boot configuration:

    Detect and Initialze network device

    Backup current platform configurations....

    SRE step 1 - SM registration...
     
    -----
    SRE information
     
    <!--StartFragment-->Show config:

    ServicesEngine boot-loader> show config                                        

    IP addr:                10.116.248.254

    Netmask:                255.255.255.252

    TFTP server :           10.116.248.253

    GW IP addr:             10.116.248.253

    eth int:                internal

    Default Boot:           chainloader

    Bootloader Version:     2.1.29.35

    Bootloader Name:        bootloader

    Default Helper-file:   sre-v-installer.smv.1.0.0.35

    Default bootloader:     primary

    service-module SM1/0 status

    R3SWTB0001#service-module SM1/0 status

    Service Module is Cisco SM1/0

    Service Module supports session via TTY line 67

    Service Module is failed

    Service Module heartbeat-reset is enabled

    Service Module is in fail open

    Service Module status is not available

    No install/uninstall in progress

    Local Partition Info
    =====================

      Please reset module to retrieve

      partition information if needed
    <!--EndFragment-->
     
    Router configuration:
     
    R3SWTB0001#sh run

    Building configuration...

    Current configuration : 6299 bytes

    ! Last configuration change at 15:31:42 EST Thu Oct 28 2010

    ! NVRAM config last updated at 16:01:12 EST Thu Oct 28 2010

    version 15.1

    service timestamps debug datetime msec

    service timestamps log datetime msec

    no service password-encryption

    hostname R3SWTB0001

    boot-start-marker

    boot system flash:c2900-universalk9-mz.SSA.T_BASE_1_20100819

    boot-end-marker

    enable secret 5 $1$5V52$yFd4/uBz65X9tMLvSUsER0

    no aaa new-model

    clock timezone EST 10 0

    clock calendar-valid

    no ipv6 cef

    ip source-route

    ip cef

    no ip domain lookup

    ip domain name network.root.internal

    multilink bundle-name authenticated

    crypto pki token default removal timeout 0

    license udi pid CISCO2911/K9 sn FTX1405A1ZG

    hw-module sm 1

    bridge irb

    interface GigabitEthernet0/0

    description Outside WAN link to Telstra

    bandwidth 512

    ip address 172.16.5.49 255.255.255.248

    ip flow ingress

    load-interval 30

    duplex full

    speed 100

    no cdp enable

    interface GigabitEthernet0/1
    description Inside LAN Trunk
    no ip address
    ip flow ingress
    duplex full
    speed 100

    interface GigabitEthernet0/1.50
    description Management VLAN
    encapsulation dot1Q 50
    ip address 10.116.245.1 255.255.255.0
    ip flow ingress

    interface GigabitEthernet0/1.200
    description DoC Data VLAN
    encapsulation dot1Q 200
    ip address 10.147.224.1 255.255.255.0
    ip helper-address 10.240.128.240
    ip helper-address 10.240.128.241
    ip flow ingress

    interface GigabitEthernet0/1.800
    encapsulation dot1Q 800

    interface GigabitEthernet0/2
    no ip address
    shutdown
    duplex auto
    speed auto


    interface SM1/0
    ip address 10.116.248.253 255.255.255.252
    service-module fail-open
    service-module ip address 10.116.248.254 255.255.255.252
    service-module ip default-gateway 10.116.248.253
    service-module mgf ip address 10.243.245.2 255.255.255.0
    service-module mgf ip default-gateway 10.243.245.1

    bridge-group 1

    hold-queue 60 out

    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk

    interface Vlan1
    no ip address

    interface Vlan800
    no ip address

    interface BVI1
    ip address 10.243.245.1 255.255.255.0

    router bgp 64760

    bgp router-id 10.116.245.1

    bgp log-neighbor-changes

    neighbor 172.16.5.50 remote-as 65530

    address-family ipv4

    redistribute connected

    neighbor 172.16.5.50 activate

    neighbor 172.16.5.50 soft-reconfiguration inbound

    neighbor 172.16.5.50 prefix-list defaultonly in

    no auto-summary

    exit-address-family

    ip forward-protocol nd
    ip forward-protocol udp bootpc

    no ip http server
    no ip http secure-server

    ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
    ip route 10.116.248.254 255.255.255.255 SM1/0
    ip route 10.243.245.2 255.255.255.255 GigabitEthernet0/1.800
    ip route 10.243.245.2 255.255.255.255 Vlan800
    ip route 10.243.245.2 255.255.255.255 BVI1

    logging source-interface GigabitEthernet0/1.50

    logging 10.118.0.188

    snmp-server ifindex persist
    snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
    snmp-server enable traps vrrp
    snmp-server enable traps ds1
    snmp-server enable traps tty
    snmp-server enable traps eigrp
    snmp-server enable traps ospf state-change
    snmp-server enable traps ospf errors
    snmp-server enable traps ospf retransmit
    snmp-server enable traps ospf lsa
    snmp-server enable traps ospf cisco-specific state-change nssa-trans-change
    snmp-server enable traps ospf cisco-specific state-change shamlink interface-old
    snmp-server enable traps ospf cisco-specific state-change shamlink neighbor
    snmp-server enable traps ospf cisco-specific errors
    snmp-server enable traps ospf cisco-specific retransmit
    snmp-server enable traps ospf cisco-specific lsa
    snmp-server enable traps license
    snmp-server enable traps envmon
    snmp-server enable traps ethernet cfm cc mep-up mep-down cross-connect loop config
    snmp-server enable traps ethernet cfm crosscheck mep-missing mep-unknown service-up
    snmp-server enable traps flash insertion removal
    snmp-server enable traps c3g
    snmp-server enable traps ds3
    snmp-server enable traps adslline
    snmp-server enable traps vdsl2line
    snmp-server enable traps icsudsu
    snmp-server enable traps isdn call-information
    snmp-server enable traps isdn layer2
    snmp-server enable traps isdn chan-not-avail
    snmp-server enable traps isdn ietf
    snmp-server enable traps ds0-busyout
    snmp-server enable traps ds1-loopback
    snmp-server enable traps bgp
    snmp-server enable traps isis
    snmp-server enable traps rf
    snmp-server enable traps aaa_server
    snmp-server enable traps atm subif
    snmp-server enable traps cef resource-failure peer-state-change peer-fib-state-change inconsistency
    snmp-server enable traps memory bufferpeak
    snmp-server enable traps cnpd
    snmp-server enable traps config-copy
    snmp-server enable traps config
    snmp-server enable traps config-ctid
    snmp-server enable traps entity
    snmp-server enable traps fru-ctrl
    snmp-server enable traps resource-policy
    snmp-server enable traps event-manager
    snmp-server enable traps frame-relay multilink bundle-mismatch
    snmp-server enable traps frame-relay
    snmp-server enable traps frame-relay subif
    snmp-server enable traps hsrp
    snmp-server enable traps ipmulticast
    snmp-server enable traps msdp
    snmp-server enable traps mvpn
    snmp-server enable traps nhrp nhs
    snmp-server enable traps nhrp nhc
    snmp-server enable traps nhrp nhp
    snmp-server enable traps nhrp quota-exceeded
    snmp-server enable traps pim neighbor-change rp-mapping-change invalid-pim-message
    snmp-server enable traps pppoe
    snmp-server enable traps cpu threshold
    snmp-server enable traps rsvp
    snmp-server enable traps syslog
    snmp-server enable traps l2tun session
    snmp-server enable traps l2tun pseudowire status
    snmp-server enable traps vtp
     
    snmp-server host 10.118.0.188 heLp23a

    snmp mib persist cbqos

    control-plane

    bridge 1 protocol ieee

    line con 0
    logging synchronous
    line aux 0
    line 67
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    flowcontrol software

    line vty 0 4
    exec-timeout 600 0
    password cisco
    logging synchronous
    login
    transport input all

     
    Obviously firstly they aren't using VLAN1 and the mgf interface is on a BVI. But based on the constructs we have how should I proceed to allow them to effectively POC this in their field?
     
    Cheers,
     
    geoff

    Subject: RE: New Message from Geoff Yates in Service Ready Engine Virtualization - S
    Replied by: Anurag Gurtu on 20-11-2010 01:34:34 AM
    Try the following



    1.       Shutdown the router

    2.       Give IP address to VLAN 1 (this is the MGF Gateway)

    3.       Session into the blade

    4.       Make sure Default Boot is ESXi or type boot esxi



    Thanks,



    Anurag Gurtu, CISSP