Cisco Service Engine can't download files

Version 1
    This document was generated from CDN thread

    Created by: TIM THOMAS on 20-11-2010 01:34:14 AM
    I'm having trouble getting the SRE-V beta installed. I'm running the latest IOS beta:
     

    Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.1(2.18)T ENGINEERING WEEKLY BUILD, synced to V150_1_M3_7
     
    When I run:
    service-module sm 1/0 install url ftp://172.30.111.206/sre-v-k9.smv.1.0.0.35.pkg
     
    It has no problem downloading the first few files, but then once the Cisco Service Engine boots and establishes networking on eth0, it can no longer find the FTP server:
     
    ------------------------------------------------------------------------------------

    ==> Management interface is eth0
    ==> Management interface is eth0
    IOS IP Address Registration complete.
     
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
    10.0.0.0        *               255.255.255.0   U         0 0          0 eth0
    default         10.0.0.100      0.0.0.0         UG        0 0          0 eth0
    INIT: Entering runlevel: 2
    ********** rc.post_install ****************
     
    Changing owners and file permissions.
    Change owners and permissions complete.
    INIT: Switching to runlevel: 4
    INIT: Sending processes the TERM signal
    STARTED: dwnldr_startup.sh
    sre_type=  1
    Welcome to Cisco Systems Service Engine Helper Software
     
    Downloading ftp sre-v-k9.smv.1.0.0.35.pkg
     
     
    Error: Download error  
     Can not download sre-v-k9.smv.1.0.0.35.pkg 
    error code 0 : error type 'couldn't connect to host'
    Unable to install. Please try again
    ------------------------------------------------------------------------------------



     
    I've tried many things, but tried to simplify back down my running config to ease troubleshooting. GigabitEthernet 0/0 is my only external interface that is up, and the FTP server is running on another server in the same subnet. Here's my running config:


    ------------------------------------------------------------------------------------

    Current configuration : 3082 bytes
    !
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot system flash0:c2900-universalk9-mz.SSA.151-2.18.T
    boot-end-marker
    !
    !
    no logging console
    enable secret 5 *******************************
    enable password *******
    !
    no aaa new-model
    !
    no ipv6 cef
    ip source-route


    ip cef    
    !
    !
    !
    !
    !
    multilink bundle-name authenticated
    !
    !
    crypto pki token default removal timeout 0
    !
    !
    license udi pid CISCO2911/K9 sn FTX1438AJTD
    hw-module ism 0
    !
    hw-module sm 1
    !
    !
    !
    !
    !
    !
    !


    interface GigabitEthernet0/0
     ip address 172.30.111.189 255.255.255.0
     duplex auto
     speed auto
    !
    interface ISM0/0
     no ip address
     shutdown
     service-module fail-open
    !
    interface GigabitEthernet0/1
     ip address dhcp
     shutdown
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/2
     no ip address
     shutdown
     duplex auto
     speed auto


    !         
    interface ISM0/1
     description Internal switch interface connected to Internal Service Module
     shutdown
    !
    interface SM1/0
     ip address 10.0.0.100 255.255.255.0
     service-module ip address 10.0.0.1 255.255.255.0
     service-module ip default-gateway 10.0.0.100
     service-module mgf ip address 1.10.10.5 255.255.255.0 vlan 30
     service-module mgf ip default-gateway 1.10.10.3 vlan 30
    !
    interface SM1/1
     description Internal switch interface connected to Service Module
     switchport mode trunk
    !
    interface Vlan1
     no ip address
    !
    interface Vlan30
     ip address 1.10.10.3 255.255.255.0
    !
    interface Async0/1/0


     no ip address
     encapsulation slip
    !

    --- 13 identical ---

    interface Async0/1/15
     no ip address
     encapsulation slip
    !


    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    !
    ip route 10.0.0.1 255.255.255.255 SM1/0


    !         
    !
    !
    !
    control-plane
    !
    !
    !
    line con 0
     password ******
     logging synchronous
     login
    line aux 0
    line 0/1/0 0/1/15
    line 67
     no activation-character
     no exec
     transport preferred none
     transport input all
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line 131
     no activation-character


     no exec  
     transport preferred none
     transport input all
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line vty 0 4
     login
     transport input all
    !
    exception data-corruption buffer truncate
    scheduler allocate 20000 1000
    end
    ------------------------------------------------------------------------------------



    We think we're probably just missing something really simple here, but we're baffled as to what.

    Subject: RE: New Message from TIM THOMAS in Service Ready Engine Virtualization - SR
    Replied by: Anurag Gurtu on 20-11-2010 01:34:14 AM
    I would suggest two things:



    1.       Please change your config to use VLAN 1 and not VLAN 30.

    2.       Make sure you can ping 10.0.0.1 from FTP server since half way during the install 10.0.0.1 would take over and then it will try to connect to FTP server to download remaining files.





    Thanks,



    Anurag Gurtu, CISSP

    Subject: RE: New Message from TIM THOMAS in Service Ready Engine Virtualization - SR
    Replied by: TIM THOMAS on 20-11-2010 01:34:14 AM
    Thanks, that was it. I added a static route on the ftp server and configured it to use vlan 1 instead of 30 and it worked fine. Thought I'd tried that before, but obviously hadn't got quite that configuration together. Thanks for your help.
     
    I would suggest two things:



    1.       Please change your config to use VLAN 1 and not VLAN 30.

    2.       Make sure you can ping 10.0.0.1 from FTP server since half way during the install 10.0.0.1 would take over and then it will try to connect to FTP server to download remaining files.





    Thanks,



    Anurag Gurtu, CISSP