SRE "Internal" nic to run multiple vlans

Version 1
    This document was generated from CDN thread

    Created by: STEVEN BOLTON on 20-11-2010 01:34:06 AM
    We are wanting to run multiple servers connecting to the router vlans at layer2 via the internal interface.  We have accomplished this over the external interface, tut we desire to keep the sre external interface open for future use such
    as iSCSI, ISP connectivity to proxy server instance, etc...  We also plan to install the EHWIC-D-8ESG-P and would like to attach any ports via L2 to any sre server instance as desired.
     
    Have tried creating interface creation and assignment to 21 for vswitch connections on vmnic2, and vmnic1.  Neither have been successful so far.   I am assuming that it should be tied to vmnic1 which I believe is SM1/1.
     
     
     
    Screenshot of vswitch setup is attached.
    Full router config and visio drawing of desired L2 connectivity can be supplied as needed.
     
    Currently, we have the following configured:
     
    The router's Gi0/0 interface is sub-interfaced, and Vlan21 is defined.  We have a Windows server instance up with 10.11.16.91 and want it connection at Layer2 to the network over Gi0/0.21.
     
     
    interface GigabitEthernet0/0
     no ip address
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/0.21
     description PrimaryLAN
     encapsulation dot1Q 21
     ip address 10.11.16.98 255.255.255.0

     
    interface SM1/0
     ip address 192.168.74.50 255.255.255.192
     service-module ip address 192.168.74.51 255.255.255.192
     !Application: SRE-V Running on SMV
     service-module ip default-gateway 192.168.74.50
     service-module mgf ip address 192.168.74.151 255.255.255.192
     service-module mgf ip default-gateway 192.168.74.129
     hold-queue 60 out
    !
    interface SM1/1
     description Internal switch interface connected to Service Module
     switchport mode trunk
     
    interface Vlan1
     ip address 192.168.74.129 255.255.255.192
    !
    interface Vlan21
     ip unnumbered GigabitEthernet0/0.21

     
    ip route 0.0.0.0 0.0.0.0 10.11.16.1
    ip route 10.11.16.97 255.255.255.255 SM1/0
    ip route 192.168.74.51 255.255.255.255 SM1/0



    Subject: RE: New Message from STEVEN BOLTON in Service Ready Engine Virtualization -
    Replied by: Radhika Miriyala on 20-11-2010 01:34:10 AM
    Steven,

    I think it will be easier to understand what you are trying to achieve with the help of a diagram. Can you please provide us this so we can help.



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Monday, October 04, 2010 1:06 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from STEVEN BOLTON in Service Ready Engine Virtualization - SRE-V Beta Testing: SRE "Internal" nic to run multiple vlans



    STEVEN BOLTON has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------
    We are wanting to run multiple servers connecting to the router vlans at layer2 via the internal interface.  We have accomplished this over the external interface, tut we desire to keep the sre external interface open for future use such
    as iSCSI, ISP connectivity to proxy server instance, etc...  We also plan to install the EHWIC-D-8ESG-P and would like to attach any ports via L2 to any sre server instance as desired.

    Full router config and visio drawing of desired L2 connectivity can be supplied as needed.

    Currently, we have the following configured:

    The router's Gi0/0 interface is sub-interfaced, and Vlan21 is defined.  We have a Windows server instance up with 10.11.16.91 and want it connection at Layer2 to the network over Gi0/0.21.


    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/0.21
    description PrimaryLAN
    encapsulation dot1Q 21
    ip address 10.11.16.98 255.255.255.0

    interface SM1/0
    ip address 192.168.74.50 255.255.255.192
    service-module ip address 192.168.74.51 255.255.255.192
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 192.168.74.50
    service-module mgf ip address 192.168.74.151 255.255.255.192
    service-module mgf ip default-gateway 192.168.74.129
    hold-queue 60 out
    !
    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk

    interface Vlan1
    ip address 192.168.74.129 255.255.255.192
    !
    interface Vlan21
    ip unnumbered GigabitEthernet0/0.21

    ip route 0.0.0.0 0.0.0.0 10.11.16.1
    ip route 10.11.16.97 255.255.255.255 SM1/0
    ip route 192.168.74.51 255.255.255.255 SM1/0


    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2606803>
    or simply reply to this email.

    Subject: Background info
    Replied by: STEVEN BOLTON on 20-11-2010 01:34:10 AM
    This is continuation to efforts attempted per post "switchport commands under the SM1/1 unavailable" on 9/15/10.
     
    See post "switchport commands under the SM1/1 unavailable" for background info.

    Subject: SRE "Internal" nic to run multiple vlans
    Replied by: STEVEN BOLTON on 20-11-2010 01:34:10 AM
    See attached diagram for desired locical connectivity.

    Subject: RE: SRE "Internal" nic to run multiple vlans
    Replied by: STEVEN BOLTON on 20-11-2010 01:34:21 AM
    What is the status on getting the desired configuration?
    We are wanting the ESXi Windows 2003 server instance running on the same network at layer 2 via vlan21 as are the local computers that will be connected via G0/0.21 and the EHWIC-D8DSGP whos port are assigned to vlan21.
     
    I can participate in a WebEx on Thursday from 9:00 - 4:00 CDT if needed or desired.

    Subject: RE: SRE "Internal" nic to run multiple vlans
    Replied by: STEVEN BOLTON on 20-11-2010 01:34:36 AM
    How do we get ESXi server instances and interfaces of the PCs connected to the EHWIC-D-8ESG-P communicating at layer2?

    Subject: RE: SRE "Internal" nic to run multiple vlans
    Replied by: STEVEN BOLTON on 20-11-2010 01:34:40 AM
    See the post "ESXi SRE VM instances communicating at layer 2 with EHWIC-D-8ESG-P ports" to view final solution.