Unable to Access Hypervisor

Version 1
    This document was generated from CDN thread

    Created by: SHAWN MCHENRY on 20-11-2010 01:33:58 AM
    I have SRE-V installed but I'm unable to access the Hypervisor remotely.
     
    I'm definitely missing something....
     
    Any assistance is appreciated.
     
    interface GigabitEthernet0/0
     ip address 10.10.16.240 255.255.255.0
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/2
     ip address 192.168.2.1 255.255.255.0
     duplex auto
     speed auto
    !
    interface SM1/0
     ip address 192.168.1.1 255.255.255.0
     service-module ip address 192.168.1.10 255.255.255.0
     !Application: SRE-V Running on SMV
     service-module ip default-gateway 192.168.1.1
     service-module mgf ip address 10.10.192.13 255.255.255.0 vlan 192
     service-module mgf ip default-gateway 10.10.192.1 vlan 192
    !
    interface SM1/1
     description Internal switch interface connected to Service Module
     switchport mode trunk
    !
    interface Vlan1
     no ip address
    !
    interface Vlan192
     ip address 10.10.192.12 255.255.255.0
     
    Test2911# show ip int br
    Interface                  IP-Address      OK? Method Status                Protocol
    GigabitEthernet0/0         10.10.16.240    YES manual up                    up     
    GigabitEthernet0/1         unassigned      YES NVRAM  administratively down down   
    GigabitEthernet0/2         192.168.2.1     YES manual up                    up     
    SM1/0                      192.168.1.1     YES NVRAM  up                    up     
    SM1/1                      unassigned      YES unset  up                    up     
    Vlan1                      unassigned      YES manual up                    up     
    Vlan192                    10.10.192.12    YES manual up                    up
     
    se-192-168-1-10# show hypervisor nic
    Name    PCI           Driver      Link Speed     Duplex MAC Address       MTU
    vmnic0  0000:01:00.00 e1000e      Up   1000Mbps  Full   c8:4c:75:23:b7:26 1500
    vmnic1  0000:02:00.00 bnx2        Up   1000Mbps  Full   d0:d0:fd:00:60:a1 1500
    vmnic2  0000:02:00.01 bnx2        Up   1000Mbps  Full   d0:d0:fd:00:60:a0 1500
    3 total nics
     
    se-192-168-1-10# show hypervisor ip
    Hostname:               localhost
    Domain Name:            None
    IP Config:              10.10.192.13(Subnet Mask: 255.255.255.0)
                            169.254.1.1(Subnet Mask: 255.255.255.0)
    Default Gateway:        None
    Preferred DNS Server:   None
    Alternative DNS Server: None
     
     

    Subject: RE: New Message from SHAWN MCHENRY in Service Ready Engine Virtualization -
    Replied by: Ashwin Venkatesan on 20-11-2010 01:33:58 AM
    Hi Shawn,



    Can you issue the following CLI on the SRE (console manager) and see if it fixes the problem.



    #hypervisor set ip default-gateway 10.10.192.1



    Thanks

    Ashwin

    Subject: RE: New Message from Ashwin Venkatesan in Service Ready Engine Virtualizati
    Replied by: SHAWN MCHENRY on 20-11-2010 01:33:58 AM
    Thanks Ashwin.

    Still no love.

    Subject: RE: New Message from SHAWN MCHENRY in Service Ready Engine Virtualization -
    Replied by: Radhika Miriyala on 20-11-2010 01:33:59 AM
    Shawn,

    Looking at you configuration your Vlan is 192 but we need to use the native vlan for the hypervisor IP address.

    Can you try  after configuring Vlan 1

    Thanks,

    Radhika

    Subject: RE: New Message from Radhika Miriyala in Service Ready Engine Virtualizatio
    Replied by: SHAWN MCHENRY on 20-11-2010 01:33:59 AM
    I¿m still not able to access it.


    Here is the new configuration:

    interface GigabitEthernet0/0
    ip address 10.10.16.240 255.255.255.0
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/2
    ip address 192.168.2.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface SM1/0
    ip address 192.168.1.1 255.255.255.0
    service-module ip address 192.168.1.10 255.255.255.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 192.168.1.1
    service-module mgf ip address 10.10.192.13 255.255.255.0
    service-module mgf ip default-gateway 10.10.192.1
    !
    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk
    !
    interface Vlan1
    ip address 10.10.192.12 255.255.255.0


    se-192-168-1-10# show hypervisor ip
    Hostname:               localhost
    Domain Name:            None
    IP Config:              10.10.192.13(Subnet Mask: 255.255.255.0)
                            169.254.1.1(Subnet Mask: 255.255.255.0)
    Default Gateway:        10.10.192.1
    Preferred DNS Server:   None
    Alternative DNS Server: None

    se-192-168-1-10# show hyper nic
    Name    PCI           Driver      Link Speed     Duplex MAC Address       MTU
    vmnic0  0000:01:00.00 e1000e      Up   1000Mbps  Full   c8:4c:75:23:b7:26 1500
    vmnic1  0000:02:00.00 bnx2        Up   1000Mbps  Full   d0:d0:fd:00:60:a1 1500
    vmnic2  0000:02:00.01 bnx2        Up   1000Mbps  Full   d0:d0:fd:00:60:a0 1500

    3 total nics

    Shawn

    Subject: RE: New Message from SHAWN MCHENRY in Service Ready Engine Virtualization -
    Replied by: Radhika Miriyala on 20-11-2010 01:33:59 AM
    Shawn,

    Did you activate the license on the SRE?  Using the cli 'License activate srevHost'

    Thanks,

    Radhika

    Subject: RE: New Message from Radhika Miriyala in Service Ready Engine Virtualizatio
    Replied by: Rajiv Arora on 20-11-2010 01:33:59 AM
    Could you check your license on SRE using "show license all"
    I would like to make sure " SRE-V-HOST-LIC" License is active.
     
    Thanks
    Rajiv


    I'm still not able to access it.


    Here is the new configuration:

    interface GigabitEthernet0/0
    ip address 10.10.16.240 255.255.255.0
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/2
    ip address 192.168.2.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface SM1/0
    ip address 192.168.1.1 255.255.255.0
    service-module ip address 192.168.1.10 255.255.255.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 192.168.1.1
    service-module mgf ip address 10.10.192.13 255.255.255.0
    service-module mgf ip default-gateway 10.10.192.1
    !
    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk
    !
    interface Vlan1
    ip address 10.10.192.12 255.255.255.0


    se-192-168-1-10# show hypervisor ip
    Hostname:               localhost
    Domain Name:            None
    IP Config:              10.10.192.13(Subnet Mask: 255.255.255.0)
                            169.254.1.1(Subnet Mask: 255.255.255.0)
    Default Gateway:        10.10.192.1
    Preferred DNS Server:   None
    Alternative DNS Server: None

    se-192-168-1-10# show hyper nic
    Name    PCI           Driver      Link Speed     Duplex MAC Address       MTU
    vmnic0  0000:01:00.00 e1000e      Up   1000Mbps  Full   c8:4c:75:23:b7:26 1500
    vmnic1  0000:02:00.00 bnx2        Up   1000Mbps  Full   d0:d0:fd:00:60:a1 1500
    vmnic2  0000:02:00.01 bnx2        Up   1000Mbps  Full   d0:d0:fd:00:60:a0 1500

    3 total nics

    Shawn

    Subject: RE: New Message from Rajiv Arora in Service Ready Engine Virtualization - S
    Replied by: SHAWN MCHENRY on 20-11-2010 01:33:59 AM
    se-192-168-1-10# show license all
    License Store: Evaluation License Storage
    StoreIndex:  0  Feature: SRE-V-HOST-LIC                    Version: 1.0
            License Type: Evaluation
            License State: Active, In Use
                Evaluation total period:  8 weeks  4 days
                Evaluation period left:  8 weeks  3 days
                Expiry date: Fri Feb 29 23:26:06 2008
            License Count: Non-Counted
            License Priority: Low

    Subject: RE: New Message from SHAWN MCHENRY in Service Ready Engine Virtualization -
    Replied by: Radhika Miriyala on 20-11-2010 01:33:59 AM
    Shawn,

    Would it be possible to have short call or webex meeting so we get more information on your network topology.

    Thanks,

    Radhika

    Subject: RE: New Message from Radhika Miriyala in Service Ready Engine Virtualizatio
    Replied by: SHAWN MCHENRY on 20-11-2010 01:33:59 AM
    Sure.  210.253.5304

    Subject: RE: New Message from SHAWN MCHENRY in Service Ready Engine Virtualization -
    Replied by: Radhika Miriyala on 20-11-2010 01:33:59 AM
    Shawn,

    Thanks for taking the time to talk to us. Please try out the configuration we discussed and let us know how it goes.

    Thanks,

    Radhika

    Subject: RE: New Message from Radhika Miriyala in Service Ready Engine Virtualizatio
    Replied by: SHAWN MCHENRY on 20-11-2010 01:34:00 AM
    Radhika,

    I changed the IP addresses on the SM1/0 and VLAN1 interfaces and placed static routes in our L3 switch.

    All is good.

    interface SM1/0
    ip address 192.168.1.1 255.255.255.0
    service-module ip address 192.168.1.10 255.255.255.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 192.168.1.1
    service-module mgf ip address 10.89.176.2 255.255.255.248
    service-module mgf ip default-gateway 10.89.176.1
    !
    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk
    !
    interface Vlan1
    ip address 10.89.176.1 255.255.255.248

    Subject: RE: New Message from SHAWN MCHENRY in Service Ready Engine Virtualization -
    Replied by: Radhika Miriyala on 20-11-2010 01:34:00 AM
    Shawn,

    Good to know that config change helped. Please let us know how the rest of you testing goes.

    Thanks,

    Radhika