can't connect to hypervisor

Version 1
    This document was generated from CDN thread

    Created by: Kin Cho on 20-11-2010 01:33:57 AM
    Hi,

    After successfully installing SRE-V, I'm not having success connecting
    to hypervisor console.  Following advice of posts in this forum, I
    have the configuration below.  Other than 10.10.10.1, all other IP's
    are routeable within our network in which my desktop is a part of.

    The problem with this configuration is that I'm not able to get ping
    response from ge0/0, sm1/0 (10.35.1.161), or mgf (10.32.2.242).

    However, if I remove Vlan1's IP from this configuration, ge0/0 and
    sm1/0 responds to ping.

    This blade was running fine under AXP with a similar configuration
    (minus vlan1 and mgf, and sm1/0's ip address).

    -kin

    interface GigabitEthernet0/0
     description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
     ip address 10.35.20.1 255.255.0.0
     duplex auto
     speed auto
    !
    interface SM1/0
     ip address 10.10.10.1 255.255.0.0
     service-module ip address 10.35.1.161 255.255.0.0
     !Application: SRE-V Running on SMV
     service-module ip default-gateway 10.35.20.206
     service-module mgf ip address 10.32.2.242 255.255.0.0
     service-module mgf ip default-gateway 10.32.2.50
     no keepalive
     hold-queue 60 out
    !
    interface SM1/1
     description Internal switch interface connected to Service Module
     switchport mode trunk
     no keepalive
     hold-queue 60 out
    !
    interface Vlan1
     ip address 10.32.2.50 255.255.0.0
    !
    ip route 0.0.0.0 0.0.0.0 10.35.0.1
    ip route 10.35.1.161 255.255.255.255 SM1/0

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Radhika Miriyala on 20-11-2010 01:33:57 AM
    Kin,

    By Hypervisor console do you mean the Vsphere client or the CLI  (Console manager) on The SRE module.



    If you are having issues connecting to Vsphere client what IP address are you using? You need to us the mgf ip address in this case that would be 10.32.2.242. are you able to ping this address from your desktop?



    Also why are you using the 10.10.10.1 IP address as the sm 1/0 IP address?

    If you are able to session into the SM than can you provide the output of

    1)show hypervisor nics

    2) show hypervisor ip



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Monday, September 20, 2010 10:49 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V Beta Testing: can't connect to hypervisor



    Kin Cho has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------
    Hi,

    After successfully installing SRE-V, I'm not having success connecting
    to hypervisor console.  Following advice of posts in this forum, I
    have the configuration below.  Other than 10.10.10.1, all other IP's
    are routeable within our network in which my desktop is a part of.

    The problem with this configuration is that I'm not able to get ping
    response from ge0/0, sm1/0 (10.35.1.161), or mgf (10.32.2.242).

    However, if I remove Vlan1's IP from this configuration, ge0/0 and
    sm1/0 responds to ping.

    This blade was running fine under AXP with a similar configuration
    (minus vlan1 and mgf, and sm1/0's ip address).

    -kin

    interface GigabitEthernet0/0
    description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
    ip address 10.35.20.1 255.255.0.0
    duplex auto
    speed auto
    !
    interface SM1/0
    ip address 10.10.10.1 255.255.0.0
    service-module ip address 10.35.1.161 255.255.0.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.35.20.206
    service-module mgf ip address 10.32.2.242 255.255.0.0
    service-module mgf ip default-gateway 10.32.2.50
    no keepalive
    hold-queue 60 out
    !
    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk
    no keepalive
    hold-queue 60 out
    !
    interface Vlan1
    ip address 10.32.2.50 255.255.0.0
    !
    ip route 0.0.0.0 0.0.0.0 10.35.0.1
    ip route 10.35.1.161 255.255.255.255 SM1/0
    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2558479>
    or simply reply to this email.

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Kin Cho on 20-11-2010 01:33:57 AM
    Kin,

    By Hypervisor console do you mean the Vsphere client or the CLI  (Console manager) on The SRE module.

    Vsphere client

    If you are having issues connecting to Vsphere client what IP address are you using? You need to us the mgf ip address in this case that would be 10.32.2.242. are you able to ping this address from your desktop?

    No, I can't ping 10.32.2.242, or even ge0/0 (unless I remove vlan1's IP).

    Also why are you using the 10.10.10.1 IP address as the sm 1/0 IP address?
     
    That's just a fake IP.  What is the sm1/0 IP used for?  In AXP, the "service-module ip" is used.

    If you are able to session into the SM than can you provide the output of

    1)show hypervisor nics

    2) show hypervisor ip

    se-10-35-1-161# show hypervisor nics all
    Name    PCI           Driver      Link Speed     Duplex MAC Address       MTU
    vmnic1  0000:01:00.00 e1000e      Up   1000Mbps  Full   00:23:eb:85:66:c9 1500
    vmnic2  0000:02:00.00 bnx2        Up   1000Mbps  Full   00:23:eb:85:66:cb 1500
    vmnic3  0000:02:00.01 bnx2        Up   1000Mbps  Full   00:23:eb:85:66:ca 1500

    3 total nics

    se-10-35-1-161# show hypervisor ip
    Hostname:               HOst1
    Domain Name:            None
    IP Config:              10.32.1.231(Subnet Mask: 255.255.0.0)
                            169.254.1.1(Subnet Mask: 255.255.255.0)
    Default Gateway:        10.32.2.50
    Preferred DNS Server:   None
    Alternative DNS Server: None

    se-10-35-1-161#


    Thanks,

    Radhika

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Radhika Miriyala on 20-11-2010 01:33:57 AM
    Kin,

    Did you change the IP address of the mgf after you installed/booted the SRE?  The reason I ask is because the show hypervisor IP show different Ip then what you have in the IOS.



    If you have changed the Ip address then you need to reboot the SRE (known issue) for the new IP address to take effect. Please reload the SRE using the reload



    Not sure why you are not able to ping the ge0/0.  The service-module Ip address is used by the console manager of the cli¿s of the SRE. If you want the IP address of the Service-module to be in the same subnet as the ge0/0 so than you can use ip unnumbered. Here is how the config would look.

    interface SM1/0
    ip unnumbered ge0/0
    service-module ip address 10.35.1.161 255.255.0.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.35.20.206
    service-module mgf ip address 10.32.2.242 255.255.0.0
    service-module mgf ip default-gateway 10.32.2.50
    no keepalive
    hold-queue 60 out





    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Monday, September 20, 2010 11:07 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V Beta Testing: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V



    Kin Cho has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------
    Kin,

    By Hypervisor console do you mean the Vsphere client or the CLI (Console manager) on The SRE module.

    Vsphere client

    If you are having issues connecting to Vsphere client what IP address are you using? You need to us the mgf ip address in this case that would be 10.32.2.242. are you able to ping this address from your desktop?

    No, I can't ping 10.32.2.242, or even ge0/0 (unless I remove vlan1's IP).

    Also why are you using the 10.10.10.1 IP address as the sm 1/0 IP address?

    That's just a fake IP.  What is the sm1/0 IP used for?  In AXP, the "service-module ip" is used.

    If you are able to session into the SM than can you provide the output of

    1)show hypervisor nics

    2) show hypervisor ip

    se-10-35-1-161# show hypervisor nics all
    Name    PCI           Driver      Link Speed     Duplex MAC Address       MTU
    vmnic1  0000:01:00.00 e1000e      Up   1000Mbps  Full   00:23:eb:85:66:c9 1500
    vmnic2  0000:02:00.00 bnx2        Up   1000Mbps  Full   00:23:eb:85:66:cb 1500
    vmnic3  0000:02:00.01 bnx2        Up   1000Mbps  Full   00:23:eb:85:66:ca 1500

    3 total nics

    se-10-35-1-161# show hypervisor ip
    Hostname:               HOst1
    Domain Name:            None
    IP Config:              10.32.1.231(Subnet Mask: 255.255.0.0)
                            169.254.1.1(Subnet Mask: 255.255.255.0)
    Default Gateway:        10.32.2.50
    Preferred DNS Server:   None
    Alternative DNS Server: None

    se-10-35-1-161#


    Thanks,

    Radhika
    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2558490>
    or simply reply to this email.

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Kin Cho on 20-11-2010 01:33:58 AM
    Did you change the IP address of the mgf after you installed/booted the SRE?  The reason I ask is because the show hypervisor IP show different Ip then what you have in the IOS.

    If you have changed the Ip address then you need to reboot the SRE (known issue) for the new IP address to take effect. Please reload the SRE using the reload

    Yes I probably did, reloaded now.

    Not sure why you are not able to ping the ge0/0.  The service-module Ip address is used by the console manager of the cli¿s of the SRE. If you want the IP address of the Service-module to be in the same subnet as the ge0/0 so than you can use ip unnumbered. Here is how the config would look.

    interface SM1/0
    ip unnumbered ge0/0
    service-module ip address 10.35.1.161 255.255.0.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.35.20.206
    service-module mgf ip address 10.32.2.242 255.255.0.0
    service-module mgf ip default-gateway 10.32.2.50
    no keepalive
    hold-queue 60 out

    I now have this:



     ip unnumbered GigabitEthernet0/0



    instead of:


    ip address 10.10.10.1 255.255.0.0


    but my situation remains the same.

     

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Radhika Miriyala on 20-11-2010 01:33:58 AM
    Kin,

    Did the reload of the SRE help resolve the networking issues? If not can you the output of ¿Show interface brief¿ from the IOS.



    Also I think we need to figure out why gige 0/0 is not pingable from your desktop. What network is your desktop in is it 10.35.x.x or 10.32.x.x?

    Do you think you can give us access to you setup so we can take a look or we can try to do a webex  meeting if that is easier for you.



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Monday, September 20, 2010 11:50 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V Beta Testing: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V



    Kin Cho has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------
    Did you change the IP address of the mgf after you installed/booted the SRE? The reason I ask is because the show hypervisor IP show different Ip then what you have in the IOS.

    If you have changed the Ip address then you need to reboot the SRE (known issue) for the new IP address to take effect. Please reload the SRE using the reload

    Yes I probably did, reloaded now.

    Not sure why you are not able to ping the ge0/0. The service-module Ip address is used by the console manager of the cli¿s of the SRE. If you want the IP address of the Service-module to be in the same subnet as the ge0/0 so than you can use ip unnumbered. Here is how the config would look.

    interface SM1/0
    ip unnumbered ge0/0
    service-module ip address 10.35.1.161 255.255.0.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.35.20.206
    service-module mgf ip address 10.32.2.242 255.255.0.0
    service-module mgf ip default-gateway 10.32.2.50
    no keepalive
    hold-queue 60 out

    I now have this:


    ip unnumbered GigabitEthernet0/0



    instead of:


    ip address 10.10.10.1 255.255.0.0


    but my situation remains the same.


    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2558541>
    or simply reply to this email.

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Kin Cho on 20-11-2010 01:33:58 AM
    Kin,

    Did the reload of the SRE help resolve the networking issues? If not can you the output of ¿Show interface brief¿ from the IOS.

    No, it didn't seem to, show interface brief doesn't work for me, here's the output of show interface:

     
    https://docs.google.com/document/pub?id=1bPQ8Ky7P9gr0RyWOuigVnHHsjte2_TSpT_eE70rFoYw
     
    Also I think we need to figure out why gige 0/0 is not pingable from your desktop. What network is your desktop in is it 10.35.x.x or 10.32.x.x?
     
    My desktop is at 10.32, but 10.35 is reachable from my desktop.
     
    Do you think you can give us access to you setup so we can take a look or we can try to do a webex  meeting if that is easier for you.

    Sure.  I'll check with our IT to see what type of inbound connections are allowed.  What kind of access is possible with webex?

    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Monday, September 20, 2010 11:50 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V Beta Testing: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V



    Kin Cho has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------
    Did you change the IP address of the mgf after you installed/booted the SRE? The reason I ask is because the show hypervisor IP show different Ip then what you have in the IOS.

    If you have changed the Ip address then you need to reboot the SRE (known issue) for the new IP address to take effect. Please reload the SRE using the reload

    Yes I probably did, reloaded now.

    Not sure why you are not able to ping the ge0/0. The service-module Ip address is used by the console manager of the cli¿s of the SRE. If you want the IP address of the Service-module to be in the same subnet as the ge0/0 so than you can use ip unnumbered. Here is how the config would look.

    interface SM1/0
    ip unnumbered ge0/0
    service-module ip address 10.35.1.161 255.255.0.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.35.20.206
    service-module mgf ip address 10.32.2.242 255.255.0.0
    service-module mgf ip default-gateway 10.32.2.50
    no keepalive
    hold-queue 60 out

    I now have this:


    ip unnumbered GigabitEthernet0/0



    instead of:


    ip address 10.10.10.1 255.255.0.0


    but my situation remains the same.


    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2558541>
    or simply reply to this email.


    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Kin Cho on 20-11-2010 01:33:59 AM
    Hi Radhika, this is my output:
     
    eng-lab-417#show ip interface brief
    Interface                  IP-Address      OK? Method Status                Protocol
    GigabitEthernet0/0         10.35.20.1      YES manual up                    up     
    GigabitEthernet0/1         10.36.1.161     YES NVRAM  up                    up     
    GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down   
    SM1/0                      10.35.20.1      YES TFTP   up                    up     
    SM1/1                      unassigned      YES unset  up                    up     
    Vlan1                      10.32.2.50      YES manual up                    up     
    eng-lab-417#

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Radhika Miriyala on 20-11-2010 01:33:59 AM
    Thanks kin.  I have been looking at your configs again  and it looks like your Ge0/0 (10.35.x.x/24) and Ge0/1 (10.36.x.x/24) are  different subnets then your desktop which is 10.32.x.x/24 network.

    You are trying to configure the interface Vlan 1 with the 10.32.x.x address. Once you do this VLAn1 is associated with the router MGF switch and the router routes any 10.32.x.x traffic to the internal MGF switch.



    So that is the reason once you configure the Vlan 1 in 10.32 address even the connection to router Ge0/0 is lost from the 10.32.x.x network.



    Do you need the router Ip address to be in 10.32.x.x network or could it be in the 10.36.x.x network? If it is ok to have it in this network you could  do something like configuration below.



    Interface vlan 1

    Ip unnumbered ge0/1



    interface SM1/0
    ip unnumbered ge0/0
    service-module ip address 10.35.1.161 255.255.0.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.35.20.206
    service-module mgf ip address 10.36.1.242 255.255.0.0
    service-module mgf ip default-gateway 10.36.1.1
    no keepalive
    hold-queue 60 out



    Once you change the IP address can you please reload the SM and then check you can connect to ge0/0 and ge0/1 and then try connecting to the hypervisor using Vsphere.



    Let me know if this does not work for you.



    Thanks,

    Radhika









    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, September 21, 2010 11:47 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V Beta Testing: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V



    Kin Cho has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------
    Hi Radhika, this is my output:

    eng-lab-417#show ip interface brief
    Interface                  IP-Address      OK? Method Status                Protocol
    GigabitEthernet0/0         10.35.20.1      YES manual up                    up     
    GigabitEthernet0/1         10.36.1.161     YES NVRAM  up                    up     
    GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down   
    SM1/0                      10.35.20.1      YES TFTP   up                    up     
    SM1/1                      unassigned      YES unset  up                    up     
    Vlan1                      10.32.2.50      YES manual up                    up     
    eng-lab-417#
    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2559838>
    or simply reply to this email.

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Kin Cho on 20-11-2010 01:33:59 AM
    Hi Radhika, please see my new configs (I reloaded the SM):

    https://docs.google.com/document/pub?id=1L6_2B7cStycRZUEWOvyf69kLlIWdqRI06cYTN8dMA8w

    I'm now able to ping ge0/0, ge0/1, and SRE (10.35.1.161), but not mgf (10.36.1.242).

    Note that I corrected mgf's gateway to be 10.36.0.1, which I can ping it as well.

    What else is missing to ping mgf?
     
    -kin
     

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Radhika Miriyala on 20-11-2010 01:34:00 AM
    Kin,

    You need to add a ip route to the MGF ipaddress to point to vlan 1

    The cli would be

    ¿ip route 10.36.1.242 255.255.255.255 vlan 1¿



    After you do this still ping to the MGF does not work can you provide the output of the following cli¿s from the SRE console manager:



    1)       ¿show hypervisor ip¿

    2)       ¿show hypervisor nics¿

    3)      Show hypervisor

    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Wednesday, September 22, 2010 3:00 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V Beta Testing: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V



    Kin Cho has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------
    Hi Radhika, please see my new configs (I reloaded the SM):

    https://docs.google.com/document/pub?id=1L6_2B7cStycRZUEWOvyf69kLlIWdqRI06cYTN8dMA8w

    I'm now able to ping ge0/0, ge0/1, and SRE (10.35.1.161), but not mgf (10.36.1.242).

    Note that I corrected mgf's gateway to be 10.36.0.1, which I can ping it as well.

    What else is missing to ping mgf?

    -kin

    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2562746>
    or simply reply to this email.

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Kin Cho on 20-11-2010 01:34:00 AM
    Hi Radhika, with the vlan 1 route, I'm now able to download new vsphere client and connect to the hypervisor.
     
    Thanks a lot for your help!
     
    -kin
     

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Kin Cho on 20-11-2010 01:34:03 AM
    Hi,

    I have deployed a VM on my hypervisor, but I'm not able to reach my VM's IP
    (10.36.99.99/16).

    From a shell within my VM, I can ping the hypervisor's management IP
    (10.36.1.242), but not the hypervisor's default gateway (10.36.0.1).

    What additional configuration is needed to allow me to reach my VM?

    Please see my configs and relevant info here:


    http://tinyurl.com/2awajvp


    Thanks,

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Radhika Miriyala on 20-11-2010 01:34:03 AM
    Kin,

    I was unable to open your document for some reason.



    So a few questions

    1)Is the VM also in the Vlan 1 you created?

    2) if the VM is in VLAn 1 then can you try  adding  a route on the router for the ip address of the VM to point to Vlan 1



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Wednesday, September 29, 2010 11:11 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V Beta Testing: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V



    Kin Cho has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------
    Hi,

    I have deployed a VM on my hypervisor, but I'm not able to reach my VM's IP
    (10.36.99.99/16).

    From a shell within my VM, I can ping the hypervisor's management IP
    (10.36.1.242), but not the hypervisor's default gateway (10.36.0.1).

    What additional configuration is needed to allow me to reach my VM?

    Please see my configs and relevant info here:

    https://docs.google.com/document/pub?id=1el6-RVCjVlpvTemoticonYkmSJP87KtQaQ0ShLN7hAOtkY3Y0

    Thanks,
    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2590652>
    or simply reply to this email.

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Kin Cho on 20-11-2010 01:34:03 AM
    Hi Radhika, adding a vlan1 route solved the problem.
     
    Thanks!