can't get service module console with # prompt

Version 1
    This document was generated from CDN thread

    Created by: Josip Zimet on 20-11-2010 01:34:04 AM
    Dear sre-v alias members,
     
    can you please tell me if you have any idea whyy I can't get # prompt when I session into the Service Module and hence I can't install license.
     
    EnergyWiseRouter#service-module sm 1/0 session
    Trying 10.62.63.68, 2067 ... Open
    ServicesEngine boot-loader>  
     
    EnergyWiseRouter#service-module sm 1/0 status 
    Service Module is Cisco SM1/0
    Service Module supports session via TTY line 67
    Service Module is waiting for registration message
    Service Module heartbeat-reset is enabled
    Service Module is in fail open
    Service Module status is not available
    No install/uninstall in progress

    Local Partition Info
    =====================
      Please reset module to retrieve
      partition information if needed

    EnergyWiseRouter#
     
    If i type/run boot esxi in boot-loader prompt it succesfully boots esxi ...
     
    ServicesEngine boot-loader> boot esxi                                         
    ESXi boot on eUSB flash at hd2
      terminal --timeout=0 serial console
      map (hd0) (hd2)
      map (hd2) (hd0)
      rootnoverify (hd2)
      chainloader +1
      boot
     
           ESXi 4.0 http://www.vmware.com
           Copyright (c) 2007-2009 VMware, Inc.

    VMware ESXi 4.0.0 Releasebuild-164009
    INSYDE SanClemente
    4 GB Memory
    Download tools to manage this host from:
    http://192.168.11.65/ (STATIC)
     
    Thanks,
    Kind regards, Josip Zimet

    Subject: RE: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Anurag Gurtu on 20-11-2010 01:34:04 AM
    It seems you are running a pre-alpha image. Please upgrade to Beta image. It¿s posted on CDN.



    Thanks,



    Anurag Gurtu, CISSP

    Subject: Re: New Message from Anurag Gurtu in Service Ready Engine Virtualization -
    Replied by: Josip Zimet on 20-11-2010 01:34:04 AM
    Thx Anurag ... Did try several times and ftp always fails ... Can you please
    verify if from service-module sm 1/0 status you can figure out why ftp fails
    ?

    Subject: RE: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Anurag Gurtu on 20-11-2010 01:34:04 AM
    When you get into boot prompt  *** type config and enter correct IP address for service module. Then make sure you can ping FTP server from the blade by invoking ping commad, if it works, network connectivity is good, if not there is a issue with routing or a firewall is blocking port 20/21.



    Thanks,



    Anurag Gurtu, CISSP

    Subject: Re: New Message from Anurag Gurtu in Service Ready Engine Virtualization -
    Replied by: Josip Zimet on 20-11-2010 01:34:04 AM
    Anurag,

    Would you recommend to use ethernet port on service module or ethernet port
    on router ?

    ServicesEngine boot-loader> config
    IP Address [10.62.63.69] >
    Subnet mask [255.255.255.128] >
    TFTP server [10.62.63.64] >
    Gateway [10.62.63.1] >
    NFS root directory [] >
    Default Helper-file [helper.sm] >
    Ethernet interface[external|internal]  >
    Debug Messages [enable|disable]  >
    Default Boot [none|disk|diag|chainloader]  >
    Default bootloader [primary|secondary]  >
    ServicesEngine boot-loader>

    I can ping ftp server from router

    EnergyWiseRouter#ping 10.62.63.64
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.62.63.64, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
    EnergyWiseRouter#

    Unfortunatelly I can¹t ping from boot prompt to ftp server

    Config :

    interface GigabitEthernet0/0
    ip address 10.62.63.68 255.255.255.128

    interface SM1/0
    ip unnumbered GigabitEthernet0/0
    service-module fail-open
    service-module ip address 10.62.63.62 255.255.255.128
    service-module ip default-gateway 10.62.63.1
    service-module mgf ip address 192.168.1.1 255.255.255.0
    service-module mgf ip default-gateway 192.168.1.3

    interface SM1/1
    switchport mode trunk

    interface Vlan1
    ip address 192.168.1.3 255.255.255.0

    ip route 0.0.0.0 0.0.0.0 10.62.63.1
    ip route 192.168.1.1 255.255.255.255 Vlan1

    Subject: Re: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Josip Zimet on 20-11-2010 01:34:04 AM
    Anurag,

    For testing purposes I¿m now connected ftp (10.62.63.64) server directly to
    ethernet port on sre (10.62.63.69) ...  Ping doesn¿t go through and I assume
    this is because I used Ethernet Internal option ... Will change it to
    Ethernet External.

    Josip Zimet

    Subject: Re: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Josip Zimet on 20-11-2010 01:34:04 AM
    Hi Anurag,

    Now it works ...

    ServicesEngine boot-loader> ping 10.62.63.64

    Sending 5, 32 byte ICMP Echos to 10.62.63.64:
    !!!!!
    Success rate is 100% (5/5)

    ServicesEngine boot-loader>

    Subject: Re: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Josip Zimet on 20-11-2010 01:34:04 AM
    Anurag,

    Can you please tell me if there is command on SRE within boot-loader to run
    installation from ftp server via ethernet on SRE ...

    Ping works ...
    EnergyWiseRouter#ping 10.62.63.64
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.62.63.64, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

    Running installation of beta software from router
    EnergyWiseRouter#$sre/sre-v.beta.install-1.1.0.0.35/sre-v-k9.smv.1.0.0.35.pk
    g
    Proceed with installation? : yes

    And this is output within SRE prompt ..

    ServicesEngine boot-loader>
    *Oct  1 16:17:05.215: %SM_INSTALL-6-INST_RSRC_GET: Getting resource
    information from SM1/0.
    Initializing memory. Please wait...
    Initializing memory. Please wait...
    *Oct  1 16:17:10.023: %DTP-5-NONTRUNKPORTON: Port SM1/1 has become non-trunk
    *Oct  1 16:17:10.455: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1,
    changed state to down
    *Oct  1 16:17:11.047: %DTP-5-TRUNKPORTON: Port SM1/1 has become dot1q
    trunkPress DEL key to skip memory test63% of the system memory tested OK64%
    of the system memory tested OK65% of the system memory tested OK66% of the
    system memory tested OK67% of the system memory tested OK68% of the system
    memory tested OK69% of the system memory tested OK70% of the system memory
    tested OK71% of the system memory tested OK72% of the system memory tested
    OK73% of the system memory tested OK74% of the system memory tested OK75% of
    the system memory tested OK76% of the system memory tested OK77% of the
    system memory tested OK78% of the system memory tested OK79% of the system
    memory tested OK80% of the system memory tested OK81% of the system memory
    tested OK82% of the system memory tested OK83% of the system memory tested
    OK84% of the system memory tested OK85% of the system memory tested OK86% of
    the system memory tested OK87% of the system memory tested OK88% of the
    system memory tested OK89% of the system memory tested OK90% of the system
    memory tested OK91% of the system memory tested OK92% of the system memory
    tested OK93% of the system memory tested OK94% of the system memory tested
    OK95% of the system memory tested OK96% of the system memory tested OK97% of
    the system memory tested OK98% of the system memory tested OK99% of the
    system memory tested OK100% of the system memory tested OK4,290,379,776
    bytes of system memory tested OK
    Channel 0 Master : Hitachi HTE545050B9A300
    DDR Memory 4096 MB detected
    Intel(R) Genuine processor
    BIOS SM 1.2,  BIOS Build date: 08/04/2009
    System now booting...
    Please wait... 
    Please keyin P to select Primary Boot Loader ...
              or S to select Secondary Boot Loader ...
    If no any key stroke then will pick primary boot loader....
    ............................................................................
    ...........................
    Now booting from secondary boot loader....
    BIOS check for upgrade(CSCsx48564)  49 0
    Please enter '***' to change boot configuration:
    *Oct  1 16:17:41.547: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1,
    changed state to up
    ServicesEngine Bootloader Version : eng_bld-eng
    ServicesEngine boot-loader>
    *Oct  1 16:19:05.323: %SM_INSTALL-3-INST_NORESP: SM1/0 SW installation
    failed module not responding

    Kind regards,
    JosiP Zimet

    Subject: RE: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Ashwin Venkatesan on 20-11-2010 01:34:04 AM
    Hi Josip,

    Have you tried the install from IOS (service-module sm x/y install url¿.) ? Just curious why you want to go with the boot helper method of install?

    If you want to do the install using the boot helper mode the following steps have to be done.


    1)      Make sure the files sre-v-k9.smv.1.0.0.x.key and sre-v-installer.smv.1.0.0.x   is in your TFTP Server. Issue a ping from BL mode to make sure you have connectivity with your tftp server.

    2)      In Bootloader mode issue the CLi  ¿install_key sre-v-k9.smv.1.0.0.x.key¿

    3)      Once this is complete, next issue the CLI ¿boot helper¿ in BL mode.

    4)      Once you issue boot helper you will get several options, the first one would be for installing the image.

    5)       Here you can specify the ftpserver ip address, user and password (if any) and the package name (sre-v-k9.smv.1.0.0.x.pkg) and this will start the installation for you.

    Thanks,

    Ashwin

    Subject: Re: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Anurag Gurtu on 20-11-2010 01:34:04 AM
    You are missing a route to the console manager. I would suggest you use internal interface.

    Thanks

    Subject: Re: New Message from Anurag Gurtu in Service Ready Engine Virtualization -
    Replied by: Josip Zimet on 20-11-2010 01:34:05 AM
    Hi Anurag,

    Can you please tell me if route to console manager would be global config :

    ip route 192.168.1.1 255.255.255.255 Vlan1

    And if console manager is actually mgf ip address :

    service-module mgf ip address 192.168.1.1 255.255.255.0

    And default gateway for console manager would be actually interface vlan 1 :

    interface Vlan1
    ip address 192.168.1.3 255.255.255.0
    ...
    service-module mgf ip default-gateway 192.168.1.3


    If yes than I have all set (except explicit route on my pc/if required)

    Subject: Re: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Anurag Gurtu on 20-11-2010 01:34:05 AM
    You need a direct route to 10.62.63.62, and ip route is a global configuration command. Our document should have this command documented.

    Thanks

    Anurag Gurtu

    Subject: Re: New Message from Ashwin Venkatesan in Service Ready Engine Virtualizati
    Replied by: Josip Zimet on 20-11-2010 01:34:05 AM
    Ashwin,

    1. ping worked
    2. ¿install_key sre-v-k9.smv.1.0.0.x.key¿ went through fine
    3. ¿boot helper¿ required adjustment and I adjusted to ¿boot helper
    sre-v-k9.smv.1.0.0.35.pkg¿ and it went through.

    This is result :

    Image signature verified successfully
    done.
    Starting Kernel.

    CISCO_BL: boot_image: 0x1200000
    : image/plat/sz: 2/8/252384
    Aesop Helper: system image header: v=1932409195, b=825128557, i=808333358
    Network boot: kernel big flag is not set! (196)
    : PANIC, halting.

    Hope this means success ?

    Kind regards,
    JosiP Zimet

    Subject: Re: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Josip Zimet on 20-11-2010 01:34:05 AM
    Hi Ashwin,

    Verified once again ... ¿default helper-file¿ points to ¿helper.sm¿ and
    ¿boot helper¿ is looking for ¿helper.sm¿ file on specified tftp server and
    since it¿s not there reports TFTP error 2 (access Violation) which means no
    file found ...

    ServicesEngine boot-loader> boot helper
    nw_boot: 0 helper.sm
    Loading tftp://192.168.1.2/helper.sm ... TFTP error 2 (Access violation)

    ServicesEngine boot-loader> config

    IP Address [192.168.1.1] >

    Subnet mask [255.255.255.0] >

    TFTP server [192.168.1.2] >

    Gateway [192.168.1.3] >

    NFS root directory [] >

    Default Helper-file [helper.sm] >

    Ethernet interface[external|internal]  >

    Debug Messages [enable|disable]  >

    Default Boot [none|disk|diag|chainloader]  >

    Default bootloader [primary|secondary]  >

    Kind regards,
    Josip Zimet

    Subject: Re: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Josip Zimet on 20-11-2010 01:34:05 AM
    Finally managed to have connectivity between ftp and G2 and sre-v  ...
    initiated ¿service-module install ...¿  which restarted sre-v, returned no
    errors on G2 console and Session into the sre-v stil returns ¿ServicesEngine
    boot-loader>¿ prompt ... Instead of # ...  Please advice ... Can you please
    verify with your ftp server (it should reach my G2 on 10.62.63.68 cisco
    cisco)

    ftp server 10.55.24.21

    Router gig eth 0/0  10.62.63.68 255.255.255.128

    interface SM1/0
    ip unnumbered GigabitEthernet0/0
    service-module fail-open
    service-module ip address 10.62.63.63 255.255.255.128
    service-module ip default-gateway 10.62.63.68
    service-module mgf ip address 20.0.0.1 255.255.255.0
    service-module mgf ip default-gateway 20.0.0.10
    !        
    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk
    !        
    interface Vlan1
    ip address 20.0.0.10 255.255.255.0

    ip route 0.0.0.0 0.0.0.0 10.62.63.1
    ip route 10.62.63.63 255.255.255.255 SM1/0
    ip route 20.0.0.1 255.255.255.255 SM1/0
    ip route 20.0.0.10 255.255.255.255 Vlan1

    Started install
    EnergyWiseRouter#$@10.55.24.21/Users/jz/Desktop/sre/sre-v.beta.install-1.1.0
    .0.35/sre-v-k9.smv.1.0.0.35.pkg
    Proceed with installation? : y

    ServicesEngine boot-loader>
    Initializing memory. Please wait...
    Press DEL key to skip memory test63% of the system memory tested OK
    Channel 0 Master : Hitachi HTE545050B9A300
    DDR Memory 4096 MB detected
    Intel(R) Genuine processor
    BIOS SM 1.2,  BIOS Build date: 08/04/2009
    System now booting...
    Please wait... 
    Please keyin P to select Primary Boot Loader ...
              or S to select Secondary Boot Loader ...
    If no any key stroke then will pick primary boot loader....
    ............................................................................
    ...........................
    Now booting from secondary boot loader....
    BIOS check for upgrade(CSCsx48564)  49 0
    Please enter '***' to change boot configuration:
    ServicesEngine Bootloader Version : eng_bld-eng
    ServicesEngine boot-loader>


    EnergyWiseRouter#

    Subject: RE: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Ashwin Venkatesan on 20-11-2010 01:34:05 AM
    Hello Josip,

    Can you try the install again?. Once you hit enter after issuing the service-module sm x/y install .. CLI, please session into the blade immediately  so the  complete installation logs  can be captured.

    Also was this blade working before? What was the software running on this prior to installing the SRE-V software?

    Thanks,

    Ashwin.

    Subject: Re: New Message from Ashwin Venkatesan in Service Ready Engine Virtualizati
    Replied by: Josip Zimet on 20-11-2010 01:34:05 AM
    HI Ashwin

    Will do as suggested ... I¿m doing combination of console access (monitor
    ServicesEngine boot-loader>) and telnet (start installation) ... Esxi on sre
    is working today ... When I enter boot esxi within ServicesEngine
    boot-loader> I have functional esxi on 192.168.x.x address (I don¿t know why
    esxi chose 192.168.x.x range) unfortunately only through external sre
    ethernet interface ... Can you please tell me what is the purpose of Default
    Helper-file [helper.sm] > and how to edit Default Helper-file [helper.sm] ?

    Kind regards,
    Josip Zimet

    Subject: Re: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Josip Zimet on 20-11-2010 01:34:05 AM
    Hi Ashwin,

    Tested within lab itself in order to avoid firewall/access lists which
    denies ftp ports ... Ftp server 10.62.63.64 directly connected to router
    10.62.63.68 with router side of the interface 10.62.63.68 (unnumbered),
    module side of the interface 10.62.63.63 and module side of the interface
    that vmware vsphere hypervisor uses 20.0.0.1

    On Router

    EnergyWiseRouter#$.beta.install-1.1.0.0.35/sre-v-k9.smv.1.0.0.35.pkg
    Proceed with installation? : y
    EnergyWiseRouter#service-module sm 1/0 status
    Service Module is Cisco SM1/0
    Service Module supports session via TTY line 67
    Service Module is trying to recover from error
    Service Module heartbeat-reset is enabled
    Service Module is in fail open
    Service Module status is not available
    No install/uninstall in progress
    Local Partition Info
    =====================
      Please reset module to retrieve
      partition information if needed
    EnergyWiseRouter#


    On ServicesEngine boot-loader>

    ServicesEngine boot-loader> ping 10.62.63.63 (module side of the interface)
    Sending 5, 32 byte ICMP Echos to 10.62.63.63:
    !!!!!
    Success rate is 100% (5/5)
    ServicesEngine boot-loader> ping 10.62.63.68 (router side of the interface)
    Sending 5, 32 byte ICMP Echos to 10.62.63.68:
    !!!!!
    Success rate is 100% (5/5)
    ServicesEngine boot-loader> ping 10.62.63.64 (ftp server)
    Sending 5, 32 byte ICMP Echos to 10.62.63.64:
    !!!!!
    Success rate is 100% (5/5)
    ServicesEngine boot-loader>
    Initializing memory. Please wait...
    Initializing memory. Please wait...
    Press DEL key to skip memory test63% of the system memory tested OK64% of
    the system memory tested OK65% of the system memory tested OK66% of the
    system memory tested OK67% of the system memory tested OK68% of the system
    memory tested OK69% of the system memory tested OK70% of the system memory
    tested OK71% of the system memory tested OK72% of the system memory tested
    OK73% of the system memory tested OK74% of the system memory tested OK75% of
    the system memory tested OK76% of the system memory tested OK77% of the
    system memory tested OK78% of the system memory tested OK79% of the system
    memory tested OK80% of the system memory tested OK81% of the system memory
    tested OK82% of the system memory tested OK83% of the system memory tested
    OK84% of the system memory tested OK85% of the system memory tested OK86% of
    the system memory tested OK87% of the system memory tested OK88% of the
    system memory tested OK89% of the system memory tested OK90% of the system
    memory tested OK91% of the system memory tested OK92% of the system memory
    tested OK93% of the system memory tested OK94% of the system memory tested
    OK95% of the system memory tested OK96% of the system memory tested OK97% of
    the system memory tested OK98% of the system memory tested OK99% of the
    system memory tested OK100% of the system memory tested OK4,290,379,776
    bytes of system memory tested OK
    Channel 0 Master : Hitachi HTE545050B9A300
    DDR Memory 4096 MB detected
    Intel(R) Genuine processor
    BIOS SM 1.2,  BIOS Build date: 08/04/2009
    System now booting...
    Please wait... 
    Please keyin P to select Primary Boot Loader ...
              or S to select Secondary Boot Loader ...
    If no any key stroke then will pick primary boot loader....
    ............................................................................
    ...........................
    Now booting from secondary boot loader....
    BIOS check for upgrade(CSCsx48564)  49 0
    Please enter '***' to change boot configuration:
    ServicesEngine Bootloader Version : eng_bld-eng
    ServicesEngine boot-loader>

    ServicesEngine boot-loader> config
    IP Address [10.62.63.63] >
    Subnet mask [255.255.255.128] >
    TFTP server [10.62.63.63] >
    Gateway [10.62.63.1] >
    NFS root directory [] >
    Default Helper-file [helper.sm] >
    Ethernet interface[external|internal]  >
    Debug Messages [enable|disable]  >
    Default Boot [none|disk|diag|chainloader]  >
    Default bootloader [primary|secondary]  >
    ServicesEngine boot-loader>

    When within ServicesEngine boot-loader> boot esxi

    I get following prompt


    And I can connetc to esxi on sre via vmware vspehere client




    jz

    Subject: RE: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Ashwin Venkatesan on 20-11-2010 01:34:06 AM
    Hi Josip,

    Couple of things.

    1)      Boot esxi is an invalid option . Looks like you are using an older version of the image.  ¿boot chainloader¿ is the valid boot option to use.

    2)      Default helper file is the helper file  used to install the software. If you want to edit the helpr file just type config and change the helper file name to the one which you want to use.  You will need to do this only if you are doing the boot helper method of install.

    3)      If you are doing an SRE install  then this will automatically be taken care during install. Please note the helper file needs to be in your FTP server for SRE install.

    Thanks,

    Ashwin

    Subject: Re: New Message from Ashwin Venkatesan in Service Ready Engine Virtualizati
    Replied by: Josip Zimet on 20-11-2010 01:34:06 AM
    Hi Ashwin, install from router goest through and unfortunately doesn't report any failure neither performs actual upgrade. Can you please help me to edit default helper ?  Rgds, jz

    Sent from my iPad

    Subject: RE: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Ashwin Venkatesan on 20-11-2010 01:34:06 AM
    Hi Josip,

    You should change the helper by using the config CLI in BL mode. A sample output from my blade is shown below.

    ServicesEngine boot-loade>config

    IP Address [10.50.80.125] >                                                   
    Subnet mask [255.255.0.0] >                                                   
    TFTP server [10.50.10.18] >                                                   
    Gateway [10.50.80.1] >                                                        
    Default Helper-file [sre-v-installer.smv.1.0.0.43] >   sre-v-installer.smv.1.0.0.44

    <<type the helper file you want to use. In your case I think it should be sre-v-installer.smv.1.0.0.35.

    If this does not work I would like to set up a webex session with you to see what's going on with this install. Please let me know if it is possible and  what you be a good time for you today?

    Thanks,

    Ashwin.

    Subject: Re: New Message from Ashwin Venkatesan in Service Ready Engine Virtualizati
    Replied by: Josip Zimet on 20-11-2010 01:34:13 AM
    Hi Ashwin,

    Your suggestion made some progress ... After I specified correct default
    helper

    ServicesEngine boot-loader> install_key sre-v-k9.smv.1.0.0.35.key
    Downloading sre-v-k9.smv.1.0.0.35.key
    Writing keyfile to flash Size 916
    writing complete.
    ServicesEngine boot-loader> boot helper
    nw_boot: 0 sre-v-installer.smv.1.0.0.35
    Loading tftp://192.168.11.64/sre-v-installer.smv.1.0.0.35 ... -

    I got  :

             Welcome to Cisco Systems Service Engine Helper Software
    Please select from the following
    1       Install software
    2       Reload module
    3       Disk cleanup
    4       Install License(s)
    5       Linux shell
    (Type '?' at any time for help)
    Choice:

    And linux shell

    bash-2.05b#

    bash-2.05b# ifconfig
    eth0      Link encap:Ethernet  HWaddr 88:43:E1:0A:9B:C1
              inet addr:10.62.63.63  Bcast:10.62.63.127  Mask:255.255.255.128
              inet6 addr: fe80::8a43:e1ff:fe0a:9bc1/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:30 errors:0 dropped:0 overruns:0 frame:0
              TX packets:81 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:2940 (2.8 Kb)  TX bytes:6823 (6.6 Kb)
              Interrupt:16 Memory:a0000000-a0012100

    Realized that I need to change ip address of my host (and use internal
    instead of external ethernet interface on sre) and with correct syntax
    upgrade started ...

    Choice: 1
    Package name: sre-v-k9.smv.1.0.0.35.pkg
    Server url: ftp://192.168.11.64
    Username: JosipZimet
    Password:
    Argument: /Desktop/sre/sre-v.beta.install-1.1.0.0.35/
    Downloading ftp sre-v-k9.smv.1.0.0.35.pkg
    Error: Download error
    Can not download sre-v-k9.smv.1.0.0.35.pkg
    error code 0 : error type 'couldn't connect to host'
    Unable to install. Please try again

    SYSTEM ONLINE
    se-10-62-63-63#

    And commands from beta Installation and Configuration Guide finally work

    se-10-62-63-63# show license feature
    Feature name        Enforcement   Evaluation  Clear Allowed  Enabled
    SRE-V-HOST-LIC      yes           yes         yes            no
    SRE-V-RMA-LIC       yes           no          yes            no

    se-10-62-63-63#


    Can you please tell me if Cisco Configuration Professional GUI will make it
    easier ?

    Since I cant ping 20.0.0.1 (mgf ip address) which is I assume esxi and I can
    ping 20.0.0.3 (vlan 1) can you please verify if this config is ok ?

    interface GigabitEthernet0/0
    ip address 10.62.63.68 255.255.255.128

    interface SM1/0
    ip unnumbered GigabitEthernet0/0
    service-module ip address 10.62.63.63 255.255.255.128
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.62.63.68
    service-module mgf ip address 20.0.0.1 255.255.255.0
    service-module mgf ip default-gateway 20.0.0.3

    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk
    !
    interface Vlan1
    ip address 20.0.0.3 255.255.255.0

    ip route 0.0.0.0 0.0.0.0 10.62.63.1
    ip route 1.10.10.3 255.255.255.255 SM1/0
    ip route 10.62.63.63 255.255.255.255 SM1/0
    ip route 20.0.0.1 255.255.255.255 SM1/0

    I assume something is missing on sre module ? Do I need to run config again
    and change ip address on sre ?

    se-10-62-63-63# sh ip route
    Main Routing Table:
               DEST            GATE            MASK IFACE
         10.62.63.0         0.0.0.0 255.255.255.128 eth0
        169.254.1.0         0.0.0.0   255.255.255.0 eth2
            0.0.0.0     10.62.63.68         0.0.0.0 eth0

    se-10-62-63-63#


    Regards,
    Josip Zimet

    Subject: Re: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Josip Zimet on 20-11-2010 01:34:13 AM
    Hi Ashwin,

    Changed ip route 20.0.0.1 255.255.255.255 SM1/0 to ip route 20.0.0.1
    255.255.255.255 vlan 1 for mgf interface and ping started to work ...

    Regards,
    jz

    Subject: Re: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Josip Zimet on 20-11-2010 01:34:14 AM
    Hi Ashwin,

    Can you please tell me what to do in orde to reach esxi form cisco
    corporate network ...

    Pc@144.254.241.227 can reach 10.62.63.68@e0/0 (sm 1/0 unnumerd) and can¿t
    reach 20.0.0.1@mgf and 20.0.0.3@van1


    interface GigabitEthernet0/0
    i address 10.62.63.68 255.255255.128

    interface SM1/0
    ip unnumbered GigabitEthernet0/0
    service-module ip address 10.62.63.63 255.255.255.128
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 10.62.63.68
    service-module mgf ip address 20.0.0.1 255.255.255.0
    service-module mgf ip default-gateway 20.0.0.3

    interface SM1/1
    switchport mode trunk
    !
    interface Vlan1
    ip address 20.0.0.3 255.255.255.0
    !       
    ip route 0.0.0.0 0.0.0.0 10.62.63.1
    ip route 10.62.63.63 255.255.255.255 SM1/0
    ip route 20.0.0.1 255.255.255.255 Vlan1


    EnergyWiseRouer#ping
    Protocol :
    Target IP address: 144.254.241.227
    Repeat count [5]: Datagram size [100]:
    Timeout in secons [2]:
    Extended commands  y
    Source address or interface: 20.0.0.3
    Type of service [0]:
    Set DF bit in IP header? :
    Validate reply data? :
    Data pattern [0xABCD]:
    Loose, Strict, Record, Timestamp, Verbose:
    Sweep range of sizes :
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 144.254.241.227, timeout is 2 seconds:
    Packet sent with a source address of 20.0.0.3
    .....
    Success rate is 0 percent (0/5)
    EnergyWiseRouter#


    Josip ZImet

    Subject: RE: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Ashwin Venkatesan on 20-11-2010 01:34:14 AM
    Hi Josip,

    1)      CCP support for SRE-V is currently not available. It is planned for the next release of CCP.

    2)      Can you provide the following outputs from your SRE-Vconsole manager)

    -          Show software versions

    -          Show hypervisor ip

    3)      Please let me know if you would like to have a webex session for this issue.

    Thanks,

    Ashwin

    Subject: Re: New Message from Ashwin Venkatesan in Service Ready Engine Virtualizati
    Replied by: Josip Zimet on 20-11-2010 01:34:15 AM
    Hi Ashwin,

    1. Can you please tell me what is CCP support ?

    2.
    se-10-62-63-63# show software versions
    Cisco SRE-V Software version 1.0.0.35)
    Technical Support: http://www.csco.com/techsupport Copyright (c) 1986-2010
    by Cisco Systems, Inc.

    se-10-62-63-63#

    se-10-62-63-63# show hypervisor ip
    Hostname:               localhost
    Domain Name:            None
    IP Config:              20.0.0.1(Subnet Mask 255.255.255.0)
                            19.254.1.1(Subnet Mask: 255.255.255.0)
    Default Gateway:        20.0.0.3
    Preferred DNS Server:   None
    Alternative DNS Server: None

    se-10-62-63-63#

    3. will assign ip address from 10.62.64.0 range and verify if it works ...

    Kind regards,
    Josip Zimet

    Subject: RE: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Ashwin Venkatesan on 20-11-2010 01:34:15 AM
    Hi Josip,

    That was a response in answer to your question 'Can you please tell me if Cisco Configuration Professional GUI will  make it easier ?'

    Currently the configuration of SRE-V using CCP is possible only in a future release.

    Ashwin

    Subject: Re: New Message from Ashwin Venkatesan in Service Ready Engine Virtualizati
    Replied by: Josip Zimet on 20-11-2010 01:34:15 AM
    i Ashwin,

    Connected pc 10.62.63.6 directly to router/default gateway 10.62.63.68 and
    manage to reach 10.62.64.1 esxi (finally) .

    Unfortunately cant login because servr name couldn¿t be resolved .. Not
    sure what esxi is asking me ... Any idea how to avoid this obstcle ?

    Kind regards,
    Josip Zimet

    Subject: RE: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Ashwin Venkatesan on 20-11-2010 01:34:16 AM
    What user name and password did you use to login ? Can you try user as esx-admin and password as change_it. Please paste a snapshot of the complete error if the login fails

    Also make sure you have licensing enabled . You can use eval license by using the CLI¿ license activate sreVHost¿ You will need to reload the blade for the license to take effect.

    Thanks,

    Ashwin

    Subject: Re: New Message from Ashwin Venkatesan in Service Ready Engine Virtualizati
    Replied by: Josip Zimet on 20-11-2010 01:34:18 AM
    Hi Ashwin,

    Can you please tell m how to deal with screen pop up which wans to
    retrieves client support file form vsphereclient.vmware.com ... This
    procedure doesn¿t go throgh ...

    Kind regards,
    Josip Zimet

    Subject: Re: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Josip Zimet on 20-11-2010 01:34:18 AM
    Hi Ashwin,

    imple nat provided connectiity from my desktop to esxi in lab ... Hope
    nat will not interfere with esxi on sre ?

    ip nat inside source static 10.62.64.1 10.62.63.62

    iterface GigabitEthernet0/0
    ip address 10.62.63.68 255.255.255.128
    ipnat outside

    interface SM1/0
    ip unnumbered GigabitEthernet0/0
    service-module ip address 10.62.63.63255.255.255.128
    service-module ip default-gateway 10.62.63.68
    service-module mgf i address 10.62.64.1 255.255.255.0
    service-module mgf ip default-gateway 10.62.64.2
    !
    interface SM1/1
    switchport mode trunk


    interface Vlan1
    ip address 10.62.64.2 255.255.255.0
    ip natinside


    Kind Reards,
    jz

    Subject: RE: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Ashwin Venkatesan on 20-11-2010 01:34:19 AM
    Can you paste the screen shot of the error ?

    Thanks

    Ashwin

    Subject: RE: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Ashwin Venkatesan on 20-11-2010 01:34:19 AM
    Hi Josip,

    It should not interfere. Can you explain to me the use case you are trying to do with nat on vlan 1?

    Thanks

    Ashwin

    Subject: RE: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Anurag Gurtu on 20-11-2010 01:34:19 AM
    It's ok to use NAT. However keep in mind that VMware doesn't officially support PAT (Port Address Translation) with vCenter, however it does work.

    Thanks,

    Anurag Gurtu, CISSP

    Subject: Re: New Message from Ashwin Venkatesan in Service Ready Engine Virtualizati
    Replied by: Josip Zimet on 20-11-2010 01:34:19 AM
    Hi Ashwin,

    Wanted to access from corporate or cvo wirelessor wireline network esx running on SRE-V withi G2 router which is in 10.62.63.0 ip etwork (globaly available within Cisco corporate and CVO .. Since internal SRE-V interfce can¿tbe on the same subnet as gi 0/0 (1.62.63.0) and I don't have additional Cisco globally available ip subnet (easy to get and difficut to find procedure to get it) I created myown 0.62.64.0 ip subnet address assign it to vlan1/mfg ... In order to reach esx from vsphere client nat helped (I assume bridging between vlan1/mfg/gi0/0 would help and didn't test). Since I'm using mac and vsphere client doesn¿ natively work on mac I used vsphere clien/Windows 7/Fusion ... And vsphere clien was not 4.1 ..
    Noticed that vphere was forced to uprade to 4.1 an for upgrade required internet connection to vmware.Now I do hae latest vspehere client hich can finally connet to esx on sre and  finally tested Orchestrator on esx in sre-v and next is to test Mediator on esx in srev.

    Kind regards,
    Josip Zimet

    Subject: Re: New Message from Josip Zimet in Service Ready Engine Virtualization - S
    Replied by: Josip Zimet on 20-11-2010 01:34:20 AM
    Dear alias members,

    I'm all set with ESX on SRE-V ... sharing configuration which do work for me
    ...

    interace GiabitEthernet0/0
    ip address 10.62.63.68 255.255.255.128
    ip nat outside
    !

    interfaceSM1/0
    ip unnumbered GigabitEthernet0/0
    service-module ip address 10.62.63.63 55.25.255.128
    service-module ip default-gateway 10.62.63.68
    service-module mgf ip address 10.62.64.1 255.255.255.0
    service-mdule mgf ip default-gateway 10.62.64.2

    interface SM1/1
    switchport mode trunk
    !
    interface Vlan1
    ip address 10.62.6.2 255.255.255.0
    ip nat inside
    !
    ip nat inside source static 10.62.64.5 10.62.63.59
    ip nat inside source static 10.62.64.1 10.62.63.62
    ip route 0.0.0.0 0.0.0.0 10.6.63.1
    ip route 10.62.63.3 255.255.255.255 SM1/0
    ip route 10.62.64.1 255.255.255.255 vlan1

    EnergyWiseRouter#srvice-module sm 1/ session
    Trying 10.2.63.68, 2067 ... Opn

    hypervisor set ip default-gateway 10.62.64.2

    s-1062-63-6# show hypervisor ip
    Hostname: localhot
    Domain Name: None
    IP Config: 10.62.64.1(ubnet Mask: 255.255.25.0)
    169.254.1.1(Subnet Mask 255.55.255.0)
    Default Gateway: 10.62.64.
    Preferred DNS Srver: None
    Alternativ DNS Server: None
    se-10-62-63-63#

    Kind Regards,
    Josp Zimet