virtual-machine export to ftp

Version 1
    This document was generated from CDN thread

    Created by: STEVEN BOLTON on 20-11-2010 01:34:02 AM
    The command does not appear to work with an FTP server that only allows authenticated logins.
     
    We tried the following:
    virtual-machine export ESXiSREServer ftp://sreuser:esxi@10.10.97.51/VMImges
    and received:
    virtual-machine export ESXiSREServer ftp://sreuser:esxi@10.10.97.51/VMImges 
                                                         ^
    % Invalid input detected at '^' marker.
     
     
    When the server was setup to allow anonymous and tried:
    virtual-machine export ESXiSREServer ftp://10.10.97.51/VMImges
    It worked.
     
    When will export to servers requiring authentication be supported or should it already?

    Subject: RE: New Message from STEVEN BOLTON in Service Ready Engine Virtualization -
    Replied by: Ashwin Venkatesan on 20-11-2010 01:34:03 AM
    Hi Steve,



    Please try the following CLI



    #virtual-machine export  <name-of-vm>  ftp://x.x.x.x/name username xxx password xxx



    For name of Vm, please use  CLI ¿show virtual-machine all¿



    x.x.x.x= Ip address of FTP server

    user=username of FTP server

    pass= password of User on FTP server





    Thanks,

    Ashwin



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Wednesday, September 29, 2010 3:17 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from STEVEN BOLTON in Service Ready Engine Virtualization - SRE-V Beta Testing: virtual-machine export to ftp



    STEVEN BOLTON has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------
    The command does not appear to work with an FTP server that only allows authenticated logins.

    We tried the following:
    virtual-machine export ESXiSREServer ftp://sreuser:esxi@10.10.97.51/VMImges
    and received:
    virtual-machine export ESXiSREServer ftp://sreuser:esxi@10.10.97.51/VMImges 
                                                         ^
    % Invalid input detected at '^' marker.


    When the server was setup to allow anonymous and tried:
    virtual-machine export ESXiSREServer ftp://10.10.97.51/VMImges
    It worked.

    When will export to servers requiring authentication be supported or should it already?

    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2587915>
    or simply reply to this email.

    Subject: RE: New Message from STEVEN BOLTON in Service Ready Engine Virtualization -
    Replied by: STEVEN BOLTON on 20-11-2010 01:34:03 AM
    Yep.  That is working.  I do not know why I did not type ? at the end of the command line to view the options.  Thanks